summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-11 12:10:04 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-11 12:10:04 +0100
commit2554bb3e44a296036bfb896a3fab1c9a5daec0fc (patch)
treee48c675908152f95d0ce233ee88f81f336d46493
parenta63b47779c94ed2a4a64558d3b4964c47cb1829a (diff)
Sync with rawhide:
- drop "Configure Command" from phpinfo output - prevent php_config.h changes across (otherwise identical) rebuilds
-rw-r--r--php-5.4.9-fixheader.patch23
-rw-r--r--php-5.4.9-phpinfo.patch27
-rw-r--r--php54.spec14
3 files changed, 63 insertions, 1 deletions
diff --git a/php-5.4.9-fixheader.patch b/php-5.4.9-fixheader.patch
new file mode 100644
index 0000000..f4e7db5
--- /dev/null
+++ b/php-5.4.9-fixheader.patch
@@ -0,0 +1,23 @@
+
+Make generated php_config.h constant across rebuilds.
+
+--- php-5.4.9/configure.in.fixheader
++++ php-5.4.9/configure.in
+@@ -1258,7 +1258,7 @@ fi
+ EXTRA_LDFLAGS="$EXTRA_LDFLAGS $PHP_LDFLAGS"
+ EXTRA_LDFLAGS_PROGRAM="$EXTRA_LDFLAGS_PROGRAM $PHP_LDFLAGS"
+
+-PHP_BUILD_DATE=`date '+%Y-%m-%d'`
++PHP_BUILD_DATE=`date '+%Y-%m-%d' -r $srcdir/NEWS`
+ AC_DEFINE_UNQUOTED(PHP_BUILD_DATE,"$PHP_BUILD_DATE",[PHP build date])
+
+ case $host_alias in
+@@ -1269,7 +1269,7 @@ case $host_alias in
+ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[hardcode for each of the cross compiler host])
+ ;;
+ *)
+- PHP_UNAME=`uname -a | xargs`
++ PHP_UNAME=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_UNAME,"$PHP_UNAME",[uname -a output])
+ PHP_OS=`uname | xargs`
+ AC_DEFINE_UNQUOTED(PHP_OS,"$PHP_OS",[uname output])
diff --git a/php-5.4.9-phpinfo.patch b/php-5.4.9-phpinfo.patch
new file mode 100644
index 0000000..b52a2f8
--- /dev/null
+++ b/php-5.4.9-phpinfo.patch
@@ -0,0 +1,27 @@
+
+Drop "Configure Command" from phpinfo as it doesn't
+provide any useful information.
+The available extensions are not related to this command.
+
+--- php-5.4.9/ext/standard/info.c.orig 2012-12-11 10:43:02.450578276 +0100
++++ php-5.4.9/ext/standard/info.c 2012-12-11 10:44:12.530820821 +0100
+@@ -704,9 +704,6 @@
+ #ifdef ARCHITECTURE
+ php_info_print_table_row(2, "Architecture", ARCHITECTURE);
+ #endif
+-#ifdef CONFIGURE_COMMAND
+- php_info_print_table_row(2, "Configure Command", CONFIGURE_COMMAND );
+-#endif
+
+ if (sapi_module.pretty_name) {
+ php_info_print_table_row(2, "Server API", sapi_module.pretty_name );
+--- php-5.4.9/ext/standard/tests/general_functions/phpinfo.phpt.orig 2012-12-11 11:07:26.959156091 +0100
++++ php-5.4.9/ext/standard/tests/general_functions/phpinfo.phpt 2012-12-11 11:07:30.899170970 +0100
+@@ -20,7 +20,6 @@
+
+ System => %s
+ Build Date => %s%a
+-Configure Command => %s
+ Server API => Command Line Interface
+ Virtual Directory Support => %s
+ Configuration File (php.ini) Path => %s
diff --git a/php54.spec b/php54.spec
index 8a259d9..9b7bd66 100644
--- a/php54.spec
+++ b/php54.spec
@@ -69,7 +69,7 @@ Version: 5.4.9
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.5.%{?snapdate}%{?rcver}%{?dist}
%else
-Release: 2%{?dist}
+Release: 3%{?dist}
%endif
# All files licensed under PHP version 3.01, except
# Zend is licensed under Zend
@@ -124,6 +124,10 @@ Patch43: php-5.4.0-phpize.patch
Patch44: php-5.4.5-system-libzip.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.4.8-ldap_r.patch
+# Make php_config.h constant across builds
+Patch46: php-5.4.9-fixheader.patch
+# drop "Configure command" from phpinfo output
+Patch47: php-5.4.9-phpinfo.patch
# Fixes for tests
@@ -781,6 +785,8 @@ rm -f ext/json/utf8_to_utf16.*
%if 0%{?fedora} >= 18 || 0%{?rhel} >= 7
%patch45 -p1 -b .ldap_r
%endif
+%patch46 -p1 -b .fixheader
+%patch47 -p1 -b .phpinfo
%patch91 -p1 -b .remi-oci8
@@ -1619,6 +1625,12 @@ fi
%changelog
+* Tue Dec 11 2012 Remi Collet <rcollet@redhat.com> 5.4.9-3
+- drop "Configure Command" from phpinfo output
+
+* Tue Dec 11 2012 Joe Orton <jorton@redhat.com> - 5.4.9-2
+- prevent php_config.h changes across (otherwise identical) rebuilds
+
* Fri Nov 23 2012 Remi Collet <remi@fedoraproject.org> 5.4.9-2
- add patch for https://bugs.php.net/63588
duplicated implementation of php_next_utf8_char