summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-05-09 07:37:34 +0200
committerRemi Collet <fedora@famillecollet.com>2013-05-09 07:37:34 +0200
commit1e115e3158e2b8cc7b84e47f8bb98b5262c02db6 (patch)
tree6d68996a44d389c0cc73bb486fc48cbdc9d43458
parentbd17113825af2d76b1f3d904f80c439ad02463bf (diff)
php 5.4.15
-rw-r--r--php-5.4.15-system-libzip.patch (renamed from php-5.4.5-system-libzip.patch)75
-rw-r--r--php54.spec27
2 files changed, 49 insertions, 53 deletions
diff --git a/php-5.4.5-system-libzip.patch b/php-5.4.15-system-libzip.patch
index 897fb87..7e8642b 100644
--- a/php-5.4.5-system-libzip.patch
+++ b/php-5.4.15-system-libzip.patch
@@ -1,22 +1,14 @@
-diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
---- php-5.4.5RC1/ext/zip/config.m4.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/config.m4 2012-07-07 15:56:41.418171233 +0200
-@@ -13,65 +13,116 @@
+diff -up php-5.4.15/ext/zip/config.m4.systzip php-5.4.15/ext/zip/config.m4
+--- php-5.4.15/ext/zip/config.m4.systzip 2013-05-08 07:41:20.000000000 +0200
++++ php-5.4.15/ext/zip/config.m4 2013-05-09 06:46:26.084673644 +0200
+@@ -13,65 +13,116 @@ fi
PHP_ARG_WITH(pcre-dir, pcre install prefix,
[ --with-pcre-dir ZIP: pcre install prefix], no, no)
--if test "$PHP_ZIP" != "no"; then
+PHP_ARG_WITH(libzip, libzip,
+[ --with-libzip[=DIR] ZIP: use libzip], no, no)
-
-- if test "$PHP_ZLIB_DIR" != "no" && test "$PHP_ZLIB_DIR" != "yes"; then
-- if test -f "$PHP_ZLIB_DIR/include/zlib/zlib.h"; then
-- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
-- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include/zlib"
-- elif test -f "$PHP_ZLIB_DIR/include/zlib.h"; then
-- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
-- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include"
-+if test "$PHP_ZIP" != "no"; then
++
+ if test "$PHP_ZIP" != "no"; then
+ if test "$PHP_LIBZIP" != "no"; then
+
+ AC_PATH_PROG(PKG_CONFIG, pkg-config, no)
@@ -32,7 +24,14 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
+ LIBZIP_CFLAGS=`$PKG_CONFIG libzip --cflags`
+ LIBZIP_LIBDIR=`$PKG_CONFIG libzip --variable=libdir`
+ AC_MSG_RESULT(from pkgconfig: found in $LIBZIP_LIBDIR)
-+
+
+- if test "$PHP_ZLIB_DIR" != "no" && test "$PHP_ZLIB_DIR" != "yes"; then
+- if test -f "$PHP_ZLIB_DIR/include/zlib/zlib.h"; then
+- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
+- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include/zlib"
+- elif test -f "$PHP_ZLIB_DIR/include/zlib.h"; then
+- PHP_ZLIB_DIR="$PHP_ZLIB_DIR"
+- PHP_ZLIB_INCDIR="$PHP_ZLIB_DIR/include"
else
- AC_MSG_ERROR([Can not find zlib headers under "$PHP_ZLIB_DIR"])
+ for i in /usr/local /usr; do
@@ -43,12 +42,12 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
+ break
+ fi
+ done
-+ fi
+ fi
+
+ if test -z "$LIBZIP_LIBDIR"; then
+ AC_MSG_RESULT(not found)
+ AC_MSG_ERROR(Please reinstall the libzip distribution)
- fi
++ fi
+
+ dnl Could not think of a simple way to check libzip for overwrite support
+ PHP_CHECK_LIBRARY(zip, zip_open,
@@ -160,7 +159,7 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
lib/zip_fread.c lib/zip_open.c lib/zip_source_filep.c \
lib/zip_strerror.c lib/zip_close.c lib/zip_error_get.c \
lib/zip_file_error_get.c lib/zip_free.c lib/zip_rename.c \
-@@ -98,10 +149,11 @@
+@@ -98,10 +149,11 @@ yes
lib/zip_source_open.c lib/zip_source_pkware.c lib/zip_source_pop.c \
lib/zip_source_read.c lib/zip_source_stat.c"
@@ -176,12 +175,12 @@ diff -up php-5.4.5RC1/ext/zip/config.m4.systzip php-5.4.5RC1/ext/zip/config.m4
dnl so we always include the known-good working hack.
PHP_ADD_MAKEFILE_FRAGMENT
-diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
---- php-5.4.5RC1/ext/zip/php_zip.c.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/php_zip.c 2012-07-07 15:59:12.728676026 +0200
-@@ -29,8 +29,232 @@
- #include "ext/standard/php_string.h"
+diff -up php-5.4.15/ext/zip/php_zip.c.systzip php-5.4.15/ext/zip/php_zip.c
+--- php-5.4.15/ext/zip/php_zip.c.systzip 2013-05-08 07:41:20.000000000 +0200
++++ php-5.4.15/ext/zip/php_zip.c 2013-05-09 06:50:33.286058049 +0200
+@@ -30,8 +30,232 @@
#include "ext/pcre/php_pcre.h"
+ #include "ext/standard/php_filestat.h"
#include "php_zip.h"
+#if defined(HAVE_LIBZIP)
+#include <zip.h>
@@ -412,7 +411,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
/* zip_open is a macro for renaming libzip zipopen, so we need to use PHP_NAMED_FUNCTION */
static PHP_NAMED_FUNCTION(zif_zip_open);
-@@ -1624,6 +1848,10 @@ static ZIPARCHIVE_METHOD(addEmptyDir)
+@@ -1631,6 +1855,10 @@ static ZIPARCHIVE_METHOD(addEmptyDir)
}
idx = zip_stat(intern, s, 0, &sb);
@@ -423,7 +422,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
if (idx >= 0) {
RETVAL_FALSE;
} else {
-@@ -1846,6 +2074,10 @@ static ZIPARCHIVE_METHOD(addFromString)
+@@ -1853,6 +2081,10 @@ static ZIPARCHIVE_METHOD(addFromString)
}
cur_idx = zip_name_locate(intern, (const char *)name, 0);
@@ -434,7 +433,7 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
/* TODO: fix _zip_replace */
if (cur_idx >= 0) {
if (zip_delete(intern, cur_idx) == -1) {
-@@ -2870,5 +3098,9 @@ static PHP_MINFO_FUNCTION(zip)
+@@ -2877,5 +3109,9 @@ static PHP_MINFO_FUNCTION(zip)
php_info_print_table_row(2, "Zip version", PHP_ZIP_VERSION_STRING);
- php_info_print_table_row(2, "Libzip version", LIBZIP_VERSION);
+#if defined(HAVE_LIBZIP)
@@ -445,9 +444,9 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.c.systzip php-5.4.5RC1/ext/zip/php_zip.c
php_info_print_table_end();
}
-diff -up php-5.4.5RC1/ext/zip/php_zip.h.systzip php-5.4.5RC1/ext/zip/php_zip.h
---- php-5.4.5RC1/ext/zip/php_zip.h.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/php_zip.h 2012-07-07 15:57:34.845319432 +0200
+diff -up php-5.4.15/ext/zip/php_zip.h.systzip php-5.4.15/ext/zip/php_zip.h
+--- php-5.4.15/ext/zip/php_zip.h.systzip 2013-05-08 07:41:20.000000000 +0200
++++ php-5.4.15/ext/zip/php_zip.h 2013-05-09 06:46:26.086673656 +0200
@@ -28,7 +28,11 @@ extern zend_module_entry zip_module_entr
#include "TSRM.h"
#endif
@@ -460,9 +459,9 @@ diff -up php-5.4.5RC1/ext/zip/php_zip.h.systzip php-5.4.5RC1/ext/zip/php_zip.h
#define PHP_ZIP_VERSION_STRING "1.11.0"
-diff -up php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip php-5.4.5RC1/ext/zip/tests/bug38943.phpt
---- php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/tests/bug38943.phpt 2012-07-07 15:56:41.422171242 +0200
+diff -up php-5.4.15/ext/zip/tests/bug38943.phpt.systzip php-5.4.15/ext/zip/tests/bug38943.phpt
+--- php-5.4.15/ext/zip/tests/bug38943.phpt.systzip 2013-05-08 07:41:20.000000000 +0200
++++ php-5.4.15/ext/zip/tests/bug38943.phpt 2013-05-09 06:46:26.088673667 +0200
@@ -27,7 +27,7 @@ array(1) {
[0]=>
int(1)
@@ -472,9 +471,9 @@ diff -up php-5.4.5RC1/ext/zip/tests/bug38943.phpt.systzip php-5.4.5RC1/ext/zip/t
["test":"myZip":private]=>
int(0)
["testp"]=>
-diff -up php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip php-5.4.5RC1/ext/zip/tests/pecl12414.phpt
---- php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/tests/pecl12414.phpt 2012-07-07 15:56:41.422171242 +0200
+diff -up php-5.4.15/ext/zip/tests/pecl12414.phpt.systzip php-5.4.15/ext/zip/tests/pecl12414.phpt
+--- php-5.4.15/ext/zip/tests/pecl12414.phpt.systzip 2013-05-08 07:41:20.000000000 +0200
++++ php-5.4.15/ext/zip/tests/pecl12414.phpt 2013-05-09 06:46:26.088673667 +0200
@@ -5,6 +5,8 @@ Bug #12414 ( extracting files from damag
/*$ */
if(!extension_loaded('zip')) die('skip');
@@ -484,9 +483,9 @@ diff -up php-5.4.5RC1/ext/zip/tests/pecl12414.phpt.systzip php-5.4.5RC1/ext/zip/
--FILE--
<?php
$filename = 'MYLOGOV2.GFX';
-diff -up php-5.4.5RC1/ext/zip/zip_stream.c.systzip php-5.4.5RC1/ext/zip/zip_stream.c
---- php-5.4.5RC1/ext/zip/zip_stream.c.systzip 2012-07-04 07:43:14.000000000 +0200
-+++ php-5.4.5RC1/ext/zip/zip_stream.c 2012-07-07 15:56:41.423171244 +0200
+diff -up php-5.4.15/ext/zip/zip_stream.c.systzip php-5.4.15/ext/zip/zip_stream.c
+--- php-5.4.15/ext/zip/zip_stream.c.systzip 2013-05-08 07:41:20.000000000 +0200
++++ php-5.4.15/ext/zip/zip_stream.c 2013-05-09 06:46:26.088673667 +0200
@@ -6,7 +6,11 @@
#if HAVE_ZIP
#ifdef ZEND_ENGINE_2
diff --git a/php54.spec b/php54.spec
index 1abb1e8..ee8e33c 100644
--- a/php54.spec
+++ b/php54.spec
@@ -65,7 +65,7 @@
Summary: PHP scripting language for creating dynamic web sites
Name: php
-Version: 5.4.14
+Version: 5.4.15
%if 0%{?snapdate:1}%{?rcver:1}
Release: 0.5.%{?snapdate}%{?rcver}%{?dist}
%else
@@ -111,7 +111,7 @@ Patch42: php-5.3.1-systzdata-v10.patch
# See http://bugs.php.net/53436
Patch43: php-5.4.0-phpize.patch
# Use system libzip instead of bundled one
-Patch44: php-5.4.5-system-libzip.patch
+Patch44: php-5.4.15-system-libzip.patch
# Use -lldap_r for OpenLDAP
Patch45: php-5.4.8-ldap_r.patch
# Make php_config.h constant across builds
@@ -146,7 +146,6 @@ BuildRequires: libtool-ltdl-devel
BuildRequires: libzip-devel >= 0.10
%endif
-Obsoletes: php-dbg, php3, phpfi, stronghold-php, php-zts < 5.3.7
Obsoletes: php53, php53u, php54
Provides: php-zts = %{version}-%{release}
Provides: php-zts%{?_isa} = %{version}-%{release}
@@ -276,10 +275,12 @@ Provides: php-tokenizer, php-tokenizer%{?_isa}
Provides: php-zip, php-zip%{?_isa}
Provides: php-pecl-zip = %{zipver}, php-pecl-zip%{?_isa} = %{zipver}
Provides: php-pecl(zip) = %{zipver}, php-pecl(zip)%{?_isa} = %{zipver}
-Obsoletes: php-pecl-zip
+Obsoletes: php-pecl-zip < 1.11
%endif
Provides: php-zlib, php-zlib%{?_isa}
-Obsoletes: php-openssl, php-pecl-json, php-json, php-pecl-phar, php-pecl-Fileinfo
+Obsoletes: php-pecl-json < 1.2.2
+Obsoletes: php-pecl-phar < 1.2.4
+Obsoletes: php-pecl-Fileinfo < 1.0.5
Obsoletes: php-mhash < 5.3.0
Obsoletes: php53-mhash, php53u-mhash
Obsoletes: php53-common, php53u-common, php54-common
@@ -295,7 +296,6 @@ Requires: php-cli%{?_isa} = %{version}-%{release}, autoconf, automake
%if 0%{?fedora} >= 14 || 0%{?rhel} >= 7
Requires: pcre-devel%{?_isa}
%endif
-Obsoletes: php-pecl-pdo-devel
Provides: php-zts-devel = %{version}-%{release}
Provides: php-zts-devel%{?_isa} = %{version}-%{release}
Obsoletes: php53-devel, php53u-devel, php54-devel
@@ -311,7 +311,6 @@ Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-Obsoletes: mod_php3-imap, stronghold-php-imap
BuildRequires: krb5-devel, openssl-devel, libc-client-devel
Obsoletes: php53-imap, php53u-imap, php54-imap
@@ -330,7 +329,6 @@ Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-Obsoletes: mod_php3-ldap, stronghold-php-ldap
BuildRequires: cyrus-sasl-devel, openldap-devel, openssl-devel
Obsoletes: php53-ldap, php53u-ldap, php54-ldap
@@ -348,7 +346,6 @@ Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-Obsoletes: php-pecl-pdo-sqlite, php-pecl-pdo
# ABI/API check - Arch specific
Provides: php-pdo-abi = %{pdover}%{isasuffix}
Provides: php-sqlite3, php-sqlite3%{?_isa}
@@ -371,7 +368,6 @@ Provides: php_database
Provides: php-mysqli = %{version}-%{release}
Provides: php-mysqli%{?_isa} = %{version}-%{release}
Provides: php-pdo_mysql, php-pdo_mysql%{?_isa}
-Obsoletes: mod_php3-mysql, stronghold-php-mysql
BuildRequires: mysql-devel >= 4.1.0
Conflicts: php-mysqlnd
Obsoletes: php53-mysql, php53u-mysql, php54-mysql
@@ -414,7 +410,6 @@ License: PHP
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_pgsql, php-pdo_pgsql%{?_isa}
-Obsoletes: mod_php3-pgsql, stronghold-php-pgsql
BuildRequires: krb5-devel, openssl-devel, postgresql-devel
Obsoletes: php53-pgsql, php53u-pgsql, php54-pgsql
@@ -453,7 +448,6 @@ License: PHP
Requires: php-pdo%{?_isa} = %{version}-%{release}
Provides: php_database
Provides: php-pdo_odbc, php-pdo_odbc%{?_isa}
-Obsoletes: stronghold-php-odbc
BuildRequires: unixODBC-devel
Obsoletes: php53-odbc, php53u-odbc, php54-odbc
@@ -546,7 +540,6 @@ Group: Development/Languages
# All files licensed under PHP version 3.01
License: PHP
Requires: php-common%{?_isa} = %{version}-%{release}
-Obsoletes: php-domxml, php-dom
Provides: php-dom, php-dom%{?_isa}
Provides: php-xsl, php-xsl%{?_isa}
Provides: php-domxml, php-domxml%{?_isa}
@@ -761,7 +754,7 @@ rm -f ext/json/utf8_to_utf16.*
%patch40 -p1 -b .dlopen
%patch41 -p1 -b .easter
-%if 0%{?fedora} >= 16 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 17 || 0%{?rhel} >= 5
%patch42 -p1 -b .systzdata
%endif
%patch43 -p1 -b .headers
@@ -955,7 +948,7 @@ ln -sf ../configure
--enable-calendar \
--with-libxml-dir=%{_prefix} \
--enable-xml \
-%if 0%{?fedora} >= 16 || 0%{?rhel} >= 5
+%if 0%{?fedora} >= 17 || 0%{?rhel} >= 5
--with-system-tzdata \
%endif
--with-mhash \
@@ -1610,6 +1603,10 @@ fi
%changelog
+* Thu May 9 2013 Remi Collet <rcollet@redhat.com> 5.4.15-1
+- update to 5.4.15
+- clean very old obsoletes
+
* Thu Apr 11 2013 Remi Collet <rcollet@redhat.com> 5.4.14-1
- update to 5.4.14
- clean old deprecated options