summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-5.4.16-mcrypt.patch40
-rw-r--r--php-extras.spec10
2 files changed, 5 insertions, 45 deletions
diff --git a/php-5.4.16-mcrypt.patch b/php-5.4.16-mcrypt.patch
deleted file mode 100644
index 3158c70..0000000
--- a/php-5.4.16-mcrypt.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-From dd791cd71742fdb9b87b7166537fbb25bd7cd8b9 Mon Sep 17 00:00:00 2001
-From: Dmitry Stogov <dmitry@zend.com>
-Date: Mon, 8 Dec 2014 12:18:27 +0300
-Subject: [PATCH] Fixed possible read after end of buffer and use after free.
-
----
- ext/mcrypt/mcrypt.c | 8 ++++++--
- 1 file changed, 6 insertions(+), 2 deletions(-)
-
-diff --git a/ext/mcrypt/mcrypt.c b/ext/mcrypt/mcrypt.c
-index 55302c7..7f463cf 100644
---- a/ext/mcrypt/mcrypt.c
-+++ b/ext/mcrypt/mcrypt.c
-@@ -619,8 +619,11 @@ PHP_FUNCTION(mcrypt_generic_init)
-
- if (iv_len != iv_size) {
- php_error_docref(NULL TSRMLS_CC, E_WARNING, "Iv size incorrect; supplied length: %d, needed: %d", iv_len, iv_size);
-+ if (iv_len > iv_size) {
-+ iv_len = iv_size;
-+ }
- }
-- memcpy(iv_s, iv, iv_size);
-+ memcpy(iv_s, iv, iv_len);
-
- mcrypt_generic_deinit(pm->td);
- result = mcrypt_generic_init(pm->td, key_s, key_size, iv_s);
-@@ -641,8 +644,9 @@ PHP_FUNCTION(mcrypt_generic_init)
- php_error_docref(NULL TSRMLS_CC, E_WARNING, "Unknown error");
- break;
- }
-+ } else {
-+ pm->init = 1;
- }
-- pm->init = 1;
- RETVAL_LONG(result);
-
- efree(iv_s);
---
-2.1.4
-
diff --git a/php-extras.spec b/php-extras.spec
index a2f12a1..af0c533 100644
--- a/php-extras.spec
+++ b/php-extras.spec
@@ -28,15 +28,14 @@
Name: %{?scl_prefix}php-extras
Summary: Additional PHP modules from the standard PHP distribution
-Version: 5.4.16
-Release: 6%{?dist}
+Version: 5.4.40
+Release: 1%{?dist}
Group: Development/Languages
License: The PHP License
URL: http://www.php.net/
Source0: http://www.php.net/distributions/php-%{version}.tar.bz2
# Security patches
-Patch0: php-5.4.16-mcrypt.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel >= 5.4
@@ -158,8 +157,6 @@ add support for using the enchant library to PHP.
%prep
%setup -q -n php-%{version}
-%patch0 -p1 -b .security
-
# avoid tests which requires databases
rm -rf ext/{mssql,pdo_dblib,interbase,pdo_firebird}/tests
@@ -247,6 +244,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Jun 11 2015 Remi Collet <rcollet@redhat.com> - 5.4.40-1
+- update to 5.4.40 (rhscl-2.0)
+
* Fri Feb 13 2015 Remi Collet <rcollet@redhat.com> - 5.4.16-6
- mcrypt upstream security fix