summaryrefslogtreecommitdiffstats
path: root/php-5.3.11-gnusrc.patch
diff options
context:
space:
mode:
Diffstat (limited to 'php-5.3.11-gnusrc.patch')
-rw-r--r--php-5.3.11-gnusrc.patch115
1 files changed, 115 insertions, 0 deletions
diff --git a/php-5.3.11-gnusrc.patch b/php-5.3.11-gnusrc.patch
new file mode 100644
index 0000000..13a4626
--- /dev/null
+++ b/php-5.3.11-gnusrc.patch
@@ -0,0 +1,115 @@
+diff -up php-5.3.11/configure.in.gnusrc php-5.3.11/configure.in
+--- php-5.3.11/configure.in.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/configure.in 2012-04-27 16:17:29.399074435 +0200
+@@ -58,6 +58,8 @@ AC_DEFUN([PHP_EXT_DIR],[ext/$1])dnl
+ AC_DEFUN([PHP_EXT_SRCDIR],[$abs_srcdir/ext/$1])dnl
+ AC_DEFUN([PHP_ALWAYS_SHARED],[])dnl
+
++AC_DEFINE([_GNU_SOURCE], 1, [Define to enable GNU C Library extensions])
++
+ dnl Setting up the PHP version based on the information above.
+ dnl -------------------------------------------------------------------------
+
+diff -up php-5.3.11/ext/interbase/interbase.c.gnusrc php-5.3.11/ext/interbase/interbase.c
+--- php-5.3.11/ext/interbase/interbase.c.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/ext/interbase/interbase.c 2012-04-27 16:17:29.399074435 +0200
+@@ -24,7 +24,6 @@
+ #include "config.h"
+ #endif
+
+-#define _GNU_SOURCE
+
+ #include "php.h"
+
+diff -up php-5.3.11/ext/pdo_firebird/firebird_driver.c.gnusrc php-5.3.11/ext/pdo_firebird/firebird_driver.c
+--- php-5.3.11/ext/pdo_firebird/firebird_driver.c.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/ext/pdo_firebird/firebird_driver.c 2012-04-27 16:17:29.400074435 +0200
+@@ -22,7 +22,6 @@
+ #include "config.h"
+ #endif
+
+-#define _GNU_SOURCE
+
+ #include "php.h"
+ #ifdef ZEND_ENGINE_2
+diff -up php-5.3.11/ext/standard/file.c.gnusrc php-5.3.11/ext/standard/file.c
+--- php-5.3.11/ext/standard/file.c.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/ext/standard/file.c 2012-04-27 16:17:29.401074435 +0200
+@@ -113,9 +113,6 @@ php_file_globals file_globals;
+ #endif
+
+ #if defined(HAVE_FNMATCH) && !defined(PHP_WIN32)
+-# ifndef _GNU_SOURCE
+-# define _GNU_SOURCE
+-# endif
+ # include <fnmatch.h>
+ #endif
+
+diff -up php-5.3.11/ext/zlib/zlib_fopen_wrapper.c.gnusrc php-5.3.11/ext/zlib/zlib_fopen_wrapper.c
+--- php-5.3.11/ext/zlib/zlib_fopen_wrapper.c.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/ext/zlib/zlib_fopen_wrapper.c 2012-04-27 16:18:10.230075414 +0200
+@@ -19,8 +19,6 @@
+
+ /* $Id$ */
+
+-#define _GNU_SOURCE
+-
+ #include "php.h"
+ #include "php_zlib.h"
+ #include "fopen_wrappers.h"
+diff -up php-5.3.11/main/php.h.gnusrc php-5.3.11/main/php.h
+--- php-5.3.11/main/php.h.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/main/php.h 2012-04-27 16:17:29.402074435 +0200
+@@ -30,6 +30,7 @@
+ #define PHP_HAVE_STREAMS
+ #define YYDEBUG 0
+
++#include "php_config.h"
+ #include "php_version.h"
+ #include "zend.h"
+ #include "zend_qsort.h"
+diff -up php-5.3.11/main/streams/cast.c.gnusrc php-5.3.11/main/streams/cast.c
+--- php-5.3.11/main/streams/cast.c.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/main/streams/cast.c 2012-04-27 16:18:39.614076117 +0200
+@@ -18,7 +18,6 @@
+
+ /* $Id$ */
+
+-#define _GNU_SOURCE
+ #include "php.h"
+ #include "php_globals.h"
+ #include "php_network.h"
+diff -up php-5.3.11/main/streams/memory.c.gnusrc php-5.3.11/main/streams/memory.c
+--- php-5.3.11/main/streams/memory.c.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/main/streams/memory.c 2012-04-27 16:19:10.417076852 +0200
+@@ -18,7 +18,6 @@
+
+ /* $Id$ */
+
+-#define _GNU_SOURCE
+ #include "php.h"
+
+ PHPAPI int php_url_decode(char *str, int len);
+diff -up php-5.3.11/main/streams/streams.c.gnusrc php-5.3.11/main/streams/streams.c
+--- php-5.3.11/main/streams/streams.c.gnusrc 2012-04-25 00:13:15.000000000 +0200
++++ php-5.3.11/main/streams/streams.c 2012-04-27 16:19:27.774077269 +0200
+@@ -21,7 +21,6 @@
+
+ /* $Id$ */
+
+-#define _GNU_SOURCE
+ #include "php.h"
+ #include "php_globals.h"
+ #include "php_network.h"
+diff -up php-5.3.11/Zend/zend_language_parser.c.gnusrc php-5.3.11/Zend/zend_language_parser.c
+--- php-5.3.11/Zend/zend_language_parser.c.gnusrc 2012-04-25 00:26:10.000000000 +0200
++++ php-5.3.11/Zend/zend_language_parser.c 2012-04-27 16:17:29.405074435 +0200
+@@ -112,6 +112,8 @@
+ #include "zend_API.h"
+ #include "zend_constants.h"
+
++#include <string.h>
++
+
+ #define YYERROR_VERBOSE
+ #define YYSTYPE znode