summaryrefslogtreecommitdiffstats
path: root/php-zstd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zstd.spec')
-rw-r--r--php-zstd.spec18
1 files changed, 11 insertions, 7 deletions
diff --git a/php-zstd.spec b/php-zstd.spec
index 2af661f..4d18d72 100644
--- a/php-zstd.spec
+++ b/php-zstd.spec
@@ -77,7 +77,7 @@ These are the files needed to compile programs using %{name}.
%prep
%setup -qc
-%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml
cd %{sources}
%if %{with libzstd}
@@ -113,6 +113,8 @@ EOF
cd %{sources}
%{__phpize}
+[ -f Makefile.global ] && GLOBAL=Makefile.global || GLOBAL=build/Makefile.global
+sed -e 's/INSTALL_ROOT/DESTDIR/' -i $GLOBAL
cd ../NTS
%configure \
@@ -122,7 +124,8 @@ cd ../NTS
%endif
--with-libdir=%{_lib} \
--enable-zstd
-make %{?_smp_mflags}
+
+%make_build
%if %{with_zts}
cd ../ZTS
@@ -133,7 +136,8 @@ cd ../ZTS
%endif
--with-libdir=%{_lib} \
--enable-zstd
-make %{?_smp_mflags}
+
+%make_build
%endif
@@ -141,7 +145,7 @@ make %{?_smp_mflags}
%{?dtsenable}
# Install the NTS stuff
-make -C NTS install INSTALL_ROOT=%{buildroot}
+%make_install -C NTS
install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
# Install XML package description
@@ -149,7 +153,7 @@ install -D -m 644 package.xml %{buildroot}%{pecl_xmldir}/%{name}.xml
%if %{with_zts}
# Install the ZTS stuff
-make -C ZTS install INSTALL_ROOT=%{buildroot}
+%make_install -C ZTS
install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
@@ -213,11 +217,11 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%files
-%{?_licensedir:%license %{sources}/LICENSE}
+%license %{sources}/LICENSE
%doc %{pecl_docdir}/%{pecl_name}
%{pecl_xmldir}/%{name}.xml
%if ! %{with libzstd}
-%{?_licensedir:%license %{sources}/LICENSE-libzstd}
+%license %{sources}/LICENSE-libzstd
%endif
%config(noreplace) %{php_inidir}/%{ini_name}