summaryrefslogtreecommitdiffstats
path: root/php-zstd.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-zstd.spec')
-rw-r--r--php-zstd.spec249
1 files changed, 249 insertions, 0 deletions
diff --git a/php-zstd.spec b/php-zstd.spec
new file mode 100644
index 0000000..8a88b43
--- /dev/null
+++ b/php-zstd.spec
@@ -0,0 +1,249 @@
+# remirepo spec file for php-zstd
+#
+# Copyright (c) 2018 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-zstd
+%else
+%global pkg_name %{name}
+%endif
+
+%if 0%{?fedora} >= 24 || 0%{?rhel} >= 6
+%global with_libzstd 1
+%else
+%global with_libzstd 0
+%endif
+
+
+%global gh_commit 8ca4cf45c200bcfa80469703d2f3a2ab46918a45
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner kjdev
+%global gh_project php-ext-zstd
+#global gh_date 20160608
+%global pecl_name zstd
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: Zstd Extension for PHP
+Name: %{?sub_prefix}php-%{pecl_name}
+Version: 0.4.11
+%if 0%{?gh_date:1}
+Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%endif
+%if %{?with_libzstd}
+License: MIT
+%else
+# bundled library is BSD
+License: MIT and BSD
+%endif
+Group: Development/Languages
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
+# retrieve a recursive git snapshot with submodule
+Source1: makesrc.sh
+
+# https://github.com/kjdev/php-ext-zstd/pull/7
+Patch0: https://patch-diff.githubusercontent.com/raw/kjdev/php-ext-zstd/pull/7.patch
+
+BuildRequires: %{?scl_prefix}php-devel
+%if %{?with_libzstd}
+BuildRequires: libzstd-devel >= 1.3
+%else
+Provides: bundled(libstd) = 1.3.1
+%endif
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-%{pecl_name} <= %{version}
+Obsoletes: php56w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-%{pecl_name} <= %{version}
+Obsoletes: php70w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-%{pecl_name} <= %{version}
+Obsoletes: php71w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-%{pecl_name} <= %{version}
+Obsoletes: php72w-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension allows Zstd compression.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%package devel
+Summary: %{name} developer files (header)
+Group: Development/Libraries
+Requires: %{name}%{?_isa} = %{version}-%{release}
+Requires: %{?scl_prefix}php-devel%{?_isa}
+Provides: %{?scl_prefix}php-%{pecl_name}-devel = %{version}-%{release}
+Provides: %{?scl_prefix}php-%{pecl_name}-devel%{?_isa} = %{version}-%{release}
+
+%description devel
+These are the files needed to compile programs using %{name}.
+
+
+%prep
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+
+cd NTS
+%patch0 -p1
+
+# replace symlink
+rm LICENSE-zstd
+mv zstd/LICENSE LICENSE-zstd
+
+%if %{?with_libzstd}
+# Use the system library
+rm -r zstd
+%endif
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_ZSTD_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_zstd.h)
+if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Drop in the bit of configuration
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension = %{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config \
+%if %{?with_libzstd}
+ --with-libzstd \
+%endif
+ --with-libdir=%{_lib} \
+ --enable-zstd
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config \
+%if %{?with_libzstd}
+ --with-libzstd \
+%endif
+ --with-libdir=%{_lib} \
+ --enable-zstd
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff || : ignore
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license NTS/LICENSE
+%if ! %{?with_libzstd}
+%license NTS/LICENSE-zstd
+%endif
+%doc NTS/README.md
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%files devel
+%doc NTS/tests
+%{php_incldir}/ext/%{pecl_name}
+
+%if %{with_zts}
+%{php_ztsincldir}/ext/%{pecl_name}
+%endif
+
+
+%changelog
+* Tue Jan 30 2018 Remi Collet <remi@remirepo.net> - 0.4.11-1
+- new package, version 0.4.11
+- add patch to build with system libzstd from
+ https://github.com/kjdev/php-ext-zstd/pull/7