summaryrefslogtreecommitdiffstats
path: root/php-zstd.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-28 08:24:40 +0200
committerRemi Collet <remi@php.net>2023-04-28 08:24:40 +0200
commitd822908a13b7ea9e6da33d7324600ae1f2b29fd2 (patch)
treef34fd229261a6f7df8aa6985c2f97bd3fd4bb9eb /php-zstd.spec
parent9f3ae057224ab6a1f0268b28ff2a24814cfba8c7 (diff)
update to 0.12.2
fix extension version and build warnings, using patch from https://github.com/kjdev/php-ext-zstd/pull/57
Diffstat (limited to 'php-zstd.spec')
-rw-r--r--php-zstd.spec20
1 files changed, 12 insertions, 8 deletions
diff --git a/php-zstd.spec b/php-zstd.spec
index 4c2f7d1..92519d9 100644
--- a/php-zstd.spec
+++ b/php-zstd.spec
@@ -10,17 +10,13 @@
# we don't want -z defs linker flag
%undefine _strict_symbol_defs_build
-%if 0%{?scl:1}
-%scl_package php-zstd
-%else
-%global pkg_name %{name}
-%endif
+%{?scl:%scl_package php-zstd}
%bcond_without tests
%bcond_without apcu
%bcond_without libzstd
-%global zstdver 1.5.1
+%global zstdver 1.5.5
%global pecl_name zstd
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -29,7 +25,7 @@
Summary: Zstandard extension
Name: %{?scl_prefix}php-%{pecl_name}
-Version: 0.12.1
+Version: 0.12.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%if %{with libzstd}
License: MIT
@@ -40,6 +36,8 @@ License: MIT AND BSD-3-Clause
URL: https://pecl.php.net/package/%{pecl_name}
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
+Patch0: %{pecl_name}-pr57.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.0
%if %{with apcu}
@@ -87,6 +85,7 @@ mv %{pecl_name}-%{version} NTS
%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
cd NTS
+%patch -P0 -p1 -b .pr57
cp zstd/LICENSE LICENSE-libzstd
@@ -97,7 +96,7 @@ sed -e '\:"zstd/:d' -i ../package.xml
%endif
# Sanity check, really often broken
-extver=$(sed -n '/#define PHP_ZSTD_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_zstd.h)
+extver=$(sed -n '/#define PHP_ZSTD_VERSION/{s/.* "//;s/".*$//;p}' php_zstd.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
exit 1
@@ -245,6 +244,11 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Fri Apr 28 2023 Remi Collet <remi@remirepo.net> - 0.12.2-1
+- update to 0.12.2
+- fix extension version and build warnings, using patch from
+ https://github.com/kjdev/php-ext-zstd/pull/57
+
* Mon Jan 23 2023 Remi Collet <remi@remirepo.net> - 0.12.1-1
- update to 0.12.1