summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-04-23 08:16:40 +0200
committerRemi Collet <remi@remirepo.net>2019-04-23 08:16:40 +0200
commit66103f5590123cba39be5cada1ffb2832a6981e8 (patch)
tree7c240ac126beec49aa80f9c646407e39b79685c8
parent07adae3fcc55c93767b559397f2e6abc22226e66 (diff)
- update to 0.7.2
- use bundled libzstd 1.4.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION6
-rw-r--r--php-zstd.spec20
3 files changed, 18 insertions, 12 deletions
diff --git a/PHPINFO b/PHPINFO
index 6bdf2e9..bd9abd3 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,5 +2,5 @@
zstd
Zstd support => enabled
-Extension Version => 0.7.1
-Interface Version => 1.3.8
+Extension Version => 0.7.2
+Interface Version => 1.4.0
diff --git a/REFLECTION b/REFLECTION
index f08472c..633e350 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,9 +1,11 @@
-Extension [ <persistent> extension #187 zstd version 0.7.1 ] {
+Extension [ <persistent> extension #187 zstd version 0.7.2 ] {
- - Constants [3] {
+ - Constants [5] {
Constant [ integer ZSTD_COMPRESS_LEVEL_MIN ] { 1 }
Constant [ integer ZSTD_COMPRESS_LEVEL_MAX ] { 22 }
Constant [ integer ZSTD_COMPRESS_LEVEL_DEFAULT ] { 3 }
+ Constant [ integer LIBZSTD_VERSION_NUMBER ] { 10400 }
+ Constant [ string LIBZSTD_VERSION_STRING ] { 1.4.0 }
}
- Functions {
diff --git a/php-zstd.spec b/php-zstd.spec
index 49d7653..2198d39 100644
--- a/php-zstd.spec
+++ b/php-zstd.spec
@@ -17,14 +17,14 @@
%global pkg_name %{name}
%endif
-%if 0%{?fedora} >= 28 || 0%{?rhel} >= 6
+%if 0%{?fedora} >= 99 || 0%{?rhel} >= 99
%global with_libzstd 1
%else
%global with_libzstd 0
%endif
-%global zstdver 1.3.8
+%global zstdver 1.4.0
-%global gh_commit e7f5972d54aed22bc951dd30e11fc04704b4e14a
+%global gh_commit dc436e0c8729ea121ee1d7c4184c17b168ecd654
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-zstd
@@ -35,7 +35,7 @@
Summary: Zstd Extension for PHP
Name: %{?sub_prefix}php-%{pecl_name}
-Version: 0.7.1
+Version: 0.7.2
%if 0%{?gh_date:1}
Release: 1%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -55,9 +55,9 @@ Source1: makesrc.sh
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
%if %{?with_libzstd}
-BuildRequires: libzstd-devel >= %{zstdver}
+BuildRequires: libzstd-devel >= %{zstdver}
%else
-Provides: bundled(libstd) = %{zstdver}
+Provides: bundled(libzstd) = %{zstdver}
%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -110,7 +110,7 @@ mv %{gh_project}-%{gh_commit} NTS
cd NTS
# replace symlink
rm LICENSE-zstd
-mv zstd/LICENSE LICENSE-zstd
+mv zstd/LICENSE LICENSE-libzstd
%if %{?with_libzstd}
# Use the system library
@@ -219,7 +219,7 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%{!?_licensedir:%global license %%doc}
%license NTS/LICENSE
%if ! %{?with_libzstd}
-%license NTS/LICENSE-zstd
+%license NTS/LICENSE-libzstd
%endif
%doc NTS/README.md
@@ -242,6 +242,10 @@ TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
%changelog
+* Tue Apr 23 2019 Remi Collet <remi@remirepo.net> - 0.7.2-1
+- update to 0.7.2
+- use bundled libzstd 1.4.0
+
* Fri Apr 19 2019 Remi Collet <remi@remirepo.net> - 0.7.1-1
- update to 0.7.1