summaryrefslogtreecommitdiffstats
path: root/php-xz.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-xz.spec')
-rw-r--r--php-xz.spec24
1 files changed, 9 insertions, 15 deletions
diff --git a/php-xz.spec b/php-xz.spec
index 68fa9fd..5bf98f2 100644
--- a/php-xz.spec
+++ b/php-xz.spec
@@ -16,7 +16,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit 84e8742a9a7cdb985190a02f270298efcf264c21
+%global gh_commit be72e636dd7dd8a220cb9b54f2970477dad878a0
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner codemasher
%global gh_project php-ext-xz
@@ -26,22 +26,15 @@
Summary: XZ (LZMA2) compression/decompression
Name: %{?scl_prefix}php-%{pecl_name}
-Version: 1.1.1
+Version: 1.1.2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: PHP
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
-# library check
-Patch0: pr1.patch
-# extension version
-Patch1: pr2.patch
-# arginfo
-Patch2: pr3.patch
-
BuildRequires: make
BuildRequires: %{?dtsprefix}gcc
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel >= 7.0
BuildRequires: pkgconfig(liblzma)
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -76,9 +69,6 @@ mv %{gh_project}-%{gh_commit} NTS
cd NTS
mv LICENSE.txt LICENSE
-%patch0 -p1 -b .pr1
-%patch1 -p1 -b .pr2
-%patch2 -p1 -b .pr3
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_XZ_VERSION/{s/.* "//;s/".*$//;p}' php_xz.h)
@@ -152,7 +142,7 @@ cd NTS
TEST_PHP_EXECUTABLE=%{__php} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__php} -n run-tests.php -q --offline --show-diff
+%{__php} -n run-tests.php -q -x --offline --show-diff
%if %{with_zts}
cd ../ZTS
@@ -165,7 +155,7 @@ cd ../ZTS
TEST_PHP_EXECUTABLE=%{__ztsphp} \
TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
REPORT_EXIT_STATUS=1 \
-%{__ztsphp} -n run-tests.php -q --offline --show-diff
+%{__ztsphp} -n run-tests.php -q -x --offline --show-diff
%endif
@@ -184,6 +174,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Aug 2 2021 Remi Collet <remi@remirepo.net> - 1.1.2-1
+- update to 1.1.2
+- drop all patches merged upstream
+
* Fri Jul 9 2021 Remi Collet <remi@remirepo.net> - 1.1.1-1
- new package, version 1.1.1
- open https://github.com/codemasher/php-ext-xz/pull/1 library check