summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-11-12 10:00:46 +0100
committerRemi Collet <remi@remirepo.net>2017-11-12 10:00:46 +0100
commit3a9adb2b641e4f15e6e5a7682e93f3e636ae0c65 (patch)
tree745b059ca77ce24d834be18eb2e0de15b286a101
New package
-rw-r--r--.gitignore8
-rw-r--r--Makefile4
-rw-r--r--REFLECTION118
-rw-r--r--php-wkhtmltox.spec189
4 files changed, 319 insertions, 0 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..e617353
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,118 @@
+Extension [ <persistent> extension #161 wkhtmltox version 0.3.2-dev ] {
+
+ - INI {
+ Entry [ wkhtmltox.graphics <PERDIR,SYSTEM> ]
+ Current = '0'
+ }
+ }
+
+ - Classes [3] {
+ Class [ <internal:wkhtmltox> class WKHTMLTOX\PDF\Converter ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:wkhtmltox> static public method getVersion ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:wkhtmltox, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array $settings ]
+ }
+ }
+
+ Method [ <internal:wkhtmltox> public method add ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> wkhtmltox\PDF\Object $object ]
+ }
+ }
+
+ Method [ <internal:wkhtmltox> public method convert ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+ }
+ }
+
+ Class [ <internal:wkhtmltox> class WKHTMLTOX\PDF\Object ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:wkhtmltox, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $data ]
+ Parameter #1 [ <optional> array or NULL $settings ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:wkhtmltox> class WKHTMLTOX\Image\Converter ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [1] {
+ Method [ <internal:wkhtmltox> static public method getVersion ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [2] {
+ Method [ <internal:wkhtmltox, ctor> public method __construct ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <optional> string or NULL $buffer ]
+ Parameter #1 [ <optional> array $settings ]
+ }
+ }
+
+ Method [ <internal:wkhtmltox> public method convert ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string or NULL ]
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-wkhtmltox.spec b/php-wkhtmltox.spec
new file mode 100644
index 0000000..c6e858c
--- /dev/null
+++ b/php-wkhtmltox.spec
@@ -0,0 +1,189 @@
+# remirepo spec file for php-wkhtmltox
+#
+# Copyright (c) 2017 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%global sub_prefix %{scl_prefix}
+%scl_package php-wkhtmltox
+%else
+%global pkg_name %{name}
+%endif
+
+# Disable RPATH check
+%global __arch_install_post /bin/true
+
+%global gh_commit fecc9af29088b60512c454cb27be35f81fa33140
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner krakjoe
+%global gh_project wkhtmltox
+%global gh_date 20171112
+%global pecl_name wkhtmltox
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: HTML Converter
+Name: %{?sub_prefix}php-%{pecl_name}
+Version: 0.3.2
+%if 0%{?gh_date:1}
+Release: 0.2.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%endif
+License: MIT
+Group: Development/Languages
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+BuildRequires: %{?scl_prefix}php-devel > 7
+BuildRequires: wkhtmltopdf-opt >= 0.12.4
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+Requires: wkhtmltopdf-opt%{_isa} >= 0.12.4
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+Obsoletes: php70u-%{pecl_name} <= %{version}
+Obsoletes: php70w-%{pecl_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-%{pecl_name} <= %{version}
+Obsoletes: php71w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-%{pecl_name} <= %{version}
+Obsoletes: php72w-%{pecl_name} <= %{version}
+%endif
+%endif
+
+# Filter shared private and unwanted dependency on libwkhtmltox
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_from_requires: %filter_from_requires /libwkhtmltox/d}
+%{?filter_setup}
+
+
+%description
+Converting HTML to X since 2017.
+
+This extension wraps libwkhtmltox for PHP 7, and is linked against
+libwkhtmltox-opt package to get rid of X11 server requirement.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+
+cd NTS
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define PHP_WKHTMLTOX_VERSION/{s/.* "//;s/".*$//;p}' php_wkhtmltox.h)
+if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Drop in the bit of configuration
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension = %{pecl_name}.so
+EOF
+
+
+%build
+%{?dtsenable}
+
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config \
+ --with-libdir=%{_lib} \
+ --with-%{pecl_name}=/opt/wkhtmltopdf
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config \
+ --with-libdir=%{_lib} \
+ --with-%{pecl_name}=/opt/wkhtmltopdf
+make %{?_smp_mflags}
+%endif
+
+
+%install
+%{?dtsenable}
+
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+
+%check
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff || : ignore
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license NTS/LICENSE
+%doc NTS/README.md
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Sun Nov 12 2017 Remi Collet <remi@remirepo.net> - 0.3.2-0.2.20171112.fecc9af
+- new snapshot including 7.2 fix
+
+* Sun Nov 12 2017 Remi Collet <remi@remirepo.net> - 0.3.2-0.1.20171112.febce92
+- new package, version 0.3.2-dev