summaryrefslogtreecommitdiffstats
path: root/Makefile
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-17 11:01:28 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-17 11:01:28 +0100
commite032af37507dc6cfbf1036394b829bb509585499 (patch)
treed3425915cb3d2cff3e2cb5e3c6e2ab712a17f2fe /Makefile
parent66e46ccbf69170ba72bfbeed9066a9f131d780e8 (diff)
php-when: backport
Diffstat (limited to 'Makefile')
-rw-r--r--Makefile10
1 files changed, 10 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed