summaryrefslogtreecommitdiffstats
path: root/php-tcpdf.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2017-12-21 09:57:57 +0100
committerRemi Collet <remi@remirepo.net>2017-12-21 09:57:57 +0100
commite8216295565399e46b0a315087aa71b42751fcfc (patch)
tree6f6eeb963f5c85746e85ac6e10ffd7d8d6e93773 /php-tcpdf.spec
parentfacb5cff970f4aaa8aabdfba9dc76ae6674f6edd (diff)
add patch for PHP 7.2 from https://github.com/tecnickcom/TCPDF/pull/74/files
disable opcache caching for fonts
Diffstat (limited to 'php-tcpdf.spec')
-rw-r--r--php-tcpdf.spec17
1 files changed, 16 insertions, 1 deletions
diff --git a/php-tcpdf.spec b/php-tcpdf.spec
index a1da136..bcd0898 100644
--- a/php-tcpdf.spec
+++ b/php-tcpdf.spec
@@ -16,13 +16,17 @@
Name: php-tcpdf
Summary: PHP class for generating PDF documents and barcodes
Version: 6.2.13
-Release: 1%{?dist}
+Release: 4%{?dist}
URL: http://www.tcpdf.org
License: LGPLv3+
Group: Development/Libraries
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{?gh_short}.tar.gz
+# Disable opcache cahing for font metadata which may consume up to 90MB
+Source1: %{name}.blacklist
+
+Patch0: https://patch-diff.githubusercontent.com/raw/tecnickcom/TCPDF/pull/74.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -217,6 +221,7 @@ This package allow to use system GNU FreeFont serif font faces in TCPDF.
%prep
%setup -q -n %{gh_project}-%{gh_commit}
+%patch0 -p1
: remove bundled fonts
rm -rf fonts/dejavu-fonts-ttf* fonts/freefont-* fonts/ae_fonts_*
@@ -254,6 +259,9 @@ install -d %{buildroot}%{_sysconfdir}/%{name}
install -m 0644 config/*.php \
%{buildroot}%{_sysconfdir}/%{name}
+install -Dpm 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/php.d/opcache-%{name}.blacklist
+install -Dpm 0644 %{SOURCE1} %{buildroot}%{_sysconfdir}/php-zts.d/opcache-%{name}.blacklist
+
: Tools
install -d %{buildroot}%{_bindir}
install -m 0755 tools/%{real_name}_addfont.php \
@@ -304,6 +312,8 @@ rm -rf %{buildroot}
%{_datadir}/php/%{real_name}/*php
%dir %{_sysconfdir}/%{name}
%config(noreplace) %{_sysconfdir}/%{name}/*
+%config(noreplace) %{_sysconfdir}/php.d/opcache-%{name}.blacklist
+%config(noreplace) %{_sysconfdir}/php-zts.d/opcache-%{name}.blacklist
%files dejavu-lgc-sans-fonts
%defattr(-,root,root,-)
@@ -345,6 +355,11 @@ rm -rf %{buildroot}
%changelog
+* Thu Dec 21 2017 Remi Collet <remi@fedoraproject.org> - 6.2.13-4
+- add patch for PHP 7.2 from
+ https://github.com/tecnickcom/TCPDF/pull/74/files
+- disable opcache caching for fonts
+
* Mon Jan 9 2017 Remi Collet <remi@fedoraproject.org> - 6.2.13-1
- update to 6.2.13
- add classmap autoloader using fedora/autoloader