summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2013-05-14 08:21:49 +0200
committerRemi Collet <fedora@famillecollet.com>2013-05-14 08:21:49 +0200
commit067e2b59aa8cb5239f974cc02df4d5ce15f3bba9 (patch)
tree3782a4ff5d763ee993751d45906d4ca49f6700a2
parent79142a9a636d57a9be8fc7074f2117f8be7b12d5 (diff)
php-tcpdf: 6.0.014, drop patch merged upstream
-rw-r--r--php-tcpdf.spec13
-rw-r--r--php-tcpdf_sysfonts.patch54
2 files changed, 7 insertions, 60 deletions
diff --git a/php-tcpdf.spec b/php-tcpdf.spec
index d5bdcff..aa9b28a 100644
--- a/php-tcpdf.spec
+++ b/php-tcpdf.spec
@@ -1,10 +1,10 @@
-%global dl_version 6_0_013
+%global dl_version 6_0_014
%global real_name tcpdf
Name: php-tcpdf
Summary: PHP class for generating PDF documents
-Version: 6.0.013
-Release: 2%{?dist}
+Version: 6.0.014
+Release: 1%{?dist}
URL: http://www.tcpdf.org
License: LGPLv3+
@@ -15,8 +15,6 @@ Source1: %{real_name}_addfont.php
Patch0: %{name}_badpath.patch
Patch1: %{name}_config.patch
-# https://sourceforge.net/p/tcpdf/patches/63/ - allow to use system fonts
-Patch2: %{name}_sysfonts.patch
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
@@ -128,7 +126,6 @@ This package allow to use system GNU FreeFonts in TCPDF.
%setup -qn %{real_name}
%patch0 -p1 -b .badpath
%patch1 -p1 -b .config
-%patch2 -p1 -b .sysfonts
: globally fix permissions, always broken...
find ./ -type d -exec chmod 755 {} \;
@@ -279,6 +276,10 @@ rm -rf %{buildroot}
%changelog
+* Tue May 14 2013 Remi Collet <remi@fedoraproject.org> - 6.0.014-1
+- update to 6.0.014
+- drop patch merged upstream
+
* Mon May 13 2013 Remi Collet <remi@fedoraproject.org> - 6.0.013-2
- split fonts in sub-packages
diff --git a/php-tcpdf_sysfonts.patch b/php-tcpdf_sysfonts.patch
deleted file mode 100644
index 1a847bc..0000000
--- a/php-tcpdf_sysfonts.patch
+++ /dev/null
@@ -1,54 +0,0 @@
---- tcpdf/include/tcpdf_fonts.php.prev 2013-05-13 09:43:35.000000000 +0200
-+++ tcpdf/include/tcpdf_fonts.php 2013-05-13 09:48:19.000000000 +0200
-@@ -57,12 +57,13 @@
- * @param $platid (int) Platform ID for CMAP table to extract (when building a Unicode font for Windows this value should be 3, for Macintosh should be 1).
- * @param $encid (int) Encoding ID for CMAP table to extract (when building a Unicode font for Windows this value should be 1, for Macintosh should be 0). When Platform ID is 3, legal values for Encoding ID are: 0=Symbol, 1=Unicode, 2=ShiftJIS, 3=PRC, 4=Big5, 5=Wansung, 6=Johab, 7=Reserved, 8=Reserved, 9=Reserved, 10=UCS-4.
- * @param $addcbbox (boolean) If true includes the character bounding box information on the php font file.
-+ * @param $link (boolean) If true link to system font instead of copying the font data (not transportable).
- * @return (string) TCPDF font name.
- * @author Nicola Asuni
- * @since 5.9.123 (2010-09-30)
- * @public static
- */
-- public static function addTTFfont($fontfile, $fonttype='', $enc='', $flags=32, $outpath='', $platid=3, $encid=1, $addcbbox=false) {
-+ public static function addTTFfont($fontfile, $fonttype='', $enc='', $flags=32, $outpath='', $platid=3, $encid=1, $addcbbox=false, $link=false) {
- if (!file_exists($fontfile)) {
- // Could not find file
- return false;
-@@ -92,7 +93,7 @@
- // this font already exist (delete it from fonts folder to rebuild it)
- return $font_name;
- }
-- $fmetric['file'] = $font_name.'.z';
-+ $fmetric['file'] = $font_name;
- $fmetric['ctg'] = $font_name.'.ctg.z';
- // get font data
- $font = file_get_contents($fontfile);
-@@ -178,6 +179,7 @@
- $encrypted = substr($font, (12 + $fmetric['size1']), $fmetric['size2']);
- $data .= $encrypted;
- // store compressed font
-+ $fmetric['file'] .= '.z';
- $fp = fopen($outpath.$fmetric['file'], 'wb');
- fwrite($fp, gzcompress($data));
- fclose($fp);
-@@ -347,10 +349,15 @@
- } else {
- // ---------- TRUE TYPE ----------
- if ($fmetric['type'] != 'cidfont0') {
-- // store compressed font
-- $fp = fopen($outpath.$fmetric['file'], 'wb');
-- fwrite($fp, gzcompress($font));
-- fclose($fp);
-+ if ($link) {
-+ symlink($fontfile, $outpath.$fmetric['file']);
-+ } else {
-+ $fmetric['file'] .= '.z';
-+ // store compressed font
-+ $fp = fopen($outpath.$fmetric['file'], 'wb');
-+ fwrite($fp, gzcompress($font));
-+ fclose($fp);
-+ }
- }
- $offset = 0; // offset position of the font data
- if (TCPDF_STATIC::_getULONG($font, $offset) != 0x10000) {