summaryrefslogtreecommitdiffstats
path: root/php-tarantool.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tarantool.spec')
-rw-r--r--php-tarantool.spec18
1 files changed, 17 insertions, 1 deletions
diff --git a/php-tarantool.spec b/php-tarantool.spec
index c6225c3..5c36f59 100644
--- a/php-tarantool.spec
+++ b/php-tarantool.spec
@@ -35,7 +35,7 @@ Version: 0.2.0
%if 0%{?github_date}
Release: 0.1.%{?github_date}git%{?github_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
Summary: PHP driver for Tarantool/Box
@@ -45,6 +45,8 @@ License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{pkg_name}-%{version}-%{github_short}.tar.gz
+Patch0: 121.patch
+
BuildRequires: %{?scl_prefix}php-devel >= 7
%if %{with_tests}
# For tests
@@ -75,6 +77,10 @@ Obsoletes: php70w-%{ext_name} <= %{version}
Obsoletes: php71u-%{ext_name} <= %{version}
Obsoletes: php71w-%{ext_name} <= %{version}
%endif
+%if "%{php_version}" > "7.2"
+Obsoletes: php72u-%{ext_name} <= %{version}
+Obsoletes: php72w-%{ext_name} <= %{version}
+%endif
%endif
%if 0%{?fedora} < 20 && 0%{?rhel} < 7
@@ -98,6 +104,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{github_name}-%{github_commit} NTS
cd NTS
+%patch0 -p1 -b .pr121
+
extver=$(sed -n '/#define PHP_TARANTOOL_VERSION/{s/.* "//;s/".*$//;p}' php_tarantool.h)
if test "x${extver}" != "x%{version}%{?pre}%{?github_date:-dev}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?pre}%{?github_date:-dev}.
@@ -126,6 +134,8 @@ INI
%build
+%{?dtsenable}
+
: Ext -- NTS
pushd NTS
%{_bindir}/phpize
@@ -144,6 +154,8 @@ popd
%install
+%{?dtsenable}
+
: Ext -- NTS
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 0644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -183,6 +195,10 @@ install -D -m 0644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%changelog
+* Sat Jun 24 2017 Remi Collet <remi@fedoraproject.org> - 0.2.0-3
+- add patch for PHP 7.2 from
+ https://github.com/tarantool/tarantool-php/pull/121
+
* Thu Dec 1 2016 Remi Collet <remi@fedoraproject.org> - 0.2.0-2
- rebuild with PHP 7.1.0 GA