summaryrefslogtreecommitdiffstats
path: root/php-tarantool-php7.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-tarantool-php7.spec')
-rw-r--r--php-tarantool-php7.spec18
1 files changed, 7 insertions, 11 deletions
diff --git a/php-tarantool-php7.spec b/php-tarantool-php7.spec
index ac4229a..ecfa955 100644
--- a/php-tarantool-php7.spec
+++ b/php-tarantool-php7.spec
@@ -10,12 +10,8 @@
%if 0%{?scl:1}
# PHPUnit not available in SCL
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
%global sub_prefix %{scl_prefix}
-%endif
-%scl_package php-%{ext_name}
+%scl_package php-tarantool
%else
%global pkg_name %{name}
@@ -23,9 +19,9 @@
%global github_owner tarantool
%global github_name tarantool-php
-%global github_commit 27697cf6c1bf0d87a46ac6412767d46aa04ce5f3
+%global github_commit 3bf856687bc2e72a093f4c01c1f80d2bc39de928
%global github_short %(c=%{github_commit}; echo ${c:0:7})
-%global github_date 20160906
+#global github_date 20160906
%global ext_name tarantool
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
@@ -35,7 +31,7 @@
%global with_tests 0
Name: %{?sub_prefix}php-%{ext_name}
-Version: 0.1.1
+Version: 0.2.0
%if 0%{?github_date}
Release: 0.1.%{?github_date}git%{?github_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -102,9 +98,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{github_name}-%{github_commit} NTS
cd NTS
-: Bump version to avoid user confusion
-sed -i -e '/PHP_TARANTOOL_VERSION/s/0.1.0/%{version}-dev/' php_tarantool.h
-
extver=$(sed -n '/#define PHP_TARANTOOL_VERSION/{s/.* "//;s/".*$//;p}' php_tarantool.h)
if test "x${extver}" != "x%{version}%{?pre}%{?github_date:-dev}"; then
: Error: Upstream extension version is ${extver}, expecting %{version}%{?pre}%{?github_date:-dev}.
@@ -190,6 +183,9 @@ install -D -m 0644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%changelog
+* Wed Nov 23 2016 Remi Collet <remi@fedoraproject.org> - 0.2.0-1
+- update to 0.2.0
+
* Thu Mar 24 2016 Remi Collet <remi@fedoraproject.org> - 0.1.1-0.1.20160906git27697cf
- update to git snapshot for PHP 7