summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-29 11:33:29 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-29 11:33:29 +0200
commit8435bf761a14aa1d2e7ffea878f04be0adf2cf12 (patch)
tree9afa9f1d7c7e04442e5db3e351319085d1ef6c0b
parent02b8d2f45f59840463b0afe0030f5c0280ea0871 (diff)
php-tarantool: 0.1.1-dev for PHP 7
-rw-r--r--REFLECTION-DEV350
-rw-r--r--php-tarantool-dev.spec70
2 files changed, 381 insertions, 39 deletions
diff --git a/REFLECTION-DEV b/REFLECTION-DEV
index a4fd1a9..3145162 100644
--- a/REFLECTION-DEV
+++ b/REFLECTION-DEV
@@ -1,10 +1,13 @@
-Extension [ <persistent> extension #16 tarantool version 1.0 ] {
+Extension [ <persistent> extension #125 tarantool version 0.1.0 ] {
- INI {
- Entry [ tarantool.con_per_host <SYSTEM> ]
- Current = '5'
+ Entry [ tarantool.persistent <ALL> ]
+ Current = '0'
+ }
+ Entry [ tarantool.use_namespace <SYSTEM> ]
+ Current = '0'
}
- Entry [ tarantool.persistent <SYSTEM> ]
+ Entry [ tarantool.connection_alias <SYSTEM> ]
Current = '0'
}
Entry [ tarantool.timeout <ALL> ]
@@ -36,10 +39,25 @@ Extension [ <persistent> extension #16 tarantool version 1.0 ] {
Constant [ integer TARANTOOL_ITER_NEIGHBOR ] { 11 }
}
- - Classes [1] {
+ - Classes [5] {
Class [ <internal:tarantool> class Tarantool ] {
- - Constants [0] {
+ - Constants [15] {
+ Constant [ integer ITERATOR_EQ ] { 0 }
+ Constant [ integer ITERATOR_REQ ] { 1 }
+ Constant [ integer ITERATOR_ALL ] { 2 }
+ Constant [ integer ITERATOR_LT ] { 3 }
+ Constant [ integer ITERATOR_LE ] { 4 }
+ Constant [ integer ITERATOR_GE ] { 5 }
+ Constant [ integer ITERATOR_GT ] { 6 }
+ Constant [ integer ITERATOR_BITS_ALL_SET ] { 7 }
+ Constant [ integer ITERATOR_BITSET_ALL_SET ] { 7 }
+ Constant [ integer ITERATOR_BITS_ANY_SET ] { 8 }
+ Constant [ integer ITERATOR_BITSET_ANY_SET ] { 8 }
+ Constant [ integer ITERATOR_BITS_ALL_NOT_SET ] { 9 }
+ Constant [ integer ITERATOR_BITSET_ALL_NOT_SET ] { 9 }
+ Constant [ integer ITERATOR_OVERLAPS ] { 10 }
+ Constant [ integer ITERATOR_NEIGHBOR ] { 11 }
}
- Static properties [0] {
@@ -51,56 +69,374 @@ Extension [ <persistent> extension #16 tarantool version 1.0 ] {
- Properties [0] {
}
- - Methods [17] {
+ - Methods [18] {
Method [ <internal:tarantool, ctor> public method __construct ] {
+
+ - Parameters [5] {
+ Parameter #0 [ <optional> $host ]
+ Parameter #1 [ <optional> $port ]
+ Parameter #2 [ <optional> $login ]
+ Parameter #3 [ <optional> $password ]
+ Parameter #4 [ <optional> $persistent_id ]
+ }
}
Method [ <internal:tarantool> public method connect ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:tarantool> public method reconnect ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:tarantool> public method close ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:tarantool> public method flush_schema ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:tarantool> public method authenticate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $login ]
+ Parameter #1 [ <optional> $password ]
+ }
}
Method [ <internal:tarantool> public method ping ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:tarantool> public method select ] {
+
+ - Parameters [6] {
+ Parameter #0 [ <required> $space ]
+ Parameter #1 [ <optional> $key ]
+ Parameter #2 [ <optional> $index ]
+ Parameter #3 [ <optional> $limit ]
+ Parameter #4 [ <optional> $offset ]
+ Parameter #5 [ <optional> $iterator ]
+ }
}
Method [ <internal:tarantool> public method insert ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $space ]
+ Parameter #1 [ <required> array $tuple ]
+ }
}
Method [ <internal:tarantool> public method replace ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $space ]
+ Parameter #1 [ <required> array $tuple ]
+ }
}
Method [ <internal:tarantool> public method call ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $proc ]
+ Parameter #1 [ <optional> $tuple ]
+ }
}
Method [ <internal:tarantool> public method eval ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $proc ]
+ Parameter #1 [ <optional> $tuple ]
+ }
}
Method [ <internal:tarantool> public method delete ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $space ]
+ Parameter #1 [ <required> $key ]
+ Parameter #2 [ <optional> $index ]
+ }
}
Method [ <internal:tarantool> public method update ] {
+
+ - Parameters [4] {
+ Parameter #0 [ <required> $space ]
+ Parameter #1 [ <required> $key ]
+ Parameter #2 [ <required> array $args ]
+ Parameter #3 [ <optional> $index ]
+ }
}
Method [ <internal:tarantool> public method upsert ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> $space ]
+ Parameter #1 [ <required> array $tuple ]
+ Parameter #2 [ <required> array $args ]
+ }
}
Method [ <internal:tarantool> public method evaluate ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $proc ]
+ Parameter #1 [ <optional> $tuple ]
+ }
}
Method [ <internal:tarantool> public method flushSchema ] {
+
+ - Parameters [0] {
+ }
}
Method [ <internal:tarantool> public method disconnect ] {
+
+ - Parameters [0] {
+ }
+ }
+ }
+ }
+
+ Class [ <internal:tarantool> class TarantoolException extends Exception implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:tarantool> class TarantoolIOException extends TarantoolException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:tarantool> class TarantoolClientError extends TarantoolException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
+ }
+ }
+ }
+
+ Class [ <internal:tarantool> class TarantoolParsingException extends TarantoolException implements Throwable ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [4] {
+ Property [ <default> protected $message ]
+ Property [ <default> protected $code ]
+ Property [ <default> protected $file ]
+ Property [ <default> protected $line ]
+ }
+
+ - Methods [10] {
+ Method [ <internal:Core, inherits Exception, ctor> <visibility error> method __construct ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <optional> $message ]
+ Parameter #1 [ <optional> $code ]
+ Parameter #2 [ <optional> $previous ]
+ }
+ }
+
+ Method [ <internal:Core, inherits Exception> public method __wakeup ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getMessage ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getCode ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getFile ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getLine ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTrace ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getPrevious ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> final public method getTraceAsString ] {
+ }
+
+ Method [ <internal:Core, inherits Exception, prototype Throwable> public method __toString ] {
}
}
}
diff --git a/php-tarantool-dev.spec b/php-tarantool-dev.spec
index b4e8d4b..ac4229a 100644
--- a/php-tarantool-dev.spec
+++ b/php-tarantool-dev.spec
@@ -8,19 +8,6 @@
# Please preserve changelog entries
#
-%global github_owner tarantool
-%global github_name tarantool-php
-%global github_commit 96879c6df07c6f0ebeeee5c2c611b86fc2b7856a
-%global github_short %(c=%{github_commit}; echo ${c:0:7})
-
-%global ext_name tarantool
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%if "%{php_version}" < "5.6"
-%global ini_name %{ext_name}.ini
-%else
-%global ini_name 40-%{ext_name}.ini
-%endif
-
%if 0%{?scl:1}
# PHPUnit not available in SCL
%if "%{scl}" == "rh-php56"
@@ -34,12 +21,26 @@
%global pkg_name %{name}
%endif
+%global github_owner tarantool
+%global github_name tarantool-php
+%global github_commit 27697cf6c1bf0d87a46ac6412767d46aa04ce5f3
+%global github_short %(c=%{github_commit}; echo ${c:0:7})
+%global github_date 20160906
+
+%global ext_name tarantool
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{ext_name}.ini
+
# Test suite requires a running server
%global with_tests 0
Name: %{?sub_prefix}php-%{ext_name}
-Version: 0.1.0
+Version: 0.1.1
+%if 0%{?github_date}
+Release: 0.1.%{?github_date}git%{?github_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%endif
Summary: PHP driver for Tarantool/Box
Group: Development/Libraries
@@ -48,8 +49,7 @@ License: BSD
URL: https://github.com/%{github_owner}/%{github_name}
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{pkg_name}-%{version}-%{github_short}.tar.gz
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
-BuildRequires: %{?scl_prefix}php-devel >= 5.4
+BuildRequires: %{?scl_prefix}php-devel >= 7
%if %{with_tests}
# For tests
BuildRequires: %{_bindir}/phpunit
@@ -69,17 +69,15 @@ Obsoletes: php53-%{ext_name} <= %{version}
Obsoletes: php53u-%{ext_name} <= %{version}
Obsoletes: php54-%{ext_name} <= %{version}
Obsoletes: php54w-%{ext_name} <= %{version}
-%if "%{php_version}" > "5.5"
Obsoletes: php55u-%{ext_name} <= %{version}
Obsoletes: php55w-%{ext_name} <= %{version}
-%endif
-%if "%{php_version}" > "5.6"
Obsoletes: php56u-%{ext_name} <= %{version}
Obsoletes: php56w-%{ext_name} <= %{version}
-%endif
-%if "%{php_version}" > "7.0"
Obsoletes: php70u-%{ext_name} <= %{version}
Obsoletes: php70w-%{ext_name} <= %{version}
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-%{ext_name} <= %{version}
+Obsoletes: php71w-%{ext_name} <= %{version}
%endif
%endif
@@ -101,8 +99,19 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
-
mv %{github_name}-%{github_commit} NTS
+
+cd NTS
+: Bump version to avoid user confusion
+sed -i -e '/PHP_TARANTOOL_VERSION/s/0.1.0/%{version}-dev/' php_tarantool.h
+
+extver=$(sed -n '/#define PHP_TARANTOOL_VERSION/{s/.* "//;s/".*$//;p}' php_tarantool.h)
+if test "x${extver}" != "x%{version}%{?pre}%{?github_date:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?pre}%{?github_date:-dev}.
+ exit 1
+fi
+cd ..
+
%if %{with_zts}
cp -pr NTS ZTS
%endif
@@ -113,8 +122,9 @@ cat > %{ini_name} << 'INI'
extension=%{ext_name}.so
; ----- Configuration options
-;tarantool.con_per_host = '5'
-;tarantool.persistent = '0'
+;tarantool.persistent = 0
+;tarantool.use_namespace = 0
+;tarantool.connection_alias = 0
;tarantool.timeout = '10.0'
;tarantool.request_timeout = '10.0'
;tarantool.retry_count = '1'
@@ -141,8 +151,6 @@ popd
%install
-rm -rf %{buildroot}
-
: Ext -- NTS
make -C NTS install INSTALL_ROOT=%{buildroot}
install -D -m 0644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
@@ -168,12 +176,7 @@ install -D -m 0644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license NTS/LICENSE NTS/AUTHORS
@@ -187,6 +190,9 @@ rm -rf %{buildroot}
%changelog
-* Thu Mar 24 2016 Remi Collet <remi@fedoraproject.org> - 0.1.0
+* Thu Mar 24 2016 Remi Collet <remi@fedoraproject.org> - 0.1.1-0.1.20160906git27697cf
+- update to git snapshot for PHP 7
+
+* Thu Mar 24 2016 Remi Collet <remi@fedoraproject.org> - 0.1.0-1
- Initial package