summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2021-12-03 06:51:08 +0100
committerRemi Collet <remi@php.net>2021-12-03 06:51:08 +0100
commitda8061b2d35257cdc57409de658dd0f7088c77a2 (patch)
tree7a52fe9ac5843700ffa01eb49d62316be332052e
parent94845e8aacdbd7d117019a577d8f2ca12f9fa82f (diff)
update to 5.10.0beta2
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION6
-rw-r--r--php-sqlsrv.spec16
3 files changed, 14 insertions, 10 deletions
diff --git a/PHPINFO b/PHPINFO
index d3c92f3..9aace5c 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
sqlsrv
sqlsrv support => enabled
-ExtensionVer => 5.9.0
+ExtensionVer => 5.10.0-beta2
Directive => Local Value => Master Value
sqlsrv.WarningsReturnAsErrors => On => On
diff --git a/REFLECTION b/REFLECTION
index 1661b6e..cf804bc 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #119 sqlsrv version 5.9.0 ] {
+Extension [ <persistent> extension #119 sqlsrv version 5.10.0-beta2 ] {
- INI {
Entry [ sqlsrv.WarningsReturnAsErrors <ALL> ]
@@ -18,7 +18,7 @@ Extension [ <persistent> extension #119 sqlsrv version 5.9.0 ] {
}
}
- - Constants [74] {
+ - Constants [76] {
Constant [ int SQLSRV_ERR_ERRORS ] { 0 }
Constant [ int SQLSRV_ERR_WARNINGS ] { 1 }
Constant [ int SQLSRV_ERR_ALL ] { 2 }
@@ -39,6 +39,7 @@ Extension [ <persistent> extension #119 sqlsrv version 5.9.0 ] {
Constant [ int SQLSRV_PHPTYPE_INT ] { 2 }
Constant [ int SQLSRV_PHPTYPE_FLOAT ] { 3 }
Constant [ int SQLSRV_PHPTYPE_DATETIME ] { 5 }
+ Constant [ int SQLSRV_PHPTYPE_TABLE ] { 7 }
Constant [ string SQLSRV_ENC_BINARY ] { binary }
Constant [ string SQLSRV_ENC_CHAR ] { char }
Constant [ int SQLSRV_NULLABLE_NO ] { 0 }
@@ -60,6 +61,7 @@ Extension [ <persistent> extension #119 sqlsrv version 5.9.0 ] {
Constant [ int SQLSRV_SQLTYPE_TIMESTAMP ] { 4606 }
Constant [ int SQLSRV_SQLTYPE_TINYINT ] { -6 }
Constant [ int SQLSRV_SQLTYPE_UDT ] { -151 }
+ Constant [ int SQLSRV_SQLTYPE_TABLE ] { -153 }
Constant [ int SQLSRV_SQLTYPE_UNIQUEIDENTIFIER ] { -11 }
Constant [ int SQLSRV_SQLTYPE_XML ] { -152 }
Constant [ int SQLSRV_SQLTYPE_DATE ] { 5211 }
diff --git a/php-sqlsrv.spec b/php-sqlsrv.spec
index ed79515..4399086 100644
--- a/php-sqlsrv.spec
+++ b/php-sqlsrv.spec
@@ -25,8 +25,8 @@
Name: %{?scl_prefix}php-sqlsrv
Summary: Microsoft Drivers for PHP for SQL Server
-%global tarversion 5.10.0beta1
-Version: 5.10.0~beta1
+%global tarversion 5.10.0beta2
+Version: 5.10.0~beta2
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
@@ -66,7 +66,6 @@ Provides: %{?scl_prefix}php-pecl(pdo_%{extname})%{_isa} = %{version}
%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-Obsoletes: php73-sqlsrv <= %{version}
%if "%{php_version}" > "7.4"
Obsoletes: php74-sqlsrv <= %{version}
%endif
@@ -223,20 +222,20 @@ install -D -m 644 %{ininame} %{buildroot}%{php_ztsinidir}/%{ininame}
# simple module load test
%{__php} --no-php-ini \
--define extension=%{buildroot}%{php_extdir}/%{extname}.so \
- --modules | grep %{extname}
+ --modules | grep '^%{extname}$'
%{__php} --no-php-ini \
--define extension=pdo.so \
--define extension=%{buildroot}%{php_extdir}/pdo_%{extname}.so \
- --modules | grep %{extname}
+ --modules | grep '^pdo_%{extname}$'
%if %{with_zts}
%{__ztsphp} --no-php-ini \
--define extension=%{buildroot}%{php_ztsextdir}/%{extname}.so \
- --modules | grep %{extname}
+ --modules | grep '^%{extname}$'
%{__ztsphp} --no-php-ini \
--define extension=pdo.so \
--define extension=%{buildroot}%{php_ztsextdir}/pdo_%{extname}.so \
- --modules | grep %{extname}
+ --modules | grep '^pdo_%{extname}$'
%endif
@@ -281,6 +280,9 @@ fi
%changelog
+* Fri Dec 3 2021 Remi Collet <remi@remirepo.net> - 5.10.0~beta2-1
+- update to 5.10.0beta2
+
* Thu Sep 9 2021 Remi Collet <remi@remirepo.net> - 5.10.0~beta1-1
- update to 5.10.0beta1