summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2019-02-22 08:51:15 +0100
committerRemi Collet <remi@remirepo.net>2019-02-22 08:51:15 +0100
commit3df8943d1d94f93162e99eb47cdb307b5f81a776 (patch)
tree41b4f9195d4f3d0b3aa0fa8461234c21d64f86e4
parent9783b59d01f740ee95384eadc55dd1996a59fe42 (diff)
v5.6.0
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--pdo.patch13
-rw-r--r--php-sqlsrv.spec12
-rw-r--r--sqlsrv.patch78
5 files changed, 8 insertions, 99 deletions
diff --git a/PHPINFO b/PHPINFO
index 024bb38..ad11666 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
sqlsrv
sqlsrv support => enabled
-ExtensionVer => 5.5.0-preview
+ExtensionVer => 5.6.0
Directive => Local Value => Master Value
sqlsrv.WarningsReturnAsErrors => On => On
diff --git a/REFLECTION b/REFLECTION
index 6e9b9ea..bcb4587 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #142 sqlsrv version 5.5.0-preview ] {
+Extension [ <persistent> extension #145 sqlsrv version 5.6.0 ] {
- INI {
Entry [ sqlsrv.WarningsReturnAsErrors <ALL> ]
diff --git a/pdo.patch b/pdo.patch
deleted file mode 100644
index d62bb22..0000000
--- a/pdo.patch
+++ /dev/null
@@ -1,13 +0,0 @@
-diff --git a/source/pdo_sqlsrv/pdo_util.cpp b/source/pdo_sqlsrv/pdo_util.cpp
-index 343537d..b0083e4 100644
---- a/source/pdo_sqlsrv/pdo_util.cpp
-+++ b/source/pdo_sqlsrv/pdo_util.cpp
-@@ -512,7 +512,7 @@ bool pdo_sqlsrv_handle_dbh_error( _Inout_ sqlsrv_context& ctx, _In_opt_ unsigned
- msg = static_cast<char*>( sqlsrv_malloc( msg_len ) );
- core_sqlsrv_format_message( msg, static_cast<unsigned int>( msg_len ), WARNING_TEMPLATE, error->sqlstate, error->native_code,
- error->native_message );
-- php_error( E_WARNING, msg );
-+ php_error( E_WARNING, "%s", msg );
- }
- ctx.set_last_error( error );
- break;
diff --git a/php-sqlsrv.spec b/php-sqlsrv.spec
index 459fb9f..e80491b 100644
--- a/php-sqlsrv.spec
+++ b/php-sqlsrv.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-sqlsrv
#
-# Copyright (c) 2016-2018 Remi Collet
+# Copyright (c) 2016-2019 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -25,11 +25,10 @@
Name: %{?scl_prefix}php-sqlsrv
Summary: Microsoft Drivers for PHP for SQL Server
-%global tarversion 5.5.0preview
-Version: 5.5.0~preview
+%global tarversion 5.6.0
+Version: 5.6.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
License: MIT
-Group: Development/Languages
URL: https://github.com/Microsoft/msphpsql
%if %{from_pecl}
@@ -65,8 +64,6 @@ Provides: %{?scl_prefix}php-pecl(pdo_%{extname})%{_isa} = %{version}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
-Obsoletes: php70u-sqlsrv <= %{version}
-Obsoletes: php70w-sqlsrv <= %{version}
%if "%{php_version}" > "7.1"
Obsoletes: php71u-sqlsrv <= %{version}
Obsoletes: php71w-sqlsrv <= %{version}
@@ -278,6 +275,9 @@ fi
%changelog
+* Fri Feb 22 2019 Remi Collet <remi@remirepo.net> - 5.6.0-1
+- update to 5.6.0 (stable)
+
* Mon Dec 10 2018 Remi Collet <remi@remirepo.net> - 5.5.0~preview-1
- update to 5.5.0.preview (devel)
diff --git a/sqlsrv.patch b/sqlsrv.patch
deleted file mode 100644
index 8ea4ce1..0000000
--- a/sqlsrv.patch
+++ /dev/null
@@ -1,78 +0,0 @@
-diff --git a/source/sqlsrv/stmt.cpp b/source/sqlsrv/stmt.cpp
-index 96aeae8..7757868 100644
---- a/source/sqlsrv/stmt.cpp
-+++ b/source/sqlsrv/stmt.cpp
-@@ -889,7 +889,9 @@ PHP_FUNCTION( sqlsrv_fetch_object )
- fci.object = Z_OBJ_P( &retval_z );
-
- memset( &fcic, 0, sizeof( fcic ));
-+#if PHP_VERSION_ID < 70300
- fcic.initialized = 1;
-+#endif
- fcic.function_handler = class_entry->constructor;
- fcic.calling_scope = class_entry;
-
-@@ -1806,10 +1808,8 @@ void fetch_fields_common( _Inout_ ss_sqlsrv_stmt* stmt, _In_ zend_long fetch_typ
- field_names.transferred();
- }
-
-- int zr = array_init( &fields );
-- CHECK_ZEND_ERROR( zr, stmt, SQLSRV_ERROR_ZEND_HASH ) {
-- throw ss::SSException();
-- }
-+ int zr;
-+ array_init( &fields );
-
- for( int i = 0; i < num_cols; ++i ) {
- SQLLEN field_len = -1;
-diff --git a/source/sqlsrv/util.cpp b/source/sqlsrv/util.cpp
-index 50b963e..a68b93c 100644
---- a/source/sqlsrv/util.cpp
-+++ b/source/sqlsrv/util.cpp
-@@ -506,10 +506,7 @@ PHP_FUNCTION( sqlsrv_errors )
- int result;
- zval err_z;
- ZVAL_UNDEF( &err_z );
-- result = array_init( &err_z );
-- if( result == FAILURE ) {
-- RETURN_FALSE;
-- }
-+ array_init( &err_z );
- if( flags == SQLSRV_ERR_ALL || flags == SQLSRV_ERR_ERRORS ) {
- if( Z_TYPE( SQLSRV_G( errors )) == IS_ARRAY && !sqlsrv_merge_zend_hash( &err_z, &SQLSRV_G( errors ) TSRMLS_CC )) {
- zval_ptr_dtor(&err_z);
-@@ -747,9 +744,7 @@ void copy_error_to_zval( _Inout_ zval* error_z, _In_ sqlsrv_error_const* error,
- _In_ bool warning TSRMLS_DC )
- {
-
-- if( array_init( error_z ) == FAILURE ) {
-- DIE( "Fatal error during error processing" );
-- }
-+ array_init( error_z );
-
- // sqlstate
- zval temp;
-@@ -837,10 +832,7 @@ bool handle_errors_and_warnings( _Inout_ sqlsrv_context& ctx, _Inout_ zval* repo
- if( Z_TYPE_P( reported_chain ) == IS_NULL ) {
-
- reported_chain_was_null = true;
-- zr = array_init( reported_chain );
-- if( zr == FAILURE ) {
-- DIE( "Fatal error in handle_errors_and_warnings" );
-- }
-+ array_init( reported_chain );
- }
- else {
- prev_reported_cnt = zend_hash_num_elements( Z_ARRVAL_P( reported_chain ));
-@@ -852,10 +844,7 @@ bool handle_errors_and_warnings( _Inout_ sqlsrv_context& ctx, _Inout_ zval* repo
- if( Z_TYPE_P( ignored_chain ) == IS_NULL ) {
-
- ignored_chain_was_null = true;
-- zr = array_init( ignored_chain );
-- if( zr == FAILURE ) {
-- DIE( "Fatal error in handle_errors_and_warnings" );
-- }
-+ array_init( ignored_chain );
- }
- }
-