summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-12-15 07:34:39 +0100
committerRemi Collet <fedora@famillecollet.com>2015-12-15 07:34:39 +0100
commitc8f0920dc65d88e80db1e0481eb39fb31115d7c2 (patch)
tree1b154390aa0ed28cb6560192c399bd8d90311b7e
parent01f519c5fd4e8c02e6c32f9d62a71516c708acb4 (diff)
php-solarium: fix for old symfony (epel)
-rw-r--r--php-solarium-autoload.php6
-rw-r--r--php-solarium.spec2
2 files changed, 6 insertions, 2 deletions
diff --git a/php-solarium-autoload.php b/php-solarium-autoload.php
index ad48221..b8be4e0 100644
--- a/php-solarium-autoload.php
+++ b/php-solarium-autoload.php
@@ -15,4 +15,8 @@ if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Compo
$fedoraClassLoader->addPrefix('Solarium\\', dirname(__DIR__));
// dependencies
-require_once $vendorDir . '/Symfony/Component/autoload.php';
+if (file_exists($vendorDir . '/Symfony/Component/autoload.php')) {
+ require_once $vendorDir . '/Symfony/Component/autoload.php';
+} else {
+ require_once $vendorDir . '/Symfony/autoload.php';
+}
diff --git a/php-solarium.spec b/php-solarium.spec
index f4ff502..e13562f 100644
--- a/php-solarium.spec
+++ b/php-solarium.spec
@@ -8,7 +8,7 @@
#
%global gh_commit 0b51430cc3b8a975084435dada53a3c27940b2d6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
-%global gh_owner basdenooijer
+%global gh_owner solariumphp
%global gh_project solarium
%global with_tests %{?_without_tests:0}%{!?_without_tests:1}