summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--php-snuffleupagus.spec14
1 files changed, 12 insertions, 2 deletions
diff --git a/php-snuffleupagus.spec b/php-snuffleupagus.spec
index 724c9d5..d08f0f2 100644
--- a/php-snuffleupagus.spec
+++ b/php-snuffleupagus.spec
@@ -35,7 +35,7 @@ Version: 0.4.0
%if 0%{?gh_date}
Release: 1%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: LGPLv3
Group: Development/Languages
@@ -48,7 +48,12 @@ BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: pcre-devel
# For tests/upload_validation_real.phpt
-BuildRequires: %{_root_bindir}/python
+%if 0%{?fedora} >= 29 || 0%{?rhel} >= 8
+%global python %{_root_bindir}/python3
+%else
+%global python %{_root_bindir}/python
+%endif
+BuildRequires: %{python}
BuildRequires: %{?scl_prefix}php-vld
#BuildRequires: gdb
#BuildRequires: php-debuginfo
@@ -171,6 +176,8 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
rm src/tests/stream_wrapper.phpt
%endif
+sed -e 's:#!/usr/bin/python:#!%{python}:' -i scripts/upload_validation.py
+
cd src
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -218,6 +225,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Tue Dec 4 2018 Remi Collet <remi@remirepo.net> - 0.4.0-3
+- EL-8 build
+
* Mon Sep 3 2018 Remi Collet <remi@remirepo.net> - 0.4.0-2
- add patch for PHP 7.3 on 32-bit from
https://github.com/nbs-system/snuffleupagus/pull/242