summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-02-07 14:44:42 +0100
committerRemi Collet <remi@remirepo.net>2018-02-07 14:44:42 +0100
commit712d9a4c332d2bdee0455da79a95ef74062d3fc7 (patch)
treeceb9966b4c27357d4a5e4a02c6aa9e071de492f7
parent2214cb1cf55f71b884addaf8268607c475c4fed0 (diff)
v0.2.1
-rw-r--r--REFLECTION11
-rw-r--r--php-snuffleupagus.spec25
2 files changed, 17 insertions, 19 deletions
diff --git a/REFLECTION b/REFLECTION
index 3dd3e78..ba5f9ce 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,13 +1,4 @@
-Extension [ <persistent> extension #134 snuffleupagus version 0.2 ] {
-
- - INI {
- Entry [ sp.configuration_file <SYSTEM> ]
- Current = '/etc/php.d/snuffleupagus-*.rules'
- }
- }
-}
-
-Extension [ <persistent> extension #134 snuffleupagus version 0.2 ] {
+Extension [ <persistent> extension #135 snuffleupagus version 0.2.1 ] {
- INI {
Entry [ sp.configuration_file <SYSTEM> ]
diff --git a/php-snuffleupagus.spec b/php-snuffleupagus.spec
index 2cd5b59..2774397 100644
--- a/php-snuffleupagus.spec
+++ b/php-snuffleupagus.spec
@@ -6,6 +6,10 @@
#
# Please, preserve the changelog entries
#
+
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-snuffleupagus
@@ -13,7 +17,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit 0b36d6ab1d91cdfca0ddc686a8b2ed930505210d
+%global gh_commit a9ee27231e057e3b30a424d7dec8f92ac8beac11
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nbs-system
%global gh_project snuffleupagus
@@ -26,9 +30,9 @@
Summary: Security module for php7
Name: %{?sub_prefix}php-snuffleupagus
-Version: 0.2.0
+Version: 0.2.1
%if 0%{?gh_date}
-Release: 3.%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
@@ -37,7 +41,7 @@ Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pkg_name}-%{version}-%{gh_short}.tar.gz
-BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: pcre-devel
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
@@ -84,11 +88,11 @@ sed -e '/^CFLAGS/d' -i config.m4
# TODO not ok for now
# Sanity check, really often broken
grep PHP_SNUFFLEUPAGUS_VERSION php_snuffleupagus.h
-#extver=$(sed -n '/#define PHP_SNUFFLEUPAGUS_VERSION/{s/.* "//;s/".*$//;p}' php_snuffleupagus.h)
-#if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
-# : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
-# exit 1
-#fi
+extver=$(sed -n '/#define PHP_SNUFFLEUPAGUS_VERSION/{s/.* "//;s/".*$//;p}' php_snuffleupagus.h)
+if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
+ exit 1
+fi
cd ..
%if %{with_zts}
@@ -195,6 +199,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Wed Feb 7 2018 Remi Collet <remi@remirepo.net> - 0.2.1-1
+- Update to 0.2.1
+
* Thu Jan 18 2018 Remi Collet <remi@remirepo.net> - 0.2.0-1
- update to 0.2.0
- open https://github.com/nbs-system/snuffleupagus/pull/128 - src in path