summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-05-17 07:00:25 +0200
committerRemi Collet <remi@php.net>2022-05-17 07:00:25 +0200
commit4db8b1e839864c8fc3c488f097ff692b1cc49416 (patch)
treeb8fdd7780762fda62ee4b739b712b395829b8023
parent25db9b8a97f0753499f7a76040bcf5c7b5953445 (diff)
update to 0.8.0
open https://github.com/jvoisin/snuffleupagus/issues/418 bad version open https://github.com/jvoisin/snuffleupagus/issues/419 failed test
-rw-r--r--PHPINFO2
-rw-r--r--REFLECTION2
-rw-r--r--php-snuffleupagus.spec17
3 files changed, 13 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index 25d5ade..247b24a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -2,7 +2,7 @@
snuffleupagus
snuffleupagus support => enabled
-Version => 0.8.0-sng (with Suhosin-NG patches)
+Version => 0.8.1-sng (with Suhosin-NG patches)
Valid config => yes
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index bc1475f..3eeac9a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 snuffleupagus version 0.8.0 ] {
+Extension [ <persistent> extension #120 snuffleupagus version 0.8.1 ] {
- INI {
Entry [ sp.configuration_file <SYSTEM> ]
diff --git a/php-snuffleupagus.spec b/php-snuffleupagus.spec
index 9f9ccf4..2fce251 100644
--- a/php-snuffleupagus.spec
+++ b/php-snuffleupagus.spec
@@ -18,7 +18,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit c0e72a25f32e4916ac5eda8cb47888fd0a200b23
+%global gh_commit 3d206b9ae51680ae6c0f0eee3e11e667d343d3e4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner jvoisin
%global gh_project snuffleupagus
@@ -31,7 +31,7 @@
Summary: Security module for PHP
Name: %{?sub_prefix}php-snuffleupagus
-Version: 0.8.0
+Version: 0.8.1
%if 0%{?gh_date}
Release: 2%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
@@ -88,7 +88,7 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
cd src
# Sanity check, really often broken
grep PHP_SNUFFLEUPAGUS_VERSION php_snuffleupagus.h
-sed -e '/PHP_SNUFFLEUPAGUS_VERSION/s/0.9.0/0.8.0/' -i php_snuffleupagus.h
+# sed -e '/PHP_SNUFFLEUPAGUS_VERSION/s/0.9.0/0.8.0/' -i php_snuffleupagus.h
extver=$(sed -n '/#define PHP_SNUFFLEUPAGUS_VERSION/{s/.* "//;s/".*$//;p}' php_snuffleupagus.h)
if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
@@ -109,6 +109,14 @@ extension = %{pecl_name}.so
; Path to rules configuration files, glob or comma separated list
sp.configuration_file = '%{php_inidir}/%{pecl_name}-*.rules'
+
+; Since our configuration format is a bit more complex than php’s one,
+; we have a sp.allow_broken_configuration parameter (false by default),
+; that you can set to true if you want PHP to carry on if your Snuffleupagus’
+; configuration contains syntax errors. You’ll still get a big scary message
+; in your logs of course. We do not recommend to use it of course, but
+; sometimes it might be useful to be able to “debug in production” without
+; breaking your website.
;sp.allow_broken_configuration = Off
EOF
@@ -175,9 +183,6 @@ export SP_SKIP_OLD_PHP_CHECK=1
# add extensions used by test suite
TEST_DEPS="-d extension=xml.so -d extension=dom.so -d extension=curl.so -d extension=simplexml.so"
-# https://github.com/jvoisin/snuffleupagus/issues/419
-rm */tests/disable_function/disabled_functions_param_str_representation_php8.phpt
-
cd src
: Minimal load test for NTS extension
%{__php} --no-php-ini \