summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-02-21 08:28:19 +0100
committerRemi Collet <remi@remirepo.net>2020-02-21 08:28:19 +0100
commit3494f8af6d039ef52df8e13f85b0cfe67dcb5ac0 (patch)
tree32ec6661503ae3f458eced34ef6a1635010dcbde
parent081405a5460fd711e352f74573e8b6cc93818b7d (diff)
fix test suite
-rw-r--r--php-snuffleupagus.spec16
1 files changed, 13 insertions, 3 deletions
diff --git a/php-snuffleupagus.spec b/php-snuffleupagus.spec
index 2263bd7..4580b53 100644
--- a/php-snuffleupagus.spec
+++ b/php-snuffleupagus.spec
@@ -35,7 +35,7 @@ Version: 0.5.0
%if 0%{?gh_date}
Release: 2%{gh_date}.%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 4%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
License: LGPLv3
Group: Development/Languages
@@ -49,6 +49,10 @@ BuildRequires: %{?scl_prefix}php-devel > 7
BuildRequires: pcre-devel
# For tests/upload_validation_real.phpt
BuildRequires: %{?scl_prefix}php-vld
+BuildRequires: %{?scl_prefix}php-curl
+BuildRequires: %{?scl_prefix}php-dom
+BuildRequires: %{?scl_prefix}php-simplexml
+BuildRequires: %{?scl_prefix}php-xml
#BuildRequires: gdb
#BuildRequires: php-debuginfo
@@ -171,6 +175,9 @@ install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
%check
sed -e 's:#!/usr/bin/env php:#!%{__php}:' -i scripts/upload_validation.php
+# add extensions used by test suite
+TEST_DEPS="-d extension=xml.so -d extension=dom.so -d extension=curl.so -d extension=simplexml.so"
+
cd src
: Minimal load test for NTS extension
%{__php} --no-php-ini \
@@ -180,7 +187,7 @@ cd src
: Upstream test suite for NTS extension
TEST_PHP_EXECUTABLE=%{__php} \
-TEST_PHP_ARGS="-n -d extension=$PWD/modules/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n $TEST_DEPS -d extension=$PWD/modules/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__php} -n run-tests.php --show-diff
@@ -195,7 +202,7 @@ cd ../ZTS
: Upstream test suite for ZTS extension
TEST_PHP_EXECUTABLE=%{__ztsphp} \
-TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+TEST_PHP_ARGS="-n $TEST_DEPS -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
NO_INTERACTION=1 \
REPORT_EXIT_STATUS=1 \
%{__ztsphp} -n run-tests.php --show-diff
@@ -218,6 +225,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Fri Feb 21 2020 Remi Collet <remi@remirepo.net> - 0.5.0-4
+- fix test suite
+
* Thu Feb 20 2020 Remi Collet <remi@remirepo.net> - 0.5.0-3
- add upstream patch to fix GCC 10 build