summaryrefslogtreecommitdiffstats
path: root/php-snappy.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-snappy.spec')
-rw-r--r--php-snappy.spec48
1 files changed, 33 insertions, 15 deletions
diff --git a/php-snappy.spec b/php-snappy.spec
index c23a464..bfcc9e2 100644
--- a/php-snappy.spec
+++ b/php-snappy.spec
@@ -7,15 +7,15 @@
# Please, preserve the changelog entries
#
%if 0%{?scl:1}
-%if "%{scl}" == "rh-php56"
-%global sub_prefix more-php56-
-%else
-%global sub_prefix %{scl_prefix}
-%endif
+%global sub_prefix %{scl_prefix}
%scl_package php-snappy
+%else
+%global pkg_name %{name}
%endif
-%global gh_commit be30d1bf298f0369bab9c3dbeee3986260e698b1
+%global with_libsnappy 0
+
+%global gh_commit eeaf10c34cbaf6953f61fd4b6ac57075c72fc8d6
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner kjdev
%global gh_project php-ext-snappy
@@ -26,20 +26,29 @@
Summary: Snappy Extension for PHP
Name: %{?sub_prefix}php-snappy
-Version: 0.1.7
+Version: 0.1.8
%if 0%{?gh_date:1}
Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
+%if %{?with_libsnappy}
License: PHP
+%else
+License: PHP and BSD
+%endif
Group: Development/Languages
URL: https://github.com/%{gh_owner}/%{gh_project}
-Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+Source0: %{pkg_name}-%{version}-%{gh_short}.tgz
+# retrieve a recursive git snapshot with submodule
+Source1: makesrc.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildRequires: %{?scl_prefix}php-devel
+%if %{?with_libsnappy}
BuildRequires: snappy-devel
+%else
+Provides: bundled(snappy) = 1.1.7
+%endif
Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
@@ -91,8 +100,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{gh_project}-%{gh_commit} NTS
cd NTS
+%if %{?with_libsnappy}
# Use the system library
rm -r snappy
+%else
+# Refresh snappy License file
+cp -r snappy/COPYING COPYING.snappy
+%endif
# Sanity check, really often broken
extver=$(sed -n '/#define SNAPPY_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_snappy.h)
@@ -121,7 +135,9 @@ cd NTS
%{_bindir}/phpize
%configure \
--with-php-config=%{_bindir}/php-config \
+%if %{?with_libsnappy}
--with-snappy-includedir=/usr \
+%endif
--with-libdir=%{_lib} \
--enable-snappy
make %{?_smp_mflags}
@@ -131,7 +147,9 @@ cd ../ZTS
%{_bindir}/zts-phpize
%configure \
--with-php-config=%{_bindir}/zts-php-config \
+%if %{?with_libsnappy}
--with-snappy-includedir=/usr \
+%endif
--with-libdir=%{_lib} \
--enable-snappy
make %{?_smp_mflags}
@@ -139,7 +157,6 @@ make %{?_smp_mflags}
%install
-rm -rf %{buildroot}
%{?dtsenable}
# Install the NTS stuff
@@ -184,14 +201,12 @@ REPORT_EXIT_STATUS=1 \
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license NTS/LICENSE
+%if ! %{?with_libsnappy}
+%license NTS/COPYING.snappy
+%endif
%doc NTS/CREDITS
%doc NTS/README.md
@@ -205,6 +220,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Aug 28 2017 Remi Collet <remi@remirepo.net> - 0.1.8-1
+- update to 0.1.8 with bundled libsnappy 1.1.7
+
* Wed Jul 19 2017 Remi Collet <remi@remirepo.net> - 0.1.7-1
- update to 0.1.7 (no change)