summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-09-06 16:27:09 +0200
committerRemi Collet <fedora@famillecollet.com>2016-09-06 16:27:09 +0200
commitd30b25f692df7c08cb6ec26b111277fcc6ae7638 (patch)
treeb231bcf42481392897c15c1964bbb6e87fa9148c
php-snappy: 0.1.3 - New package
-rw-r--r--Makefile4
-rw-r--r--REFLECTION18
-rw-r--r--php-ext-snappy-pr4.patch107
-rw-r--r--php-snappy.spec210
4 files changed, 339 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..c3ee497
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,18 @@
+Extension [ <persistent> extension #112 snappy version 0.1.3 ] {
+
+ - Functions {
+ Function [ <internal:snappy> function snappy_compress ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+ Function [ <internal:snappy> function snappy_uncompress ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $data ]
+ }
+ }
+ }
+}
+
diff --git a/php-ext-snappy-pr4.patch b/php-ext-snappy-pr4.patch
new file mode 100644
index 0000000..d304a95
--- /dev/null
+++ b/php-ext-snappy-pr4.patch
@@ -0,0 +1,107 @@
+From 0416fc87704f29badb669915ad78e1c3084e2fcd Mon Sep 17 00:00:00 2001
+From: Remi Collet <fedora@famillecollet.com>
+Date: Tue, 6 Sep 2016 15:51:14 +0200
+Subject: [PATCH] add support for build with sytem library
+
+---
+ config.m4 | 41 ++++++++++++++++++++++++++++++++++-------
+ snappy.c | 6 +++++-
+ tests/info.phpt | 2 +-
+ 3 files changed, 40 insertions(+), 9 deletions(-)
+
+diff --git a/config.m4 b/config.m4
+index 94837ec..2d06e98 100644
+--- a/config.m4
++++ b/config.m4
+@@ -25,10 +25,40 @@ PHP_ARG_ENABLE(snappy, whether to enable snappy support,
+ [ --enable-snappy Enable snappy support])
+
+ PHP_ARG_WITH(snappy-includedir, for snappy header,
+-[ --with-snappy-includedir=DIR snappy header files], yes)
++[ --with-snappy-includedir=DIR snappy header files], no, no)
+
+ if test "$PHP_SNAPPY" != "no"; then
+
++ AC_MSG_CHECKING([searching for libsnappy])
++
++ if test "$PHP_SNAPPY_INCLUDEDIR" != "no"; then
++ for i in $PHP_SNAPPY_INCLUDEDIR /usr/local /usr; do
++ if test -r $i/include/snappy-c.h; then
++ LIBSNAPPY_CFLAGS="-I$i/include"
++ LIBSNAPPY_LIBDIR="$i/$PHP_LIBDIR"
++ AC_MSG_RESULT(found in $i)
++ break
++ fi
++ done
++ if test -z "$LIBSNAPPY_LIBDIR"; then
++ AC_MSG_RESULT(not found)
++ AC_MSG_ERROR(Please reinstall the snappy library distribution)
++ fi
++ PHP_CHECK_LIBRARY(snappy, snappy_compress,
++ [
++ PHP_ADD_LIBRARY_WITH_PATH(snappy, $LIBSNAPPY_LIBDIR, SNAPPY_SHARED_LIBADD)
++ AC_DEFINE(HAVE_LIBSNAPPY,1,[ ])
++ ], [
++ AC_MSG_ERROR(could not find usable libsnappy)
++ ], [
++ -L$LIBSNAPPY_LIBDIR
++ ])
++
++ PHP_SUBST(SNAPPY_SHARED_LIBADD)
++ PHP_NEW_EXTENSION(snappy, snappy.c, $ext_shared,, $LIBSNAPPY_CFLAGS)
++ else
++ AC_MSG_RESULT(use bundled version)
++
+ dnl compiler C++:
+ PHP_REQUIRE_CXX()
+
+@@ -121,10 +151,7 @@ if test "$PHP_SNAPPY" != "no"; then
+
+ PHP_NEW_EXTENSION(snappy, snappy.c $SNAPPY_SOURCES, $ext_shared)
+
+- ifdef([PHP_INSTALL_HEADERS],
+- [
+- PHP_INSTALL_HEADERS([ext/snappy/], [php_snappy.h])
+- ], [
+- PHP_ADD_MAKEFILE_FRAGMENT
+- ])
++ PHP_ADD_BUILD_DIR($ext_builddir/snappy, 1)
++ PHP_ADD_INCLUDE([$ext_srcdir/snappy])
++ fi
+ fi
+diff --git a/snappy.c b/snappy.c
+index b76fae9..9ffba4b 100644
+--- a/snappy.c
++++ b/snappy.c
+@@ -9,7 +9,7 @@
+ #include "php_snappy.h"
+
+ /* snappy */
+-#include "snappy/snappy-c.h"
++#include <snappy-c.h>
+
+ static ZEND_FUNCTION(snappy_compress);
+ static ZEND_FUNCTION(snappy_uncompress);
+@@ -33,7 +33,11 @@ PHP_MINFO_FUNCTION(snappy)
+ php_info_print_table_start();
+ php_info_print_table_row(2, "Snappy support", "enabled");
+ php_info_print_table_row(2, "Extension Version", SNAPPY_EXT_VERSION);
++#ifdef HAVE_LIBSNAPPY
++ php_info_print_table_row(2, "Snappy Version", "system library");
++#else
+ php_info_print_table_row(2, "Snappy Version", SNAPPY_LIB_VERSION);
++#endif
+ php_info_print_table_end();
+ }
+
+diff --git a/tests/info.phpt b/tests/info.phpt
+index 98939aa..f163823 100644
+--- a/tests/info.phpt
++++ b/tests/info.phpt
+@@ -14,5 +14,5 @@ snappy
+
+ Snappy support => enabled
+ Extension Version => %d.%d.%d
+-Snappy Version => %d.%d.%d
++Snappy Version => %s
+ %a
diff --git a/php-snappy.spec b/php-snappy.spec
new file mode 100644
index 0000000..7a4dc4d
--- /dev/null
+++ b/php-snappy.spec
@@ -0,0 +1,210 @@
+# remirepo spec file for php-snappy
+#
+# Copyright (c) 2016 Remi Collet
+# License: CC-BY-SA
+# http://creativecommons.org/licenses/by-sa/4.0/
+#
+# Please, preserve the changelog entries
+#
+%if 0%{?scl:1}
+%if "%{scl}" == "rh-php56"
+%global sub_prefix more-php56-
+%else
+%global sub_prefix %{scl_prefix}
+%endif
+%scl_package php-snappy
+%endif
+
+%global gh_commit 9b0357f39335ecd36858b05ace09a47f46b493c5
+%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
+%global gh_owner kjdev
+%global gh_project php-ext-snappy
+#global gh_date 20160608
+%global pecl_name snappy
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global ini_name 40-%{pecl_name}.ini
+
+Summary: Snappy Extension for PHP
+Name: %{?sub_prefix}php-snappy
+Version: 0.1.3
+%if 0%{?gh_date:1}
+Release: 0.1.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%else
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+%endif
+License: PHP
+Group: Development/Languages
+URL: https://github.com/%{gh_owner}/%{gh_project}
+Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{gh_project}-%{version}-%{gh_short}.tar.gz
+
+Patch0: %{gh_project}-pr4.patch
+
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
+BuildRequires: %{?scl_prefix}php-devel
+BuildRequires: snappy-devel
+
+Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
+Requires: %{?scl_prefix}php(api) = %{php_core_api}
+%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
+
+%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1}
+# Other third party repo stuff
+Obsoletes: php53-%{pecl_name} <= %{version}
+Obsoletes: php53u-%{pecl_name} <= %{version}
+Obsoletes: php54-%{pecl_name} <= %{version}
+Obsoletes: php54w-%{pecl_name} <= %{version}
+%if "%{php_version}" > "5.5"
+Obsoletes: php55u-%{pecl_name} <= %{version}
+Obsoletes: php55w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "5.6"
+Obsoletes: php56u-%{pecl_name} <= %{version}
+Obsoletes: php56w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.0"
+Obsoletes: php70u-%{pecl_name} <= %{version}
+Obsoletes: php70w-%{pecl_name} <= %{version}
+%endif
+%if "%{php_version}" > "7.1"
+Obsoletes: php71u-%{pecl_name} <= %{version}
+Obsoletes: php71w-%{pecl_name} <= %{version}
+%endif
+%endif
+
+%if 0%{?fedora} < 20 && 0%{?rhel} < 7
+# Filter shared private
+%{?filter_provides_in: %filter_provides_in %{_libdir}/.*\.so$}
+%{?filter_setup}
+%endif
+
+
+%description
+This extension allows Snappy, a compression/decompression library.
+
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
+
+
+%prep
+%setup -qc
+mv %{gh_project}-%{gh_commit} NTS
+
+cd NTS
+# Use the system library
+%patch0 -p1 -b .pr4
+rm -r snappy
+
+# Sanity check, really often broken
+extver=$(sed -n '/#define SNAPPY_EXT_VERSION/{s/.* "//;s/".*$//;p}' php_snappy.h)
+if test "x${extver}" != "x%{version}%{?gh_date:-dev}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{version}%{?gh_date:-dev}.
+ exit 1
+fi
+cd ..
+
+%if %{with_zts}
+# duplicate for ZTS build
+cp -pr NTS ZTS
+%endif
+
+# Drop in the bit of configuration
+cat << 'EOF' | tee %{ini_name}
+; Enable '%{summary}' extension module
+extension = %{pecl_name}.so
+EOF
+
+
+%build
+cd NTS
+%{_bindir}/phpize
+%configure \
+ --with-php-config=%{_bindir}/php-config \
+ --with-snappy-includedir=/usr \
+ --with-libdir=%{_lib} \
+ --enable-snappy
+make %{?_smp_mflags}
+
+%if %{with_zts}
+cd ../ZTS
+%{_bindir}/zts-phpize
+%configure \
+ --with-php-config=%{_bindir}/zts-php-config \
+ --with-snappy-includedir=/usr \
+ --with-libdir=%{_lib} \
+ --enable-snappy
+make %{?_smp_mflags}
+%endif
+
+
+%install
+rm -rf %{buildroot}
+# Install the NTS stuff
+make -C NTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_inidir}/%{ini_name}
+
+%if %{with_zts}
+# Install the ZTS stuff
+make -C ZTS install INSTALL_ROOT=%{buildroot}
+install -D -m 644 %{ini_name} %{buildroot}%{php_ztsinidir}/%{ini_name}
+%endif
+
+
+
+%check
+: Ignore failed test as everything seems ok
+rm ?TS/tests/003.phpt
+
+cd NTS
+: Minimal load test for NTS extension
+%{__php} --no-php-ini \
+ --define extension=%{buildroot}%{php_extdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for NTS extension
+TEST_PHP_EXECUTABLE=%{__php} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_extdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__php} -n run-tests.php --show-diff || : ignore
+
+%if %{with_zts}
+cd ../ZTS
+: Minimal load test for ZTS extension
+%{__ztsphp} --no-php-ini \
+ --define extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so \
+ --modules | grep %{pecl_name}
+
+: Upstream test suite for ZTS extension
+TEST_PHP_EXECUTABLE=%{__ztsphp} \
+TEST_PHP_ARGS="-n -d extension=%{buildroot}%{php_ztsextdir}/%{pecl_name}.so" \
+NO_INTERACTION=1 \
+REPORT_EXIT_STATUS=1 \
+%{__ztsphp} -n run-tests.php --show-diff
+%endif
+
+
+%clean
+rm -rf %{buildroot}
+
+
+%files
+%defattr(-,root,root,-)
+%{!?_licensedir:%global license %%doc}
+%license NTS/LICENSE
+%doc NTS/CREDITS
+%doc NTS/README.md
+
+%config(noreplace) %{php_inidir}/%{ini_name}
+%{php_extdir}/%{pecl_name}.so
+
+%if %{with_zts}
+%config(noreplace) %{php_ztsinidir}/%{ini_name}
+%{php_ztsextdir}/%{pecl_name}.so
+%endif
+
+
+%changelog
+* Tue Sep 6 2016 Remi Collet <remi@fedoraproject.org> - 0.1.3-1
+- new package, version 0.1.3
+- add patch to build with system libsnappy
+ open https://github.com/kjdev/php-ext-snappy/pull/4
+