summaryrefslogtreecommitdiffstats
path: root/php-smbclient.spec
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-04-03 08:03:27 +0200
committerRemi Collet <remi@php.net>2023-04-03 08:03:27 +0200
commite8efd658b28f8f07c3555d011113c01d88aada39 (patch)
tree93f605c081392bf40f607f9b63e3587a33550958 /php-smbclient.spec
parente97d954577fe0036e8e3f8ba06a19ba04dc6aef0 (diff)
update to 1.1.0
drop patch merged upstream
Diffstat (limited to 'php-smbclient.spec')
-rw-r--r--php-smbclient.spec51
1 files changed, 19 insertions, 32 deletions
diff --git a/php-smbclient.spec b/php-smbclient.spec
index 6a7fcde..8c55e6b 100644
--- a/php-smbclient.spec
+++ b/php-smbclient.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-smbclient
#
-# Copyright (c) 2015-2022 Remi Collet
-# License: CC-BY-SA
+# Copyright (c) 2015-2023 Remi Collet
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -11,7 +11,6 @@
%if 0%{?scl:1}
-%global sub_prefix %{scl_prefix}
%scl_package php-smbclient
%else
%global pkg_name %{name}
@@ -32,36 +31,35 @@
%global ini_name 40-%{pecl_name}.ini
%endif
# Test suite requires a Samba server and configuration file
-%global with_tests 0%{?_with_tests:1}
+%bcond_with tests
-Name: %{?sub_prefix}php-smbclient
-Version: 1.0.6
+
+Name: %{?scl_prefix}php-smbclient
+Version: 1.1.0
%if 0%{?gh_date}
Release: 0.9.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 6%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
Summary: PHP wrapper for libsmbclient
-License: BSD
+License: BSD-2-Clause
URL: https://github.com/eduardok/libsmbclient-php
%if 0%{?gh_date}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
%else
Source0: https://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
%endif
-%if %{with_tests}
+%if %{with tests}
Source2: %{pecl_name}-phpunit.xml
%endif
-Patch0: %{pecl_name}-stub.patch
-
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libsmbclient-devel > 3.6
-%if %{with_tests}
+%if %{with tests}
BuildRequires: php-composer(phpunit/phpunit)
BuildRequires: samba
%endif
@@ -70,20 +68,16 @@ Requires: %{?scl_prefix}php(zend-abi) = %{php_zend_api}
Requires: %{?scl_prefix}php(api) = %{php_core_api}
%{?_sclreq:Requires: %{?scl_prefix}runtime%{?_sclreq}%{?_isa}}
# Rename
-Obsoletes: %{?sub_prefix}php-libsmbclient < 0.8.0-0.2
-Provides: %{?sub_prefix}php-libsmbclient = %{version}-%{release}
-Provides: %{?sub_prefix}php-libsmbclient%{?_isa} = %{version}-%{release}
-%if "%{?scl_prefix}" != "%{?sub_prefix}"
-Provides: %{?scl_prefix}php-%{pecl_name} = %{version}-%{release}
-Provides: %{?scl_prefix}php-%{pecl_name}%{?_isa} = %{version}-%{release}
-%endif
+Obsoletes: %{?scl_prefix}php-libsmbclient < 0.8.0-0.2
+Provides: %{?scl_prefix}php-libsmbclient = %{version}-%{release}
+Provides: %{?scl_prefix}php-libsmbclient%{?_isa} = %{version}-%{release}
# PECL
Provides: %{?scl_prefix}php-pecl-%{pecl_name} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl-%{pecl_name}%{?_isa} = %{version}-%{release}
Provides: %{?scl_prefix}php-pecl(%{pecl_name}) = %{version}
Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
-%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
+%if "%{?packager}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel} == 7
# Other third party repo stuff
%if "%{php_version}" > "7.0"
Obsoletes: php70u-pecl-%{pecl_name} <= %{version}
@@ -97,15 +91,6 @@ Obsoletes: php72u-pecl-%{pecl_name} <= %{version}
%if "%{php_version}" > "7.3"
Obsoletes: php73-pecl-%{pecl_name} <= %{version}
%endif
-%if "%{php_version}" > "7.4"
-Obsoletes: php74-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.0"
-Obsoletes: php80-pecl-%{pecl_name} <= %{version}
-%endif
-%if "%{php_version}" > "8.1"
-Obsoletes: php81-pecl-%{pecl_name} <= %{version}
-%endif
%endif
@@ -132,8 +117,6 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
-%patch0 -p1
-
# Check extension version
ver=$(sed -n '/define PHP_SMBCLIENT_VERSION/{s/.* "//;s/".*$//;p}' php_smbclient.h)
if test "$ver" != "%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -205,7 +188,7 @@ done
--modules | grep '^%{pecl_name}$'
%endif
-%if %{with_tests}
+%if %{with tests}
: Upstream test suite for NTS extension
cd NTS
cp %{SOURCE2} phpunit.xml
@@ -251,6 +234,10 @@ fi
%changelog
+* Mon Apr 3 2023 Remi Collet <remi@remirepo.net> - 1.1.0-1
+- update to 1.1.0
+- drop patch merged upstream
+
* Mon Feb 7 2022 Remi Collet <remi@remirepo.net> - 1.0.6-6
- add fix from https://github.com/eduardok/libsmbclient-php/pull/94