summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-06-27 13:32:26 +0200
committerRemi Collet <remi@remirepo.net>2018-06-27 13:32:26 +0200
commite36d4eff9c14c5e2d0650ed90f69c3784ebf157d (patch)
tree4f11fc26da148be7c393a9228ff4a609258e308c
parent8388f91095590d864d88fffab420131adbd617a5 (diff)
add patch for PHP 7.3 from https://github.com/eduardok/libsmbclient-php/pull/60
-rw-r--r--PHPINFO6
-rw-r--r--php-smbclient.spec31
2 files changed, 26 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
new file mode 100644
index 0000000..50c92dd
--- /dev/null
+++ b/PHPINFO
@@ -0,0 +1,6 @@
+
+smbclient
+
+smbclient Support => enabled
+smbclient extension Version => 0.9.0
+libsmbclient library Version => 4.7.7
diff --git a/php-smbclient.spec b/php-smbclient.spec
index b2d94e3..750bb60 100644
--- a/php-smbclient.spec
+++ b/php-smbclient.spec
@@ -1,11 +1,15 @@
# remirepo spec file for php-smbclient
#
-# Copyright (c) 2015-2017 Remi Collet
+# Copyright (c) 2015-2018 Remi Collet
# License: CC-BY-SA
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
#
+# we don't want -z defs linker flag
+%undefine _strict_symbol_defs_build
+
+
%if 0%{?scl:1}
%global sub_prefix %{scl_prefix}
%scl_package php-smbclient
@@ -21,7 +25,7 @@
#global prever RC1
%global pecl_name smbclient
-%global with_zts 0%{?__ztsphp:1}
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%if "%{php_version}" < "5.6"
%global ini_name %{pecl_name}.ini
%else
@@ -35,12 +39,11 @@ Version: 0.9.0
%if 0%{?gh_date}
Release: 0.3.%{gh_date}git%{gh_short}%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%else
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Release: 5%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
%endif
Summary: PHP wrapper for libsmbclient
-Group: Development/Languages
License: BSD
URL: https://github.com/eduardok/libsmbclient-php
%if 0%{?gh_date}
@@ -52,6 +55,9 @@ Source0: http://pecl.php.net/get/%{pecl_name}-%{version}%{?prever}.tgz
Source2: %{gh_project}-phpunit.xml
%endif
+Patch0: https://patch-diff.githubusercontent.com/raw/eduardok/libsmbclient-php/pull/60.patch
+
+BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: libsmbclient-devel > 3.6
@@ -79,12 +85,6 @@ Provides: %{?scl_prefix}php-pecl(%{pecl_name})%{?_isa} = %{version}
%if "%{?vendor}" == "Remi Collet" && 0%{!?scl:1} && 0%{?rhel}
# Other third party repo stuff
-%if "%{php_version}" > "5.5"
-Obsoletes: php55u-%{pecl_name} <= %{version}
-Obsoletes: php55u-pecl-%{pecl_name} <= %{version}
-Obsoletes: php55w-%{pecl_name} <= %{version}
-Obsoletes: php55w-pecl-%{pecl_name} <= %{version}
-%endif
%if "%{php_version}" > "5.6"
Obsoletes: php56u-%{pecl_name} <= %{version}
Obsoletes: php56u-pecl-%{pecl_name} <= %{version}
@@ -141,6 +141,8 @@ sed -e 's/role="test"/role="src"/' \
-i package.xml
cd NTS
+%patch0 -p1 -b .pr60
+
# Check extension version
ver=$(sed -n '/define PHP_SMBCLIENT_VERSION/{s/.* "//;s/".*$//;p}' php_smbclient.h)
if test "$ver" != "%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -223,7 +225,7 @@ cp %{SOURCE2} phpunit.xml
%endif
-%if 0%{?fedora} < 24
+%if 0%{?fedora} < 24 && 0%{?rhel} < 8
# when pear installed alone, after us
%triggerin -- %{?scl_prefix}php-pear
if [ -x %{__pecl} ] ; then
@@ -258,6 +260,13 @@ fi
%changelog
+* Wed Jun 27 2018 Remi Collet <remi@remirepo.net> - 0.9.0-5
+- add patch for PHP 7.3 from
+ https://github.com/eduardok/libsmbclient-php/pull/60
+
+* Tue May 15 2018 Remi Collet <remi@remirepo.net> - 0.9.0-4
+- rebuild
+
* Tue Jul 18 2017 Remi Collet <remi@remirepo.net> - 0.9.0-3
- rebuild for PHP 7.2.0beta1 new API