summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-06-21 09:34:45 +0200
committerRemi Collet <fedora@famillecollet.com>2016-06-21 09:34:45 +0200
commit2f0d38e8c4c43ec2b4220840534883c8d4e0be4f (patch)
tree0c8065028a968d397dd8a767367e921cb21d7f04
parent2d303fa03bd0165bf15fed8cc6029828cc5a17c7 (diff)
php-slim3: 3.4.2
-rw-r--r--Makefile4
-rw-r--r--composer.json57
-rwxr-xr-xphp-slim3-makesrc.sh2
-rw-r--r--php-slim3.spec20
4 files changed, 79 insertions, 4 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..91b0fd5
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,4 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+include ../../common/Makefile
+
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..808eb9d
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,57 @@
+{
+ "name": "slim/slim",
+ "type": "library",
+ "description": "Slim is a PHP micro framework that helps you quickly write simple yet powerful web applications and APIs",
+ "keywords": ["framework","micro","api","router"],
+ "homepage": "http://slimframework.com",
+ "license": "MIT",
+ "authors": [
+ {
+ "name": "Josh Lockhart",
+ "email": "hello@joshlockhart.com",
+ "homepage": "https://joshlockhart.com"
+ },
+ {
+ "name": "Andrew Smith",
+ "email": "a.smith@silentworks.co.uk",
+ "homepage": "http://silentworks.co.uk"
+ },
+ {
+ "name": "Rob Allen",
+ "email": "rob@akrabat.com",
+ "homepage": "http://akrabat.com"
+ },
+ {
+ "name": "Gabriel Manricks",
+ "email": "gmanricks@me.com",
+ "homepage": "http://gabrielmanricks.com"
+ }
+ ],
+ "require": {
+ "php": ">=5.5.0",
+ "pimple/pimple": "^3.0",
+ "psr/http-message": "^1.0",
+ "nikic/fast-route": "^1.0",
+ "container-interop/container-interop": "^1.1"
+ },
+ "require-dev": {
+ "squizlabs/php_codesniffer": "^2.5",
+ "phpunit/phpunit": "^4.0"
+ },
+ "provide": {
+ "psr/http-message-implementation": "1.0"
+ },
+ "autoload": {
+ "psr-4": {
+ "Slim\\": "Slim"
+ }
+ },
+ "scripts": {
+ "test": [
+ "@phpunit",
+ "@phpcs"
+ ],
+ "phpunit": "php vendor/bin/phpunit",
+ "phpcs": "php vendor/bin/phpcs"
+ }
+}
diff --git a/php-slim3-makesrc.sh b/php-slim3-makesrc.sh
index 080b7ad..a1e294f 100755
--- a/php-slim3-makesrc.sh
+++ b/php-slim3-makesrc.sh
@@ -16,7 +16,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
-cp composer.json ../composer-$VERSION.json
+cp composer.json ../composer.json
popd
echo "Archiving..."
diff --git a/php-slim3.spec b/php-slim3.spec
index 32bd5ba..b9a0f9d 100644
--- a/php-slim3.spec
+++ b/php-slim3.spec
@@ -1,3 +1,5 @@
+# remirepo spec file for php-slim3, from
+#
# Fedora spec file for php-slim3
#
# License: MIT
@@ -5,12 +7,12 @@
#
# Please preserve changelog entries
-%global gh_commit 794073a27b2dd9ef492124263038291b7f8daeb3
+%global gh_commit a132385f736063d00632b52b3f8a389fe66fe4fa
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner slimphp
%global gh_project Slim
%global pk_project slim
-%global gh_version 3.4.1
+%global gh_version 3.4.2
%global php_home %{_datadir}/php
%global slim_home %{php_home}/Slim3
@@ -131,11 +133,20 @@ sed -e \
-e "s|\$autoloader->addPsr4.*$|require 'autoload.php';|" \
-i tests/bootstrap.php
+ret=0
+
# OK (Tests: 512, Assertions: 820, Skipped: 13)
%{_bindir}/phpunit \
-d memory_limit=-1 \
- tests
+ tests || ret=1
+if which php71; then
+ php71 %{_bindir}/phpunit \
+ -d memory_limit=-1 \
+ tests || ret=1
+fi
+
+exit $ret
%clean
rm -rf %{buildroot}
@@ -151,6 +162,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Jun 21 2016 Remi Collet <remi@fedoraproject.org> - 3.4.2-1
+- update to 3.4.2
+
* Tue May 17 2016 Johan Cwiklinski <johan AT x-tnd DOT be> - 3.4.1-1
- Update to Slim 3
- Use a git snapshot as upstream drop tests from distribution (thanks to Remi)