summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-27 07:41:09 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-27 07:41:09 +0100
commitcf54d55b0591d8299b7f42162b1f613b01ce856a (patch)
tree8bab43490061388ccad283a204c20eac7fa75634
parent65bed2d1a6f17b66ef0eb4aaf26bc2b3cb52f52e (diff)
php-simplepie: 1.4.3
-rw-r--r--composer.json6
-rw-r--r--php-simplepie-php71.patch22
-rw-r--r--php-simplepie.spec21
3 files changed, 17 insertions, 32 deletions
diff --git a/composer.json b/composer.json
index 7620585..b5965b2 100644
--- a/composer.json
+++ b/composer.json
@@ -26,6 +26,12 @@
"require": {
"php": ">=5.3.0"
},
+ "require-dev": {
+ "phpunit/phpunit": "~4 || ~5"
+ },
+ "suggest": {
+ "mf2/mf2": "Microformat module that allows for parsing HTML for microformats"
+ },
"autoload": {
"psr-0": {
"SimplePie": "library"
diff --git a/php-simplepie-php71.patch b/php-simplepie-php71.patch
deleted file mode 100644
index 0f16a20..0000000
--- a/php-simplepie-php71.patch
+++ /dev/null
@@ -1,22 +0,0 @@
-From 1111dab1baced14aaf05509c41ee416c3fc6a961 Mon Sep 17 00:00:00 2001
-From: Remi Collet <remi@famillecollet.com>
-Date: Thu, 7 Jul 2016 08:20:40 +0200
-Subject: [PATCH] Fix for PHP 7.1
-
----
- library/SimplePie/Parse/Date.php | 2 +-
- 1 file changed, 1 insertion(+), 1 deletion(-)
-
-diff --git a/library/SimplePie/Parse/Date.php b/library/SimplePie/Parse/Date.php
-index a415ba6..226f453 100644
---- a/library/SimplePie/Parse/Date.php
-+++ b/library/SimplePie/Parse/Date.php
-@@ -690,7 +690,7 @@ public function date_w3cdtf($date)
- }
-
- // Convert the number of seconds to an integer, taking decimals into account
-- $second = round($match[6] + $match[7] / pow(10, strlen($match[7])));
-+ $second = round((int)$match[6] + (int)$match[7] / pow(10, strlen($match[7])));
-
- return gmmktime($match[4], $match[5], $second, $match[2], $match[3], $match[1]) - $timezone;
- }
diff --git a/php-simplepie.spec b/php-simplepie.spec
index 0d219f8..c1b7514 100644
--- a/php-simplepie.spec
+++ b/php-simplepie.spec
@@ -7,14 +7,14 @@
#
# Please preserve changelog entries
#
-%global gh_commit 9b775e88ba1128fa14c69ff94ab954d86067de2a
+%global gh_commit 2a24b6e74aa9bf33243020f52895fe77efe94ccf
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner simplepie
%global gh_project simplepie
%global with_tests 0%{!?_without_tests:1}
Name: php-simplepie
-Version: 1.4.2
+Version: 1.4.3
Release: 1%{?dist}
Summary: A simple Atom/RSS parsing library for PHP
@@ -27,8 +27,6 @@ Source1: makesrc.sh
# Adapt autoloader for installation tree
Patch0: %{name}-rpm.patch
-# https://github.com/simplepie/simplepie/pull/458
-Patch1: %{name}-php71.patch
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXXX)
BuildArch: noarch
@@ -63,7 +61,6 @@ Autoloader: %{_datadir}/php/%{name}/autoloader.php
%setup -q -n %{gh_project}-%{gh_commit}
%patch0 -p1 -b .rpm
-%patch1 -p1
find . -type f -exec chmod -x {} \;
rm demo/cache/.gitignore
@@ -86,23 +83,24 @@ install -pm 644 autoloader.php \
sed -e 's:@PATH@:%{buildroot}/%{_datadir}/php/%{name}:' \
-i tests/bootstrap.php
+# Known failed test with PHP 7+
+rm tests/IRITest.php
+rm tests/oldtests/first_item_title/SPtests/bugs/179.0.10.php
+
+# remirepo:11
run=0
ret=0
if which php56; then
php56 %{_bindir}/phpunit || ret=1
run=1
fi
-
-# Known failed test with PHP 7+
-rm tests/IRITest.php
-rm tests/oldtests/first_item_title/SPtests/bugs/179.0.10.php
-
if which php71; then
php71 %{_bindir}/phpunit || ret=1
run=1
fi
if [ $run -eq 0 ]; then
%{_bindir}/phpunit --verbose
+# remirepo:2
fi
exit $ret
@@ -118,6 +116,9 @@ rm -rf %{buildroot}
%changelog
+* Sun Nov 27 2016 Remi Collet <remi@fedoraproject.org> - 1.4.3-1
+- update to 1.4.3
+
* Thu Jul 7 2016 Remi Collet <remi@fedoraproject.org> - 1.4.2-1
- update to 1.4.2
- sources from git snapshot