summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2020-07-01 15:13:11 +0200
committerRemi Collet <remi@remirepo.net>2020-07-01 15:13:11 +0200
commit562641ccbb7fc5f3bd35d252ebf8a463dfb94c43 (patch)
tree97d3a9a184d616644d2463d66633ef4ee2352411
parentc8fcf63bdfeb6a3b6baf4400ba1ebfd9c7416595 (diff)
update to 1.5.5
-rw-r--r--composer.json4
-rw-r--r--php-simplepie.spec16
2 files changed, 12 insertions, 8 deletions
diff --git a/composer.json b/composer.json
index dd13461..d76ee7d 100644
--- a/composer.json
+++ b/composer.json
@@ -12,8 +12,8 @@
"role": "Creator, alumnus developer"
},
{
- "name": "Geoffrey Sneddon",
- "homepage": "http://gsnedders.com/",
+ "name": "Sam Sneddon",
+ "homepage": "https://gsnedders.com/",
"role": "Alumnus developer"
},
{
diff --git a/php-simplepie.spec b/php-simplepie.spec
index cdf719c..06c887a 100644
--- a/php-simplepie.spec
+++ b/php-simplepie.spec
@@ -7,12 +7,12 @@
#
# Please preserve changelog entries
#
-%global gh_commit 20b30e4bbbed7fd2a6ffbab48e3a2e0f96087b6a
+%global gh_commit ae49e2201b6da9c808e5dac437aca356a11831b4
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner simplepie
%global gh_project simplepie
-%global gh_version 1.5.4
-%global with_tests 0%{!?_without_tests:1}
+%global gh_version 1.5.5
+%bcond_without tests
Name: php-%{gh_project}
Version: %{gh_version}
@@ -32,7 +32,7 @@ Source1: %{name}-makesrc.sh
Patch0: %{name}-rpm.patch
BuildArch: noarch
-%if %{with_tests}
+%if %{with tests}
# From composer.json, "require-dev"
# "phpunit/phpunit": "~5.4.3 || ~6.5"
# remirepo:1
@@ -108,13 +108,14 @@ install -pm 644 autoloader.php \
%{buildroot}/%{_datadir}/php/%{name}/autoloader.php
-%if %{with_tests}
+%if %{with tests}
%check
sed -e 's:@PATH@:%{buildroot}/%{_datadir}/php/%{name}:' \
-i tests/bootstrap.php
ret=0
-for cmdarg in "php %{phpunit}" "php56 %{_bindir}/phpunit" php70 php71 php72 php73 php74; do
+# TODO php 8 Errors: 1, Failures: 1.
+for cmdarg in "php %{phpunit}" php72 php73 php74; do
if which $cmdarg; then
set $cmdarg
$1 ${2:-%{_bindir}/phpunit6} --verbose || ret=1
@@ -134,6 +135,9 @@ exit $ret
%changelog
+* Wed Jul 1 2020 Remi Collet <remi@remirepo.net> - 1.5.5-1
+- update to 1.5.5
+
* Wed Dec 18 2019 Remi Collet <remi@remirepo.net> - 1.5.4-1
- update to 1.5.4
- drop patch merged upstream