summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-05-31 07:58:46 +0200
committerRemi Collet <fedora@famillecollet.com>2015-05-31 07:58:46 +0200
commitf6578e66501c2e46c58e1a9964a42de9f783ba7b (patch)
tree9e8656234eda988591758ca4ab0b935dba070982
parent767f8ce154962f86e0877825204e7c02e9d0febe (diff)
php-silex: backport stuff
-rw-r--r--Makefile10
-rw-r--r--php-silex.spec12
2 files changed, 22 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-silex.spec b/php-silex.spec
index 18de2cd..ea42575 100644
--- a/php-silex.spec
+++ b/php-silex.spec
@@ -1,3 +1,4 @@
+# remirepo spec file for php-silex, from Fedora:
#
# RPM spec file for php-silex
#
@@ -55,6 +56,7 @@ URL: http://silex.sensiolabs.org
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
BuildArch: noarch
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
# For autoload generation
BuildRequires: %{_bindir}/phpab
%if %{with_tests}
@@ -198,6 +200,8 @@ AUTOLOAD
%install
+rm -rf %{buildroot}
+
mkdir -p %{buildroot}%{phpdir}
cp -rp src/* %{buildroot}%{phpdir}
@@ -224,7 +228,12 @@ rm -f \
%endif
+%clean
+rm -rf %{buildroot}
+
+
%files
+%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc README.rst
@@ -234,6 +243,9 @@ rm -f \
%changelog
+* Sun May 31 2015 Remi Collet <remi@remirepo.net> - 1.2.4-3
+- backport in remi repository
+
* Wed May 20 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.2.4-3
- "%%{phpdir}/Pimple" => "%%{phpdir}/Pimple1"