summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2018-12-06 16:26:39 +0100
committerRemi Collet <remi@remirepo.net>2018-12-06 16:26:39 +0100
commitb5eaf1e92d2e6c51c99993a62968ca474f552b06 (patch)
treec290da8b707912a4e062795f8a6694258af6f947
parent9d6545bbf8ea6472e96722008bf54192e06c2bf0 (diff)
skip test relying on uopz extension
-rw-r--r--php-sentry.spec45
1 files changed, 13 insertions, 32 deletions
diff --git a/php-sentry.spec b/php-sentry.spec
index 8ef7a35..ec6aa98 100644
--- a/php-sentry.spec
+++ b/php-sentry.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-sentry
#
-# Copyright (c) 2016 Shawn Iwinski <shawn@iwin.ski>
+# Copyright (c) 2016-2018 Shawn Iwinski <shawn@iwin.ski>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -31,10 +31,9 @@
Name: php-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 6%{?github_release}%{?dist}
Summary: PHP client for Sentry
-Group: Development/Libraries
# ASL 2.0:
# - lib/Raven/Serializer.php
# BSD:
@@ -47,7 +46,6 @@ URL: https://github.com/%{github_owner}/%{github_name}
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root
BuildArch: noarch
# Library version value check
BuildRequires: php-cli
@@ -67,18 +65,12 @@ BuildRequires: php-reflection
BuildRequires: php-session
BuildRequires: php-spl
BuildRequires: php-zlib
-%if 0%{?fedora} >= 25
-# Required for PHPUnit with PHP 7
-# See https://github.com/getsentry/sentry-php/pull/365
-BuildRequires: php-uopz
-%endif
# Conflict because Monolog will load obsoleted package's autoloader and classes.
BuildConflicts: php-Raven
%endif
Requires: php-cli
-# use path as ca-certificates doesn't exists on EL-5
-Requires: /etc/pki/tls/cert.pem
+Requires: ca-certificates
# composer.json
Requires: php(language) >= %{php_min_ver}
Requires: php-composer(monolog/monolog) >= %{monolog_min_ver}
@@ -141,8 +133,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
-
mkdir -p %{buildroot}%{phpdir}
cp -rp lib/* %{buildroot}%{phpdir}/
@@ -170,33 +160,21 @@ require_once '%{buildroot}%{phpdir}/Raven/autoload.php';
BOOTSTRAP
: Run tests
-# remirepo:11
-run=0
ret=0
-if which php56; then
- php56 %{_bindir}/phpunit --bootstrap bootstrap.php || ret=1
- run=1
-fi
-if which php71; then
- php71 %{_bindir}/phpunit --bootstrap bootstrap.php || ret=1
- run=1
-fi
-if [ $run -eq 0 ]; then
-%{_bindir}/phpunit --verbose --bootstrap bootstrap.php
-# remirepo:2
-fi
+for cmd in php php70 php71 php72 php73; do
+ if which $cmd; then
+ $cmd %{_bindir}/phpunit \
+ --filter '^((?!(testCanTraceParamContext|testDoesFixFrameInfo)).)*$' \
+ --verbose --bootstrap bootstrap.php || ret=1
+ fi
+done
exit $ret
%else
: Tests skipped
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE
%doc *.rst
@@ -209,6 +187,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Dec 6 2018 Remi Collet <remi@remirepo.net> - 0.22.0-6
+- skip test relying on uopz extension
+
* Sun Nov 6 2016 Remi Collet <remi@remirepo.net> - 0.22.0-1
- add backport stuff for remi repo.