summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--Makefile10
-rw-r--r--php-scssphp.spec5
2 files changed, 15 insertions, 0 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-scssphp.spec b/php-scssphp.spec
index 9fa1565..41ae82f 100644
--- a/php-scssphp.spec
+++ b/php-scssphp.spec
@@ -16,6 +16,7 @@ License: MIT or GPLv3
URL: http://leafo.net/%{github_name}
Source0: https://github.com/%{github_owner}/%{github_name}/archive/%{github_commit}/%{name}-%{github_version}-%{github_commit}.tar.gz
+BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
BuildRequires: help2man
# For tests
@@ -78,6 +79,7 @@ install -p -m 644 pscss.1 %{buildroot}%{_mandir}/man1/
%files
+%defattr(-,root,root,-)
%doc *.md composer.json
%doc %{_mandir}/man1/pscss.1*
%{_datadir}/php/%{github_name}
@@ -85,6 +87,9 @@ install -p -m 644 pscss.1 %{buildroot}%{_mandir}/man1/
%changelog
+* Tue Mar 19 2013 Remi Collet <remi@fedoraproject.org> 0.0.5-1
+- backport 0.0.5 for remi repo.
+
* Sat Mar 16 2013 Shawn Iwinski <shawn.iwinski@gmail.com> 0.0.5-1
- Updated to version 0.0.5
- php-cli => php(language)