summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--.gitignore8
-rw-r--r--php-punic.spec24
2 files changed, 18 insertions, 14 deletions
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 0000000..fc9aa8c
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,8 @@
+clog
+package-*.xml
+*.tgz
+*.tar.gz
+*.tar.xz
+*.tar.xz.asc
+*.src.rpm
+*/*rpm
diff --git a/php-punic.spec b/php-punic.spec
index c62d009..edc13c9 100644
--- a/php-punic.spec
+++ b/php-punic.spec
@@ -2,7 +2,7 @@
#
# Fedora spec file for php-punic
#
-# Copyright (c) 2015-2017 Shawn Iwinski <shawn.iwinski@gmail.com>
+# Copyright (c) 2015-2019 Shawn Iwinski <shawn.iwinski@gmail.com>
#
# License: MIT
# http://opensource.org/licenses/MIT
@@ -28,10 +28,9 @@
Name: php-%{composer_project}
Version: %{github_version}
-Release: 1%{?github_release}%{?dist}
+Release: 7%{?github_release}%{?dist}
Summary: PHP-Unicode CLDR
-Group: Development/Libraries
# Code is MIT, data is Unicode
License: MIT and Unicode
URL: http://punic.github.io/
@@ -41,10 +40,7 @@ URL: http://punic.github.io/
Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
Source1: %{name}-get-source.sh
-BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-# Relative paths
-BuildRequires: python
# Tests
%if %{with_tests}
BuildRequires: php-composer(phpunit/phpunit)
@@ -112,8 +108,6 @@ AUTOLOAD
%install
-rm -rf %{buildroot}
-
: Library
mkdir -p %{buildroot}%{phpdir}/Punic
cp -rp code/* %{buildroot}%{phpdir}/Punic/
@@ -122,7 +116,11 @@ cp -rp code/* %{buildroot}%{phpdir}/Punic/
mkdir -p %{buildroot}%{_datadir}
mv %{buildroot}%{phpdir}/Punic/data %{buildroot}%{_datadir}/%{name}
ln -s \
+%if 0%{?rhel} == 6
../../%{name} \
+%else
+ $(realpath --canonicalize-missing --relative-to='%{phpdir}/Punic' '%{_datadir}/%{name}') \
+%endif
%{buildroot}%{phpdir}/Punic/data
@@ -138,7 +136,7 @@ BOOTSTRAP=%{buildroot}%{phpdir}/Punic/autoload.php
: Upstream tests with SCLs if available
SCL_RETURN_CODE=0
-for SCL in %{?rhel:php54 php55} php56 php70 php71; do
+for SCL in %{?rhel:php54 php55 php56} php70 php71 php72 php73; do
if which $SCL; then
$SCL %{_bindir}/phpunit --verbose --bootstrap $BOOTSTRAP || SCL_RETURN_CODE=1
fi
@@ -149,12 +147,7 @@ exit $SCL_RETURN_CODE
%endif
-%clean
-rm -rf %{buildroot}
-
-
%files
-%defattr(-,root,root,-)
%{!?_licensedir:%global license %%doc}
%license LICENSE.txt
%license UNICODE-LICENSE.txt
@@ -165,6 +158,9 @@ rm -rf %{buildroot}
%changelog
+* Mon Apr 29 2019 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.5-7
+- Fix install symlink
+
* Sat Mar 04 2017 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.5-1
- Update to 1.6.5 (RHBZ #1419293)
- Test with SCLs if available