summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-21 07:39:07 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-21 07:39:07 +0200
commit68ff47db7f51f51d03ed41b4a0387e57a9d1673c (patch)
treedbcf98581a1f7ed8827f6a00747f6703a2db146c
php-punic: import from Fedora
-rwxr-xr-xphp-punic-get-source.sh69
-rw-r--r--php-punic.spec158
2 files changed, 227 insertions, 0 deletions
diff --git a/php-punic-get-source.sh b/php-punic-get-source.sh
new file mode 100755
index 0000000..ba71f5d
--- /dev/null
+++ b/php-punic-get-source.sh
@@ -0,0 +1,69 @@
+#/bin/sh
+
+GIT=`which git`
+RPM=`which rpm`
+
+if [ -z "$GIT" ]
+then
+ echo "ERROR: 'git' command not found" 1>&2
+ exit 1
+elif [ -z "$RPM" ]
+then
+ echo "ERROR: 'rpm' command not found" 1>&2
+ exit 1
+fi
+
+function print {
+ echo -e "\e[0;33m>>>>> ${1}\e[0m"
+}
+
+if [ -x "$1" ]
+then
+ SPEC=$1
+else
+ SPEC=`ls *.spec | head -1`
+fi
+
+NAME=`echo $SPEC | sed 's#\.spec##'`
+VERSION=`egrep '%global\s*github_version' $SPEC | awk '{print $3}'`
+
+print "SPEC = $SPEC"
+print "NAME = $NAME"
+
+GIT_OWNER=`egrep '%global\s*github_owner' $SPEC | awk '{print $3}'`
+GIT_NAME=`egrep '%global\s*github_name' $SPEC | awk '{print $3}'`
+GIT_COMMIT=`egrep '%global\s*github_commit' $SPEC | awk '{print $3}'`
+GIT_REPO=https://github.com/${GIT_OWNER}/${GIT_NAME}
+GIT_DIR=`echo $GIT_REPO | sed 's#.*/##'`
+
+print "GIT_OWNER = $GIT_OWNER"
+print "GIT_NAME = $GIT_NAME"
+print "GIT_COMMIT = $GIT_COMMIT"
+print "GIT_REPO = $GIT_REPO"
+print "GIT_DIR = $GIT_DIR"
+
+TEMP_DIR=$(mktemp --dir)
+
+pushd $TEMP_DIR
+ print "Cloning git repo..."
+ $GIT clone $GIT_REPO
+
+ pushd $GIT_DIR
+ print "Checking out commit..."
+ $GIT checkout $GIT_COMMIT
+ popd
+
+ TAR_DIR=${GIT_NAME}-${GIT_COMMIT}
+ print "TAR_DIR = $TAR_DIR"
+
+ mv $GIT_DIR $TAR_DIR
+
+ TAR_FILE=`$RPM --eval='%{_sourcedir}'`/${NAME}-${VERSION}-${GIT_COMMIT}.tar.gz
+ print "TAR_FILE = $TAR_FILE"
+
+ [ -e $TAR_FILE ] && rm -f $TAR_FILE
+ tar --exclude-vcs -czf $TAR_FILE $TAR_DIR
+ chmod 0644 $TAR_FILE
+popd
+
+rm -rf $TEMP_DIR
diff --git a/php-punic.spec b/php-punic.spec
new file mode 100644
index 0000000..74b0224
--- /dev/null
+++ b/php-punic.spec
@@ -0,0 +1,158 @@
+#
+# Fedora spec file for php-punic
+#
+# Copyright (c) 2015 Shawn Iwinski <shawn.iwinski@gmail.com>
+#
+# License: MIT
+# http://opensource.org/licenses/MIT
+#
+# Please preserve changelog entries
+#
+
+%global github_owner punic
+%global github_name punic
+%global github_version 1.6.3
+%global github_commit 5805b35d6a574f754b49be1f539aaf3ae6484808
+
+%global composer_vendor punic
+%global composer_project punic
+
+# "php": ">=5.3"
+%global php_min_ver 5.3
+
+# Build using "--without tests" to disable tests
+%global with_tests 0%{!?_without_tests:1}
+
+%{!?phpdir: %global phpdir %{_datadir}/php}
+
+Name: php-%{composer_project}
+Version: %{github_version}
+Release: 1%{?github_release}%{?dist}
+Summary: PHP-Unicode CLDR
+
+Group: Development/Libraries
+# Code is MIT, data is Unicode
+License: MIT and Unicode
+URL: http://punic.github.io/
+
+# GitHub export does not include tests.
+# Run php-punic-get-source.sh to create full source.
+Source0: %{name}-%{github_version}-%{github_commit}.tar.gz
+Source1: %{name}-get-source.sh
+
+BuildArch: noarch
+# Relative paths
+BuildRequires: python
+# Tests
+%if %{with_tests}
+BuildRequires: %{_bindir}/phpunit
+## composer.json
+BuildRequires: php(language) >= %{php_min_ver}
+## phpcompatinfo (computed from version 1.6.3)
+BuildRequires: php-date
+BuildRequires: php-iconv
+BuildRequires: php-intl
+BuildRequires: php-json
+BuildRequires: php-mbstring
+BuildRequires: php-pcre
+BuildRequires: php-spl
+## Autoloader
+BuildRequires: php-composer(symfony/class-loader)
+%endif
+
+# composer.json
+Requires: php(language) >= %{php_min_ver}
+# phpcompatinfo (computed from version 1.6.3)
+Requires: php-date
+Requires: php-iconv
+Requires: php-intl
+Requires: php-json
+Requires: php-mbstring
+Requires: php-pcre
+# Autoloader
+Requires: php-composer(symfony/class-loader)
+Requires: php-spl
+
+# Standard "php-{COMPOSER_VENDOR}-{COMPOSER_PROJECT}" naming
+Provides: php-%{composer_vendor}-%{composer_project} = %{version}-%{release}
+# Composer
+Provides: php-composer(%{composer_vendor}/%{composer_project}) = %{version}
+
+%description
+PHP-Unicode CLDR Toolkit
+
+Punic is a PHP library using the CLDR data to help you localize various
+variables like numbers, dates, units, lists, ...
+
+For full API reference see the APIs reference [1].
+
+[1] http://punic.github.io/docs
+
+
+%prep
+%setup -qn %{github_name}-%{github_commit}
+
+: Create autoloader
+cat <<'AUTOLOAD' | tee code/autoload.php
+<?php
+/**
+ * Autoloader for %{name} and its' dependencies
+ *
+ * Created by %{name}-%{version}-%{release}
+ *
+ * @return \Symfony\Component\ClassLoader\ClassLoader
+ */
+
+if (!isset($fedoraClassLoader) || !($fedoraClassLoader instanceof \Symfony\Component\ClassLoader\ClassLoader)) {
+ if (!class_exists('Symfony\\Component\\ClassLoader\\ClassLoader', false)) {
+ require_once '%{phpdir}/Symfony/Component/ClassLoader/ClassLoader.php';
+ }
+
+ $fedoraClassLoader = new \Symfony\Component\ClassLoader\ClassLoader();
+ $fedoraClassLoader->register();
+}
+
+$fedoraClassLoader->addPrefix('Punic\\', dirname(__DIR__));
+
+return $fedoraClassLoader;
+AUTOLOAD
+
+
+%build
+# Empty build section, nothing to build
+
+
+%install
+: Library
+mkdir -p %{buildroot}%{phpdir}/Punic
+cp -rp code/* %{buildroot}%{phpdir}/Punic/
+
+: Data
+mkdir -p %{buildroot}%{_datadir}
+mv %{buildroot}%{phpdir}/Punic/data %{buildroot}%{_datadir}/%{name}
+ln -s \
+ %(python -c "import os.path; print os.path.relpath('%{_datadir}/%{name}', '%{phpdir}/Punic')") \
+ %{buildroot}%{phpdir}/Punic/data
+
+
+%check
+%if %{with_tests}
+%{_bindir}/phpunit --verbose --bootstrap %{buildroot}%{phpdir}/Punic/autoload.php
+%else
+: Tests skipped
+%endif
+
+
+%files
+%{!?_licensedir:%global license %%doc}
+%license LICENSE.txt
+%license UNICODE-LICENSE.txt
+%doc *.md
+%doc composer.json
+%{phpdir}/Punic
+%{_datadir}/%{name}
+
+
+%changelog
+* Fri Sep 11 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 1.6.3-1
+- Initial package