summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2012-12-19 07:30:23 +0100
committerRemi Collet <fedora@famillecollet.com>2012-12-19 07:30:23 +0100
commita2e7672a07fe3a871b1f6b4a973cda4b846abaf9 (patch)
tree345dc4dfbc4385b889d23201d3d044ce406316be
parenta354f5bab30ff96ff5274a0159cc3f4e9572468d (diff)
php-pluf: backportHEADmaster
-rw-r--r--Makefile10
-rw-r--r--php-pluf.spec6
2 files changed, 15 insertions, 1 deletions
diff --git a/Makefile b/Makefile
new file mode 100644
index 0000000..d095534
--- /dev/null
+++ b/Makefile
@@ -0,0 +1,10 @@
+SRCDIR := $(shell pwd)
+NAME := $(shell basename $(SRCDIR))
+INCL1 := $(shell php-config --includes)
+INCL2 := -I $(shell php-config --include-dir)/sapi/embed
+LIBS := -lphp5 $(shell php-config --libs)
+
+include ../../common/Makefile
+
+tembed: tembed.c
+ gcc -Wall $(INCL1) $(INCL2) tembed.c $(LIBS) -o tembed
diff --git a/php-pluf.spec b/php-pluf.spec
index 733064b..0f6fbad 100644
--- a/php-pluf.spec
+++ b/php-pluf.spec
@@ -14,10 +14,11 @@ URL: http://www.pluf.org/
# following commands to generate the archive:
# wget http://projects.ceondo.com/p/pluf/source/download/b1fed2e6d592d18527cfff6e78a5e14058708173 -O pluf-b1fed2e6d592d18527cfff6e78a5e14058708173.zip
Source0: %{shortname}-%{git}.zip
+
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
-Requires: php-common >= 5.2.4
+Requires: php(language) >= 5.2.4
Requires: php-gd
Requires: php-mbstring
Requires: php-mysql
@@ -57,6 +58,9 @@ rm -rf %{buildroot}
%changelog
+* Wed Dec 19 2012 Remi Collet <RPMS@FamilleCollet.com> - 1.0-3.gitb1fed2e
+- backport for remi repo.
+
* Tue Dec 04 2012 Guillaume Kulakowski <guillaume DOT kulakowski AT fedoraproject DOT org> - 1.0-3.gitb1fed2e
- Update from git to satisfy Indefero dependancy https://bugzilla.redhat.com/show_bug.cgi?id=575956