summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-13 19:52:24 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-13 19:52:24 +0200
commitf0b2f3953623de848e924161b93b70ed9697e219 (patch)
tree12d7e1f4e0a4d04a9c773839b0e588a478b7f32c
parent9978769f53031db1edc220eb717867fa6c6ba001 (diff)
php-pimple: 3.0.2
-rw-r--r--REFLECTION143
-rw-r--r--php-pimple.spec13
2 files changed, 151 insertions, 5 deletions
diff --git a/REFLECTION b/REFLECTION
new file mode 100644
index 0000000..60d5b63
--- /dev/null
+++ b/REFLECTION
@@ -0,0 +1,143 @@
+Extension [ <persistent> extension #136 pimple version 3.0.2 ] {
+
+ - Classes [3] {
+ Class [ <internal:pimple> class Pimple\Container implements ArrayAccess ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [11] {
+ Method [ <internal:pimple, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <optional> array $value ]
+ }
+ }
+
+ Method [ <internal:pimple> public method factory ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callable ]
+ }
+ }
+
+ Method [ <internal:pimple> public method protect ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $callable ]
+ }
+ }
+
+ Method [ <internal:pimple> public method raw ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $id ]
+ }
+ }
+
+ Method [ <internal:pimple> public method extend ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $id ]
+ Parameter #1 [ <required> $callable ]
+ }
+ }
+
+ Method [ <internal:pimple> public method keys ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:pimple> public method register ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Pimple\ServiceProviderInterface $provider ]
+ Parameter #1 [ <optional> array or NULL $values ]
+ }
+ }
+
+ Method [ <internal:pimple, prototype ArrayAccess> public method offsetSet ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> $offset ]
+ Parameter #1 [ <required> $value ]
+ }
+ }
+
+ Method [ <internal:pimple, prototype ArrayAccess> public method offsetGet ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:pimple, prototype ArrayAccess> public method offsetExists ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+
+ Method [ <internal:pimple, prototype ArrayAccess> public method offsetUnset ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $offset ]
+ }
+ }
+ }
+ }
+
+ Class [ <internal:pimple> final class Pimple\ContainerClosure ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [0] {
+ }
+ }
+
+ Interface [ <internal:pimple> interface Pimple\ServiceProviderInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [1] {
+ Method [ <internal:pimple> abstract public method register ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Pimple\Container $pimple ]
+ }
+ }
+ }
+ }
+ }
+}
+
diff --git a/php-pimple.spec b/php-pimple.spec
index 8685c29..82ef9dd 100644
--- a/php-pimple.spec
+++ b/php-pimple.spec
@@ -13,8 +13,8 @@
%global github_owner silexphp
%global github_name Pimple
-%global github_version 3.0.1
-%global github_commit 3313af5935dbc560fab845b76a1ca351b47855af
+%global github_version 3.0.2
+%global github_commit a30f7d6e57565a2e1a316e1baf2a483f788b258a
# Lib
%global composer_vendor pimple
@@ -69,7 +69,7 @@ BuildRequires: %{?scl_prefix}php-devel >= %{php_min_ver}
# For tests
## composer.json
BuildRequires: %{_bindir}/phpunit
-## phpcompatinfo (computed from version 3.0.0)
+## phpcompatinfo (computed from version 3.0.2)
BuildRequires: %{?scl_prefix}php-reflection
BuildRequires: %{?scl_prefix}php-spl
%endif
@@ -90,7 +90,7 @@ Requires: %{?scl_prefix}php(api) = %{php_core_api}
NOTE: This package installs the Pimple EXTENSION.
-Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl})}.
+Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')%{?scl: as Software Collection (%{scl} by %{?scl_vendor}%{!?scl_vendor:rh})}.
# ------------------------------------------------------------------------------
@@ -107,7 +107,7 @@ BuildArch: noarch
# composer.json
Requires: php(language) >= %{php_min_ver}
-# phpcompatinfo (computed from version 3.0.1)
+# phpcompatinfo (computed from version 3.0.2)
Requires: php-spl
# Composer
@@ -279,6 +279,9 @@ rm -rf %{buildroot}
%changelog
+* Sat Sep 12 2015 Shawn Iwinski <shawn.iwinski@gmail.com> - 3.0.2-1
+- Updated to 3.0.2 (RHBZ #1262507)
+
* Wed Aug 5 2015 Remi Collet <remi@remirepo.net> - 3.0.1-1
- backport for #remirepo
- adapt for SCL