summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2015-09-22 09:07:08 +0200
committerRemi Collet <fedora@famillecollet.com>2015-09-22 09:07:08 +0200
commitbe9b11b883a0c54778de6bd5806191aa80bb03a7 (patch)
treee40f9fea36b5d0d9929d40185e7a25468104d699
parent7113f13a659c56a2dc66219131795123ef517e4a (diff)
php-phpmd-PHP-PMD: 2.3.0
-rwxr-xr-xmakesrc.sh1
-rw-r--r--php-phpmd-PHP-PMD-rpm.patch10
-rw-r--r--php-phpmd-PHP-PMD.spec18
3 files changed, 18 insertions, 11 deletions
diff --git a/makesrc.sh b/makesrc.sh
index 05a6054..bde65fc 100755
--- a/makesrc.sh
+++ b/makesrc.sh
@@ -15,6 +15,7 @@ git clone https://github.com/$OWNER/$PROJECT.git $PROJECT-$COMMIT
echo "Getting commit..."
pushd $PROJECT-$COMMIT
git checkout $COMMIT
+cp composer.json ../composer-$VERSION.json
popd
echo "Archiving..."
diff --git a/php-phpmd-PHP-PMD-rpm.patch b/php-phpmd-PHP-PMD-rpm.patch
index 98be5bc..7006ca4 100644
--- a/php-phpmd-PHP-PMD-rpm.patch
+++ b/php-phpmd-PHP-PMD-rpm.patch
@@ -1,6 +1,6 @@
diff -up src/bin/phpmd.rpm src/bin/phpmd
---- src/bin/phpmd.rpm 2015-07-02 10:03:08.578182650 +0200
-+++ src/bin/phpmd 2015-07-02 10:04:10.727496791 +0200
+--- src/bin/phpmd.rpm 2015-09-22 09:01:46.283971581 +0200
++++ src/bin/phpmd 2015-09-22 09:02:14.155400697 +0200
@@ -3,23 +3,7 @@
use PHPMD\TextUI\Command;
@@ -24,11 +24,11 @@ diff -up src/bin/phpmd.rpm src/bin/phpmd
-}
+require '/usr/share/php/PHPMD/autoload.php';
- if (!ini_get('date.timezone') && !date_default_timezone_get()) {
+ if (!ini_get('date.timezone')) {
date_default_timezone_set('UTC');
diff -up src/main/php/PHPMD/RuleSetFactory.php.rpm src/main/php/PHPMD/RuleSetFactory.php
---- src/main/php/PHPMD/RuleSetFactory.php.rpm 2015-07-02 10:05:14.076816993 +0200
-+++ src/main/php/PHPMD/RuleSetFactory.php 2015-07-02 10:06:06.854083755 +0200
+--- src/main/php/PHPMD/RuleSetFactory.php.rpm 2015-09-22 08:56:25.000000000 +0200
++++ src/main/php/PHPMD/RuleSetFactory.php 2015-09-22 09:01:46.283971581 +0200
@@ -79,12 +79,7 @@ class RuleSetFactory
*/
public function __construct()
diff --git a/php-phpmd-PHP-PMD.spec b/php-phpmd-PHP-PMD.spec
index db9e38d..54ea4fd 100644
--- a/php-phpmd-PHP-PMD.spec
+++ b/php-phpmd-PHP-PMD.spec
@@ -8,7 +8,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit 5eeb5a4d39c8304910b33ae49f8813905346cc35
+%global gh_commit 246b254505951508bea08db5dde44322264f75fe
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmd
%global gh_project phpmd
@@ -19,7 +19,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-phpmd-PHP-PMD
-Version: 2.2.3
+Version: 2.3.0
Release: 1%{?dist}
Summary: PHPMD - PHP Mess Detector
@@ -37,7 +37,10 @@ BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildArch: noarch
%if %{with_tests}
# For tests
-BuildRequires: %{_bindir}/phpunit
+# From composer.json, "require-dev": {
+# "phpunit/phpunit": "^4.0",
+# "squizlabs/php_codesniffer": "^2.0"
+BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php(language) >= 5.3
BuildRequires: php-composer(pdepend/pdepend) >= 2.0
BuildRequires: php-composer(symfony/dependency-injection) >= 2.4
@@ -54,9 +57,9 @@ BuildRequires: php-composer(symfony/class-loader)
# From composer.json, "require": {
# "php": ">=5.3.0",
# "pdepend/pdepend": "~2.0",
-# "symfony/dependency-injection": ">=2.4",
-# "symfony/filesystem": ">=2.4",
-# "symfony/config": ">=2.4"
+# "symfony/dependency-injection": "^2.4",
+# "symfony/filesystem": "^2.4",
+# "symfony/config": "^2.4"
Requires: php(language) >= 5.3
Requires: php-composer(pdepend/pdepend) >= 2.0
Requires: php-composer(pdepend/pdepend) < 3
@@ -155,6 +158,9 @@ rm -rf %{buildroot}
%changelog
+* Tue Sep 22 2015 Remi Collet <remi@fedoraproject.org> - 2.3.0-1
+- update to 2.3.0
+
* Thu Jul 2 2015 Remi Collet <remi@fedoraproject.org> - 2.2.3-1
- update to 2.2.3
- switch from pear channel to git snapshot sources