summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-04-21 15:34:06 +0200
committerRemi Collet <fedora@famillecollet.com>2016-04-21 15:34:06 +0200
commit6a34e15da3b4977860f47de1926c57b92a600b02 (patch)
tree2a49fe6e4c6b4a0e0a0b54cbd0db09366d510f71
parent5a40a474b3e69cbf679a54f50c030bf5f13ac79a (diff)
php-phpmd-PHP-PMD: 2.4.3
-rw-r--r--composer.json54
-rw-r--r--php-phpmd-PHP-PMD.spec13
2 files changed, 62 insertions, 5 deletions
diff --git a/composer.json b/composer.json
new file mode 100644
index 0000000..eb31b63
--- /dev/null
+++ b/composer.json
@@ -0,0 +1,54 @@
+{
+ "name": "phpmd/phpmd",
+ "description": "PHPMD is a spin-off project of PHP Depend and aims to be a PHP equivalent of the well known Java tool PMD.",
+ "keywords": [
+ "phpmd",
+ "pdepend",
+ "pmd",
+ "mess detection",
+ "mess detector"
+ ],
+ "type": "project",
+ "license": "BSD-3-Clause",
+ "homepage": "http://phpmd.org/",
+ "authors": [
+ {
+ "name": "Manuel Pichler",
+ "homepage": "https://github.com/manuelpichler",
+ "email": "github@manuel-pichler.de",
+ "role": "Project Founder"
+ },
+ {
+ "name": "Marc Würth",
+ "homepage": "https://github.com/ravage84",
+ "email": "ravage@bluewin.ch",
+ "role": "Project Maintainer"
+ },
+ {
+ "name": "Other contributors",
+ "homepage": "https://github.com/phpmd/phpmd/graphs/contributors",
+ "role": "Contributors"
+ }
+ ],
+ "support": {
+ "irc": "irc://irc.freenode.org/phpmd"
+ },
+ "minimum-stability" : "stable",
+ "require": {
+ "php": ">=5.3.0",
+ "pdepend/pdepend": "^2.0.4"
+ },
+ "require-dev": {
+ "phpunit/phpunit": "^4.0",
+ "squizlabs/php_codesniffer": "^2.0"
+ },
+ "autoload": {
+ "psr-0": {
+ "PHPMD\\": "src/main/php"
+ }
+ },
+ "bin": ["src/bin/phpmd"],
+ "scripts": {
+ "test": "phpunit"
+ }
+}
diff --git a/php-phpmd-PHP-PMD.spec b/php-phpmd-PHP-PMD.spec
index 021714a..7395bd8 100644
--- a/php-phpmd-PHP-PMD.spec
+++ b/php-phpmd-PHP-PMD.spec
@@ -7,7 +7,7 @@
#
# Please, preserve the changelog entries
#
-%global gh_commit fccbdb6b222f6d7a6d35af1c396ba5435cec76a9
+%global gh_commit 2b9c2417a18696dfb578b38c116cd0ddc19b256e
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phpmd
%global gh_project phpmd
@@ -18,7 +18,7 @@
%global with_tests 0%{!?_without_tests:1}
Name: php-phpmd-PHP-PMD
-Version: 2.4.2
+Version: 2.4.3
Release: 1%{?dist}
Summary: PHPMD - PHP Mess Detector
@@ -41,7 +41,7 @@ BuildArch: noarch
# "squizlabs/php_codesniffer": "^2.0"
BuildRequires: php-composer(phpunit/phpunit) >= 4.0
BuildRequires: php(language) >= 5.3
-BuildRequires: php-composer(pdepend/pdepend) >= 2.0
+BuildRequires: php-composer(pdepend/pdepend) >= 2.0.4
BuildRequires: php-date
BuildRequires: php-libxml
BuildRequires: php-pcre
@@ -52,9 +52,9 @@ BuildRequires: php-composer(symfony/class-loader)
# From composer.json, "require": {
# "php": ">=5.3.0",
-# "pdepend/pdepend": "~2.0",
+# "pdepend/pdepend": "^2.0.4",
Requires: php(language) >= 5.3
-Requires: php-composer(pdepend/pdepend) >= 2.0
+Requires: php-composer(pdepend/pdepend) >= 2.0.4
Requires: php-composer(pdepend/pdepend) < 3
# From phpcompatinfo report for version 2.2.3
Requires: php-date
@@ -150,6 +150,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Apr 21 2016 Remi Collet <remi@fedoraproject.org> - 2.4.3-1
+- update to 2.4.3
+
* Fri Mar 11 2016 Remi Collet <remi@fedoraproject.org> - 2.4.2-1
- update to 2.4.2