summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <fedora@famillecollet.com>2016-11-25 06:41:07 +0100
committerRemi Collet <fedora@famillecollet.com>2016-11-25 06:41:07 +0100
commit3a1c020c698eeae83edb4508560bdd0fe2acae37 (patch)
treef2062d67d50d7a3a0b843f71f88db03d97a8e685
parentaee6e69e92378951078aa0c4003a4a5dd3c6d217 (diff)
php-phpiredis: 1.0.0
-rw-r--r--REFLECTION8
-rw-r--r--php-phpiredis.spec12
2 files changed, 10 insertions, 10 deletions
diff --git a/REFLECTION b/REFLECTION
index f910e5a..0089b2e 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #108 phpiredis version 1.0.0-dev ] {
+Extension [ <persistent> extension #108 phpiredis version 1.0.0 ] {
- Constants [9] {
Constant [ integer PHPIREDIS_READER_STATE_INCOMPLETE ] { 2 }
@@ -15,16 +15,18 @@ Extension [ <persistent> extension #108 phpiredis version 1.0.0-dev ] {
- Functions {
Function [ <internal:phpiredis> function phpiredis_connect ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $ip ]
Parameter #1 [ <optional> $port ]
+ Parameter #2 [ <optional> $timeout_ms ]
}
}
Function [ <internal:phpiredis> function phpiredis_pconnect ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $ip ]
Parameter #1 [ <optional> $port ]
+ Parameter #2 [ <optional> $timeout_ms ]
}
}
Function [ <internal:phpiredis> function phpiredis_disconnect ] {
diff --git a/php-phpiredis.spec b/php-phpiredis.spec
index d20b222..b82d7d7 100644
--- a/php-phpiredis.spec
+++ b/php-phpiredis.spec
@@ -11,11 +11,11 @@
%scl_package php-phpiredis
%endif
-%global gh_commit a64e3bfe78c06c9013d5f78651aa3f631d94622f
+%global gh_commit 981d455034a48bb19db39c578e9c16d889289b99
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner nrk
%global gh_project phpiredis
-%global gh_date 20160715
+#global gh_date 20160715
#global prever RC1
%global pecl_name phpiredis
@@ -42,9 +42,6 @@ License: BSD
URL: https://github.com/%{gh_owner}/%{gh_project}
Source0: https://github.com/%{gh_owner}/%{gh_project}/archive/%{gh_commit}/%{pecl_name}-%{version}-%{gh_short}.tar.gz
-# https://github.com/nrk/phpiredis/pull/53
-Patch0: %{pecl_name}-pr53.patch
-
BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-root-%(%{__id_u} -n)
BuildRequires: %{?scl_prefix}php-devel
BuildRequires: %{?scl_prefix}php-pear
@@ -111,8 +108,6 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
mv %{gh_project}-%{gh_commit} NTS
cd NTS
-%patch0 -p1 -b .pr53
-
# Check extension version
ver=$(sed -n '/define PHP_PHPIREDIS_VERSION/{s/.* "//;s/".*$//;p}' php_phpiredis.h)
if test "$ver" != "%{version}%{?prever}%{?gh_date:-dev}"; then
@@ -237,6 +232,9 @@ rm -rf %{buildroot}
%changelog
+* Thu Nov 24 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-1
+- update to 1.0.0 release
+
* Sun Nov 13 2016 Remi Collet <remi@fedoraproject.org> - 1.0.0-0.2.20160715gita64e3bf
- add minor fix for portability
- add full reflection for all functions