summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION4
-rw-r--r--php-phalcon5.spec32
3 files changed, 25 insertions, 15 deletions
diff --git a/PHPINFO b/PHPINFO
index 19e5414..152ba20 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.6.1
-Build Date => Feb 12 2024 00:00:00
+Version => 5.6.2
+Build Date => Mar 15 2024 00:00:00
Powered by Zephir => Version 0.18.0-$Id$
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index 170b310..6579433 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #89 phalcon version 5.6.1 ] {
+Extension [ <persistent> extension #92 phalcon version 5.6.2 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -11990,7 +11990,7 @@ Extension [ <persistent> extension #89 phalcon version 5.6.1 ] {
}
}
- Class [ <internal:phalcon> abstract class Phalcon\Di\AbstractInjectionAware implements Phalcon\Di\InjectionAwareInterface ] {
+ Class [ <internal:phalcon> abstract class Phalcon\Di\AbstractInjectionAware extends stdClass implements Phalcon\Di\InjectionAwareInterface ] {
- Constants [0] {
}
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index 1eaf41e..edfedbb 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -9,18 +9,18 @@
%{?scl:%scl_package php-phalcon5}
-%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
-%global pecl_name phalcon
+%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
+%global pecl_name phalcon
# after 40-json.ini, 20-pdo.ini
-%global ini_name 50-%{pecl_name}.ini
-%global upstream_ver 5.6.1
-#global upstream_pre RC4
-#global upstream_low %%(echo %%{upstream_pre} | tr '[:upper:]' '[:lower:]')
-%global sources %{pecl_name}-%{upstream_ver}%{?upstream_pre}
-%global _configure ../%{sources}/configure
+%global ini_name 50-%{pecl_name}.ini
+%global upstream_version 5.6.2
+#global upstream_prever RC4
+#global upstream_low %%(echo %%{upstream_prever} | tr '[:upper:]' '[:lower:]')
+%global sources %{pecl_name}-%{upstream_version}%{?upstream_prever}
+%global _configure ../%{sources}/configure
Name: %{?scl_prefix}php-phalcon5
-Version: %{upstream_ver}%{?upstream_pre:~%{upstream_low}}
+Version: %{upstream_version}%{?upstream_prever:~%{upstream_low}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -82,8 +82,8 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
cd %{sources}
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PHALCON_VERSION/{s/.* "//;s/".*$//;p}' php_phalcon.h)
-if test "x${extver}" != "x%{upstream_ver}%{?upstream_pre:%{upstream_pre}}"; then
- : Error: Upstream extension version is ${extver}, expecting %{upstream_ver}%{?upstream_pre:%{upstream_pre}}.
+if test "x${extver}" != "x%{upstream_version}%{?upstream_prever:%{upstream_prever}}"; then
+ : Error: Upstream extension version is ${extver}, expecting %{upstream_version}%{?upstream_prever:%{upstream_prever}}.
exit 1
fi
cd ..
@@ -132,6 +132,9 @@ peclconf() {
--with-php-config=$1
}
+# See https://github.com/phalcon/cphalcon/issues/16531
+export CFLAGS="%{optflags} -Wno-incompatible-pointer-types"
+
cd %{sources}
%{__phpize}
@@ -231,6 +234,13 @@ fi
%changelog
+* Fri Mar 15 2024 Remi Collet <remi@remirepo.net> - 5.6.2-1
+- update to 5.6.2
+
+* Fri Feb 16 2024 Remi Collet <remi@remirepo.net> - 5.6.1-2
+- ignore [-Wincompatible-pointer-types]
+ reported as https://github.com/phalcon/cphalcon/issues/16531
+
* Mon Feb 12 2024 Remi Collet <remi@remirepo.net> - 5.6.1-1
- update to 5.6.1