summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-02-28 12:12:18 +0100
committerRemi Collet <remi@php.net>2023-02-28 12:12:18 +0100
commita2b209b2c72fd10fc14541243e8e7160b2f724e2 (patch)
tree0607e73c58ecbbbb6ff9dc0ce7c3ba05832e3e53
parentce817763043c48f0a376a53e79bcd319ddccee46 (diff)
update to 5.2.0
fix License add patch for https://github.com/phalcon/cphalcon/issues/16295 build failure on EL7 with 8.2, from https://github.com/phalcon/cphalcon/pull/16296
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION2
-rw-r--r--phalcon-php82.patch28
-rw-r--r--php-phalcon5.spec22
4 files changed, 50 insertions, 8 deletions
diff --git a/PHPINFO b/PHPINFO
index bbff085..338898b 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,9 +5,9 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.1.4
-Build Date => Jan 11 2023 00:00:00
-Powered by Zephir => Version 0.16.3-$Id$
+Version => 5.2.0
+Build Date => Feb 28 2023 00:00:00
+Powered by Zephir => Version 0.17.0-$Id$
Directive => Local Value => Master Value
phalcon.db.escape_identifiers => On => On
diff --git a/REFLECTION b/REFLECTION
index 166fa5f..376077d 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 phalcon version 5.1.4 ] {
+Extension [ <persistent> extension #117 phalcon version 5.2.0 ] {
- Dependencies {
Dependency [ pdo (Required) ]
diff --git a/phalcon-php82.patch b/phalcon-php82.patch
new file mode 100644
index 0000000..9ba2843
--- /dev/null
+++ b/phalcon-php82.patch
@@ -0,0 +1,28 @@
+Partial fix taken from
+
+
+From 2141babe8b5b00c34a8677489d673e7b322384ef Mon Sep 17 00:00:00 2001
+From: Anton Vasiliev <aionbase@gmail.com>
+Date: Tue, 28 Feb 2023 10:07:02 +0000
+Subject: [PATCH 2/2] #16293 - Regenerate phalcon.zep.c
+
+---
+ build/phalcon/phalcon.zep.c | 310572 +++++++++++++++++----------------
+ 1 file changed, 155288 insertions(+), 155284 deletions(-)
+
+diff --git a/build/phalcon/phalcon.zep.c b/build/phalcon/phalcon.zep.c
+index e56befbd5e3..ec2ab669faf 100644
+--- a/build/phalcon/phalcon.zep.c
++++ b/build/phalcon/phalcon.zep.c
+@@ -82,6 +82,10 @@ OF THIS SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.
+ #include <ext/spl/spl_iterators.h>
+ #include <ext/spl/spl_array.h>
+
++#if defined ZEPHIR_USE_PHP_PCRE && ZEPHIR_USE_PHP_PCRE
++#include <ext/pcre/php_pcre.h>
++#endif
++
+ #include <ext/pdo/php_pdo_driver.h>
+ #include <ext/hash/php_hash.h>
+ #include <ext/date/php_date.h>
+
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index 1215bdc..b58154b 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -1,7 +1,7 @@
# remirepo spec file for php-phalcon5
#
# Copyright (c) 2014-2023 Remi Collet
-# License: CC-BY-SA
+# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
# Please, preserve the changelog entries
@@ -22,7 +22,7 @@
%global pecl_name phalcon
# after 40-json.ini, 20-pdo.ini
%global ini_name 50-%{pecl_name}.ini
-%global upstream_ver 5.1.4
+%global upstream_ver 5.2.0
#global upstream_pre RC4
#global upstream_low %%(echo %%{upstream_pre} | tr '[:upper:]' '[:lower:]')
@@ -31,7 +31,7 @@ Version: %{upstream_ver}%{?upstream_pre:~%{upstream_low}}
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
-License: MIT
+License: BSD 3-Clause
URL: https://pecl.php.net/package/phalcon
# when missing on pecl, generated from git
# git checkout v#.#.#
@@ -39,9 +39,12 @@ URL: https://pecl.php.net/package/phalcon
# pecl package
Source0: https://pecl.php.net/get/%{pecl_name}-%{upstream_ver}%{?upstream_pre}.tgz
+# See https://github.com/phalcon/cphalcon/pull/16296
+Patch0: %{pecl_name}-php82.patch
+
BuildRequires: %{?dtsprefix}gcc
BuildRequires: %{?scl_prefix}php-devel >= 7.4.1
-BuildRequires: %{?scl_prefix}php-devel < 8.2
+BuildRequires: %{?scl_prefix}php-devel < 8.3
BuildRequires: %{?scl_prefix}php-pear
BuildRequires: %{?scl_prefix}php-hash
BuildRequires: %{?scl_prefix}php-json
@@ -87,9 +90,13 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
%prep
%setup -qc
+%{?_licensedir:sed -e '/LICENSE/s/role="doc"/role="src"/' -i package.xml}
+
mv %{pecl_name}-%{upstream_ver}%{?upstream_pre} NTS
cd NTS
+%patch0 -p3
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PHALCON_VERSION/{s/.* "//;s/".*$//;p}' php_phalcon.h)
if test "x${extver}" != "x%{upstream_ver}%{?upstream_pre:%{upstream_pre}}"; then
@@ -250,6 +257,13 @@ fi
%changelog
+* Tue Feb 28 2023 Remi Collet <remi@remirepo.net> - 5.2.0-1
+- update to 5.2.0
+- fix License
+- add patch for https://github.com/phalcon/cphalcon/issues/16295
+ build failure on EL7 with 8.2, from
+ https://github.com/phalcon/cphalcon/pull/16296
+
* Wed Jan 11 2023 Remi Collet <remi@remirepo.net> - 5.1.4-1
- update to 5.1.4