summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-02-07 07:38:02 +0100
committerRemi Collet <remi@php.net>2022-02-07 07:38:02 +0100
commit946354f1997e151aba88987a01b86815f1c5bfc0 (patch)
treeff7ffb4f8a09ef53b964136a53e828a2e0137c25
parent5dc36388452f8a34a151061672b29c1980a5e296 (diff)
update to 5.0.0beta3
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION31
-rw-r--r--php-phalcon5.spec7
3 files changed, 27 insertions, 17 deletions
diff --git a/PHPINFO b/PHPINFO
index fc84d21..031122a 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,9 +5,9 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.0.0beta2
-Build Date => Jan 6 2022 00:00:00
-Powered by Zephir => Version 0.15.2-5828ae2
+Version => 5.0.0beta3
+Build Date => Feb 7 2022 00:00:00
+Powered by Zephir => Version 0.15.2-$Id$
Directive => Local Value => Master Value
phalcon.db.escape_identifiers => On => On
diff --git a/REFLECTION b/REFLECTION
index e7a1179..7e11958 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
+Extension [ <persistent> extension #116 phalcon version 5.0.0beta3 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -9912,7 +9912,7 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ ?string ]
}
Method [ <internal:phalcon> abstract public method getHttpMethods ] {
@@ -9925,7 +9925,7 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ ?string ]
}
Method [ <internal:phalcon> abstract public method getPaths ] {
@@ -37675,7 +37675,7 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
}
}
- Class [ <internal:phalcon> class Phalcon\Db\Result\Pdo implements Phalcon\Db\ResultInterface ] {
+ Class [ <internal:phalcon> class Phalcon\Db\Result\PdoResult implements Phalcon\Db\ResultInterface ] {
- Constants [0] {
}
@@ -56833,13 +56833,12 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
Property [ protected $separator = '' ]
}
- - Methods [16] {
+ - Methods [17] {
Method [ <internal:phalcon> public method __invoke ] {
- - Parameters [3] {
- Parameter #0 [ <optional> string $separator = <default> ]
- Parameter #1 [ <optional> ?string $indent = <default> ]
- Parameter #2 [ <optional> ?string $delimiter = <default> ]
+ - Parameters [2] {
+ Parameter #0 [ <optional> ?string $indent = <default> ]
+ Parameter #1 [ <optional> ?string $delimiter = <default> ]
}
- Return [ Phalcon\Html\Helper\Title ]
}
@@ -56876,6 +56875,15 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
- Return [ Phalcon\Html\Helper\Title ]
}
+ Method [ <internal:phalcon> public method setSeparator ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> string $separator ]
+ Parameter #1 [ <optional> bool $raw = <default> ]
+ }
+ - Return [ Phalcon\Html\Helper\Title ]
+ }
+
Method [ <internal:phalcon> public method prepend ] {
- Parameters [2] {
@@ -65615,7 +65623,6 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
- Parameters [1] {
Parameter #0 [ <optional> $parameters = <default> ]
}
- - Return [ ?Phalcon\Mvc\ModelInterface ]
}
Method [ <internal:phalcon, prototype Phalcon\Mvc\ModelInterface> static public method maximum ] {
@@ -72393,7 +72400,7 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ ?string ]
}
Method [ <internal:phalcon> public method getMatch ] {
@@ -72406,7 +72413,7 @@ Extension [ <persistent> extension #115 phalcon version 5.0.0beta2 ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ ?string ]
}
Method [ <internal:phalcon, prototype Phalcon\Mvc\Router\RouteInterface> public method getPaths ] {
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index 6409236..a64f3a9 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -11,7 +11,7 @@
%undefine _strict_symbol_defs_build
%if 0%{?scl:1}
-%scl_package php-phalcon4
+%scl_package php-phalcon5
%else
%global pkg_name %{name}
%endif
@@ -23,7 +23,7 @@
# after 40-json.ini, 20-pdo.ini, 40-psr.ini
%global ini_name 50-%{pecl_name}.ini
%global upstream_ver 5.0.0
-%global upstream_pre beta2
+%global upstream_pre beta3
Name: %{?scl_prefix}php-phalcon5
Version: %{upstream_ver}%{?upstream_pre:~%{upstream_pre}}
@@ -251,6 +251,9 @@ fi
%changelog
+* Mon Feb 7 2022 Remi Collet <remi@remirepo.net> - 5.0.0~beta3-1
+- update to 5.0.0beta3
+
* Thu Jan 6 2022 Remi Collet <remi@remirepo.net> - 5.0.0~beta2-1
- update to 5.0.0beta2