summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2024-01-10 08:30:07 +0100
committerRemi Collet <remi@php.net>2024-01-10 08:30:07 +0100
commit910c0f2822717c3a2fa8c66133f9b5cab34250a0 (patch)
tree59c936ab9f3dd000d550e014d0211f40fd75fdaf
parent38080b4c75e22336a9af7e94f0d89adc321c6c1e (diff)
update to 5.6.0
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION461
-rw-r--r--php-phalcon5.spec7
3 files changed, 407 insertions, 65 deletions
diff --git a/PHPINFO b/PHPINFO
index ae80193..2306496 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.5.0
-Build Date => Dec 28 2023 00:00:00
+Version => 5.6.0
+Build Date => Jan 10 2024 00:00:00
Powered by Zephir => Version 0.18.0-$Id$
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index d1551e3..d5580d6 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
+Extension [ <persistent> extension #80 phalcon version 5.6.0 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -71,7 +71,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
}
}
- - Classes [618] {
+ - Classes [617] {
Interface [ <internal:phalcon> interface Phalcon\Di\InjectionAwareInterface ] {
- Constants [0] {
@@ -13698,7 +13698,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected $store = NULL ]
}
- - Methods [13] {
+ - Methods [21] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [2] {
@@ -13776,6 +13776,63 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Parameters [0] {
}
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetColumns ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetFrom ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetWhere ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetGroupBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetHaving ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetOrderBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetLimit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon> public method resetFlags ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method buildFlags ] {
@@ -14170,7 +14227,14 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected static $connectionConsecutive = 0 ]
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:phalcon> static public method setup ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $options ]
+ }
+ - Return [ void ]
+ }
}
- Properties [12] {
@@ -15042,7 +15106,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected $store = NULL ]
}
- - Methods [30] {
+ - Methods [38] {
Method [ <internal:phalcon> public method limit ] {
- Parameters [1] {
@@ -15268,6 +15332,63 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Parameters [0] {
}
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetColumns ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFrom ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetWhere ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetGroupBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetHaving ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetOrderBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetLimit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFlags ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
}
Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildFlags ] {
@@ -15303,7 +15424,14 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected static $connectionConsecutive = 0 ]
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AbstractAdapter> static public method setup ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $options ]
+ }
+ - Return [ void ]
+ }
}
- Properties [14] {
@@ -23022,11 +23150,9 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Method [ <internal:phalcon> protected method phpApcuDec ] {
- - Parameters [4] {
+ - Parameters [2] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> int $step = <default> ]
- Parameter #2 [ <optional> $success = <default> ]
- Parameter #3 [ <optional> int $ttl = <default> ]
}
}
@@ -23046,19 +23172,16 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Method [ <internal:phalcon> protected method phpApcuInc ] {
- - Parameters [4] {
+ - Parameters [2] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> int $step = <default> ]
- Parameter #2 [ <optional> $success = <default> ]
- Parameter #3 [ <optional> int $ttl = <default> ]
}
}
Method [ <internal:phalcon> protected method phpApcuFetch ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $success = <default> ]
}
}
@@ -27871,11 +27994,9 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Method [ <internal:phalcon, inherits Phalcon\Storage\Adapter\Apcu> protected method phpApcuDec ] {
- - Parameters [4] {
+ - Parameters [2] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> int $step = <default> ]
- Parameter #2 [ <optional> $success = <default> ]
- Parameter #3 [ <optional> int $ttl = <default> ]
}
}
@@ -27895,19 +28016,16 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Method [ <internal:phalcon, inherits Phalcon\Storage\Adapter\Apcu> protected method phpApcuInc ] {
- - Parameters [4] {
+ - Parameters [2] {
Parameter #0 [ <required> $key ]
Parameter #1 [ <optional> int $step = <default> ]
- Parameter #2 [ <optional> $success = <default> ]
- Parameter #3 [ <optional> int $ttl = <default> ]
}
}
Method [ <internal:phalcon, inherits Phalcon\Storage\Adapter\Apcu> protected method phpApcuFetch ] {
- - Parameters [2] {
+ - Parameters [1] {
Parameter #0 [ <required> $key ]
- Parameter #1 [ <optional> $success = <default> ]
}
}
@@ -33765,7 +33883,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected $store = NULL ]
}
- - Methods [32] {
+ - Methods [40] {
Method [ <internal:phalcon, overwrites Phalcon\DataMapper\Query\AbstractQuery, ctor> public method __construct ] {
- Parameters [2] {
@@ -34010,6 +34128,62 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Return [ string ]
}
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetColumns ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFrom ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetWhere ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetGroupBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetHaving ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetOrderBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetLimit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFlags ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildFlags ] {
- Parameters [0] {
@@ -34051,7 +34225,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected $store = NULL ]
}
- - Methods [20] {
+ - Methods [28] {
Method [ <internal:phalcon, overwrites Phalcon\DataMapper\Query\AbstractQuery, ctor> public method __construct ] {
- Parameters [2] {
@@ -34190,6 +34364,62 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Return [ string ]
}
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetColumns ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFrom ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetWhere ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetGroupBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetHaving ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetOrderBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetLimit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFlags ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildFlags ] {
- Parameters [0] {
@@ -34301,7 +34531,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected $forUpdate = false ]
}
- - Methods [50] {
+ - Methods [58] {
Method [ <internal:phalcon> public method __call ] {
- Parameters [2] {
@@ -34438,7 +34668,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Parameters [0] {
}
- - Return [ Phalcon\DataMapper\Query\Select ]
+ - Return [ void ]
}
Method [ <internal:phalcon> public method subSelect ] {
@@ -34698,6 +34928,62 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Return [ string ]
}
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetColumns ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFrom ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetWhere ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetGroupBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetHaving ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetOrderBy ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetLimit ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFlags ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildFlags ] {
- Parameters [0] {
@@ -34739,7 +35025,7 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected $store = NULL ]
}
- - Methods [37] {
+ - Methods [45] {
Method [ <internal:phalcon, overwrites Phalcon\DataMapper\Query\AbstractQuery, ctor> public method __construct ] {
- Parameters [2] {
@@ -35025,52 +35311,83 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Return [ string ]
}
- Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildFlags ] {
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetColumns ] {
- Parameters [0] {
}
+ - Return [ void ]
}
- Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildReturning ] {
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFrom ] {
- Parameters [0] {
}
- - Return [ string ]
+ - Return [ void ]
}
- Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method indent ] {
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetWhere ] {
- - Parameters [2] {
- Parameter #0 [ <required> array $collection ]
- Parameter #1 [ <optional> string $glue = <default> ]
+ - Parameters [0] {
}
- - Return [ string ]
+ - Return [ void ]
}
- }
- }
- Class [ <internal:phalcon> abstract class Phalcon\Db\AbstractDb ] {
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetGroupBy ] {
- - Constants [0] {
- }
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
- - Static properties [0] {
- }
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetHaving ] {
- - Static methods [1] {
- Method [ <internal:phalcon> static public method setup ] {
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
- - Parameters [1] {
- Parameter #0 [ <required> array $options ]
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetOrderBy ] {
+
+ - Parameters [0] {
}
- Return [ void ]
}
- }
- - Properties [0] {
- }
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetLimit ] {
- - Methods [0] {
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> public method resetFlags ] {
+
+ - Parameters [0] {
+ }
+ - Return [ void ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildFlags ] {
+
+ - Parameters [0] {
+ }
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method buildReturning ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\DataMapper\Query\AbstractQuery> protected method indent ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> array $collection ]
+ Parameter #1 [ <optional> string $glue = <default> ]
+ }
+ - Return [ string ]
+ }
}
}
@@ -35180,7 +35497,14 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected static $connectionConsecutive = 0 ]
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AbstractAdapter> static public method setup ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $options ]
+ }
+ - Return [ void ]
+ }
}
- Properties [14] {
@@ -35201,13 +35525,6 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
}
- Methods [78] {
- Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\Pdo\AbstractPdo, ctor> public method __construct ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> array $descriptor ]
- }
- }
-
Method [ <internal:phalcon, overwrites Phalcon\Db\Adapter\AbstractAdapter, prototype Phalcon\Db\Adapter\AdapterInterface> public method addForeignKey ] {
- Parameters [3] {
@@ -35252,6 +35569,13 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
- Return [ array ]
}
+ Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, ctor> public method __construct ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $descriptor ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\Pdo\AbstractPdo, prototype Phalcon\Db\Adapter\AdapterInterface> public method affectedRows ] {
- Parameters [0] {
@@ -35870,7 +36194,14 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected static $connectionConsecutive = 0 ]
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AbstractAdapter> static public method setup ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $options ]
+ }
+ - Return [ void ]
+ }
}
- Properties [14] {
@@ -36560,7 +36891,14 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Property [ protected static $connectionConsecutive = 0 ]
}
- - Static methods [0] {
+ - Static methods [1] {
+ Method [ <internal:phalcon, inherits Phalcon\Db\Adapter\AbstractAdapter> static public method setup ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $options ]
+ }
+ - Return [ void ]
+ }
}
- Properties [14] {
@@ -66466,8 +66804,9 @@ Extension [ <persistent> extension #79 phalcon version 5.5.0 ] {
Method [ <internal:phalcon> public method toArray ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <optional> $columns = <default> ]
+ Parameter #1 [ <optional> $useGetter = <default> ]
}
- Return [ array ]
}
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index 7cd16b2..cc586b3 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -1,6 +1,6 @@
# remirepo spec file for php-phalcon5
#
-# Copyright (c) 2014-2023 Remi Collet
+# Copyright (c) 2014-2024 Remi Collet
# License: CC-BY-SA-4.0
# http://creativecommons.org/licenses/by-sa/4.0/
#
@@ -13,7 +13,7 @@
%global pecl_name phalcon
# after 40-json.ini, 20-pdo.ini
%global ini_name 50-%{pecl_name}.ini
-%global upstream_ver 5.5.0
+%global upstream_ver 5.6.0
#global upstream_pre RC4
#global upstream_low %%(echo %%{upstream_pre} | tr '[:upper:]' '[:lower:]')
%global sources %{pecl_name}-%{upstream_ver}%{?upstream_pre}
@@ -231,6 +231,9 @@ fi
%changelog
+* Wed Jan 10 2024 Remi Collet <remi@remirepo.net> - 5.6.0-1
+- update to 5.6.0
+
* Thu Dec 28 2023 Remi Collet <remi@remirepo.net> - 5.5.0-1
- update to 5.5.0