summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2023-09-12 21:08:12 +0200
committerRemi Collet <remi@php.net>2023-09-12 21:08:12 +0200
commit7dd01e8f872bb5630352f2a0000f3242b1165431 (patch)
treebcd77c6b541649a892fd69e9670c50da0f6828c5
parent3cce8fc56c513933cfbf9d111b4ca036df3c971a (diff)
update to 5.3.1
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION22
-rw-r--r--php-phalcon5.spec5
3 files changed, 22 insertions, 9 deletions
diff --git a/PHPINFO b/PHPINFO
index d96b694..7744ceb 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.3.0
-Build Date => Aug 18 2023 00:00:00
+Version => 5.3.1
+Build Date => Sep 12 2023 00:00:00
Powered by Zephir => Version 0.17.0-$Id$
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index dcf2905..633693a 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #120 phalcon version 5.3.0 ] {
+Extension [ <persistent> extension #120 phalcon version 5.3.1 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -65691,7 +65691,7 @@ Extension [ <persistent> extension #120 phalcon version 5.3.0 ] {
Property [ protected $uniqueTypes = NULL ]
}
- - Methods [87] {
+ - Methods [88] {
Method [ <internal:phalcon, ctor> final public method __construct ] {
- Parameters [3] {
@@ -65999,6 +65999,14 @@ Extension [ <persistent> extension #120 phalcon version 5.3.0 ] {
- Return [ bool ]
}
+ Method [ <internal:phalcon> public method doSave ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> Phalcon\Support\Collection\CollectionInterface $visited ]
+ }
+ - Return [ bool ]
+ }
+
Method [ <internal:phalcon, prototype Serializable> public method serialize ] {
- Parameters [0] {
@@ -66197,9 +66205,10 @@ Extension [ <persistent> extension #120 phalcon version 5.3.0 ] {
Method [ <internal:phalcon> protected method preSaveRelatedRecords ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> Phalcon\Db\Adapter\AdapterInterface $connection ]
Parameter #1 [ <required> $related ]
+ Parameter #2 [ <required> Phalcon\Support\Collection\CollectionInterface $visited ]
}
- Return [ bool ]
}
@@ -66215,9 +66224,10 @@ Extension [ <persistent> extension #120 phalcon version 5.3.0 ] {
Method [ <internal:phalcon> protected method postSaveRelatedRecords ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> Phalcon\Db\Adapter\AdapterInterface $connection ]
Parameter #1 [ <required> $related ]
+ Parameter #2 [ <required> Phalcon\Support\Collection\CollectionInterface $visited ]
}
- Return [ bool ]
}
@@ -72567,7 +72577,7 @@ Extension [ <persistent> extension #120 phalcon version 5.3.0 ] {
Property [ protected $converters = NULL ]
Property [ protected $group = NULL ]
Property [ protected $hostname = NULL ]
- Property [ protected $id = NULL ]
+ Property [ protected $id = '' ]
Property [ protected $methods = NULL ]
Property [ protected $match = NULL ]
Property [ protected $name = NULL ]
@@ -72661,7 +72671,7 @@ Extension [ <persistent> extension #120 phalcon version 5.3.0 ] {
- Parameters [0] {
}
- - Return [ ?string ]
+ - Return [ string ]
}
Method [ <internal:phalcon> public method getMatch ] {
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index 6d5af43..3fde07b 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -13,7 +13,7 @@
%global pecl_name phalcon
# after 40-json.ini, 20-pdo.ini
%global ini_name 50-%{pecl_name}.ini
-%global upstream_ver 5.3.0
+%global upstream_ver 5.3.1
#global upstream_pre RC4
#global upstream_low %%(echo %%{upstream_pre} | tr '[:upper:]' '[:lower:]')
%global sources %{pecl_name}-%{upstream_ver}%{?upstream_pre}
@@ -231,6 +231,9 @@ fi
%changelog
+* Tue Sep 12 2023 Remi Collet <remi@remirepo.net> - 5.3.1-1
+- update to 5.3.1
+
* Fri Aug 18 2023 Remi Collet <remi@remirepo.net> - 5.3.0-1
- update to 5.3.0