summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-12-01 09:04:56 +0100
committerRemi Collet <remi@php.net>2022-12-01 09:04:56 +0100
commit45e8bb6de207437c0e887fa5af21138db93bf285 (patch)
treeed8df43f51f8d545e20fdb48efbc09f89182bef6
parentef3391f7f78d3e9e8b7d0fd2cb2fdadaf4573df1 (diff)
update to 5.1.2
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION51
-rw-r--r--php-phalcon5.spec5
3 files changed, 49 insertions, 11 deletions
diff --git a/PHPINFO b/PHPINFO
index fb49295..ccdbba9 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.1.1
-Build Date => Nov 14 2022 00:00:00
+Version => 5.1.2
+Build Date => Dec 1 2022 00:00:00
Powered by Zephir => Version 0.16.3-$Id$
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index e10be79..7f1264b 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
+Extension [ <persistent> extension #117 phalcon version 5.1.2 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -38765,10 +38765,10 @@ Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
- Properties [3] {
Property [ protected $activeProfile = NULL ]
Property [ protected $allProfiles = NULL ]
- Property [ protected $totalSeconds = 0 ]
+ Property [ protected $totalNanoseconds = 0 ]
}
- - Methods [7] {
+ - Methods [9] {
Method [ <internal:phalcon> public method getLastProfile ] {
- Parameters [0] {
@@ -38783,6 +38783,20 @@ Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
- Return [ int ]
}
+ Method [ <internal:phalcon> public method getTotalElapsedNanoseconds ] {
+
+ - Parameters [0] {
+ }
+ - Return [ float ]
+ }
+
+ Method [ <internal:phalcon> public method getTotalElapsedMilliseconds ] {
+
+ - Parameters [0] {
+ }
+ - Return [ float ]
+ }
+
Method [ <internal:phalcon> public method getTotalElapsedSeconds ] {
- Parameters [0] {
@@ -38808,8 +38822,8 @@ Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
- Parameters [3] {
Parameter #0 [ <required> string $sqlStatement ]
- Parameter #1 [ <optional> $sqlVariables = <default> ]
- Parameter #2 [ <optional> $sqlBindTypes = <default> ]
+ Parameter #1 [ <optional> array $sqlVariables = [] ]
+ Parameter #2 [ <optional> array $sqlBindTypes = [] ]
}
- Return [ Phalcon\Db\Profiler ]
}
@@ -38842,7 +38856,7 @@ Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
Property [ protected $sqlVariables = NULL ]
}
- - Methods [11] {
+ - Methods [13] {
Method [ <internal:phalcon> public method getFinalTime ] {
- Parameters [0] {
@@ -38878,6 +38892,20 @@ Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
- Return [ array ]
}
+ Method [ <internal:phalcon> public method getTotalElapsedNanoseconds ] {
+
+ - Parameters [0] {
+ }
+ - Return [ float ]
+ }
+
+ Method [ <internal:phalcon> public method getTotalElapsedMilliseconds ] {
+
+ - Parameters [0] {
+ }
+ - Return [ float ]
+ }
+
Method [ <internal:phalcon> public method getTotalElapsedSeconds ] {
- Parameters [0] {
@@ -76919,7 +76947,7 @@ Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
- Static methods [0] {
}
- - Properties [7] {
+ - Properties [8] {
Property [ protected $blacklist = NULL ]
Property [ protected $data = NULL ]
Property [ protected $hideDocumentRoot = false ]
@@ -76927,9 +76955,16 @@ Extension [ <persistent> extension #117 phalcon version 5.1.1 ] {
Property [ protected $showFileFragment = false ]
Property [ protected $showFiles = true ]
Property [ protected $uri = 'https://assets....' ]
+ Property [ private $version = NULL ]
}
- - Methods [22] {
+ - Methods [23] {
+ Method [ <internal:phalcon, ctor> public method __construct ] {
+
+ - Parameters [0] {
+ }
+ }
+
Method [ <internal:phalcon> public method clearVars ] {
- Parameters [0] {
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index 98c2217..ca05f0c 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -22,7 +22,7 @@
%global pecl_name phalcon
# after 40-json.ini, 20-pdo.ini
%global ini_name 50-%{pecl_name}.ini
-%global upstream_ver 5.1.1
+%global upstream_ver 5.1.2
#global upstream_pre RC4
#global upstream_low %%(echo %%{upstream_pre} | tr '[:upper:]' '[:lower:]')
@@ -250,6 +250,9 @@ fi
%changelog
+* Thu Dec 1 2022 Remi Collet <remi@remirepo.net> - 5.1.2-1
+- update to 5.1.2
+
* Mon Nov 14 2022 Remi Collet <remi@remirepo.net> - 5.1.1-1
- update to 5.1.1