summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRemi Collet <remi@remirepo.net>2022-08-09 07:40:41 +0200
committerRemi Collet <remi@php.net>2022-08-09 07:40:41 +0200
commit0ed578da1a4de6c9a17fd89b14570a65d9cd4812 (patch)
tree8863d5468f90002959b313f668d56c88c0a2591c
parent16c2a50eef8336dbb18b84e4c43db7a7d712e9a3 (diff)
update to 5.0.0RC4
-rw-r--r--PHPINFO4
-rw-r--r--REFLECTION437
-rw-r--r--php-phalcon5.spec5
3 files changed, 230 insertions, 216 deletions
diff --git a/PHPINFO b/PHPINFO
index 40a8454..c09b227 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,8 +5,8 @@ phalcon
Phalcon is a full stack PHP framework, delivered as a PHP extension, offering lower resource consumption and high performance.
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 5.0.0RC3
-Build Date => Jul 12 2022 00:00:00
+Version => 5.0.0RC4
+Build Date => Aug 9 2022 00:00:00
Powered by Zephir => Version 0.16.0-$Id$
Directive => Local Value => Master Value
diff --git a/REFLECTION b/REFLECTION
index c2ff418..e722867 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
+Extension [ <persistent> extension #115 phalcon version 5.0.0RC4 ] {
- Dependencies {
Dependency [ pdo (Required) ]
@@ -3628,7 +3628,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon> abstract public method mask ] {
- Parameters [1] {
- Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $watermark ]
+ Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $mask ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -3654,7 +3654,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon> abstract public method render ] {
- Parameters [2] {
- Parameter #0 [ <optional> ?string $ext = <default> ]
+ Parameter #0 [ <optional> ?string $extension = <default> ]
Parameter #1 [ <optional> int $quality = <default> ]
}
- Return [ string ]
@@ -3704,7 +3704,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #3 [ <optional> int $opacity = <default> ]
Parameter #4 [ <optional> string $color = <default> ]
Parameter #5 [ <optional> int $size = <default> ]
- Parameter #6 [ <optional> ?string $fontfile = <default> ]
+ Parameter #6 [ <optional> ?string $fontFile = <default> ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -4663,7 +4663,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [0] {
}
- - Return [ Phalcon\Mvc\Router\RouteInterface ]
+ - Return [ ?Phalcon\Mvc\Router\RouteInterface ]
}
Method [ <internal:phalcon> abstract public method getMatches ] {
@@ -11247,7 +11247,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [0] {
}
- - Return [ Phalcon\Cli\Router\RouteInterface ]
+ - Return [ ?Phalcon\Cli\Router\RouteInterface ]
}
Method [ <internal:phalcon> abstract public method getMatches ] {
@@ -19224,8 +19224,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Constants [0] {
}
- - Static properties [1] {
- Property [ protected static $checked = false ]
+ - Static properties [0] {
}
- Static methods [0] {
@@ -19242,99 +19241,87 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
}
- Methods [21] {
- Method [ <internal:phalcon> public method getHeight ] {
+ Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method background ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> string $color ]
+ Parameter #1 [ <optional> int $opacity = <default> ]
}
- - Return [ int ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon> public method getImage ] {
+ Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method blur ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> int $radius ]
}
- - Return [ ?NULL ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon> public method getMime ] {
+ Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method crop ] {
- - Parameters [0] {
+ - Parameters [4] {
+ Parameter #0 [ <required> int $width ]
+ Parameter #1 [ <required> int $height ]
+ Parameter #2 [ <optional> ?int $offsetX = <default> ]
+ Parameter #3 [ <optional> ?int $offsetY = <default> ]
}
- - Return [ string ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon> public method getRealpath ] {
+ Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method flip ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> int $direction ]
}
- - Return [ string ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon> public method getType ] {
+ Method [ <internal:phalcon> public method getHeight ] {
- Parameters [0] {
}
- Return [ int ]
}
- Method [ <internal:phalcon> public method getWidth ] {
+ Method [ <internal:phalcon> public method getImage ] {
- Parameters [0] {
}
- - Return [ int ]
- }
-
- Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method background ] {
-
- - Parameters [2] {
- Parameter #0 [ <required> string $color ]
- Parameter #1 [ <optional> int $opacity = <default> ]
- }
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method blur ] {
+ Method [ <internal:phalcon> public method getMime ] {
- - Parameters [1] {
- Parameter #0 [ <required> int $radius ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ string ]
}
- Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method crop ] {
+ Method [ <internal:phalcon> public method getRealpath ] {
- - Parameters [4] {
- Parameter #0 [ <required> int $width ]
- Parameter #1 [ <required> int $height ]
- Parameter #2 [ <optional> ?int $offsetX = <default> ]
- Parameter #3 [ <optional> ?int $offsetY = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ string ]
}
- Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method flip ] {
+ Method [ <internal:phalcon> public method getType ] {
- - Parameters [1] {
- Parameter #0 [ <required> int $direction ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ int ]
}
- Method [ <internal:phalcon> public method liquidRescale ] {
+ Method [ <internal:phalcon> public method getWidth ] {
- - Parameters [4] {
- Parameter #0 [ <required> int $width ]
- Parameter #1 [ <required> int $height ]
- Parameter #2 [ <optional> int $deltaX = <default> ]
- Parameter #3 [ <optional> int $rigidity = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AbstractAdapter ]
+ - Return [ int ]
}
Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method mask ] {
- Parameters [1] {
- Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $watermark ]
+ Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $mask ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -19360,7 +19347,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon, prototype Phalcon\Image\Adapter\AdapterInterface> public method render ] {
- Parameters [2] {
- Parameter #0 [ <optional> ?string $ext = <default> ]
+ Parameter #0 [ <optional> ?string $extension = <default> ]
Parameter #1 [ <optional> int $quality = <default> ]
}
- Return [ string ]
@@ -19410,7 +19397,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #3 [ <optional> int $opacity = <default> ]
Parameter #4 [ <optional> string $color = <default> ]
Parameter #5 [ <optional> int $size = <default> ]
- Parameter #6 [ <optional> ?string $fontfile = <default> ]
+ Parameter #6 [ <optional> ?string $fontFile = <default> ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -19425,6 +19412,16 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
+
+ Method [ <internal:phalcon> protected method checkHighLow ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> int $value ]
+ Parameter #1 [ <optional> int $min = <default> ]
+ Parameter #2 [ <optional> int $max = <default> ]
+ }
+ - Return [ int ]
+ }
}
}
@@ -22094,7 +22091,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [0] {
}
- - Return [ Phalcon\Mvc\Router\RouteInterface ]
+ - Return [ ?Phalcon\Mvc\Router\RouteInterface ]
}
Method [ <internal:phalcon, prototype Phalcon\Mvc\RouterInterface> public method getMatches ] {
@@ -29387,7 +29384,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [0] {
}
- - Return [ Phalcon\Cli\Router\RouteInterface ]
+ - Return [ ?Phalcon\Cli\Router\RouteInterface ]
}
Method [ <internal:phalcon> public method getMatches ] {
@@ -60657,24 +60654,10 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Constants [0] {
}
- - Static properties [1] {
- Property [ protected static $checked = false ]
+ - Static properties [0] {
}
- - Static methods [2] {
- Method [ <internal:phalcon> static public method check ] {
-
- - Parameters [0] {
- }
- - Return [ bool ]
- }
-
- Method [ <internal:phalcon> static public method getVersion ] {
-
- - Parameters [0] {
- }
- - Return [ string ]
- }
+ - Static methods [0] {
}
- Properties [7] {
@@ -60687,7 +60670,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Property [ protected $width = NULL ]
}
- - Methods [38] {
+ - Methods [40] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [3] {
@@ -60703,14 +60686,22 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
}
}
+ Method [ <internal:phalcon> public method getVersion ] {
+
+ - Parameters [0] {
+ }
+ - Return [ string ]
+ }
+
Method [ <internal:phalcon> protected method processBackground ] {
- Parameters [4] {
- Parameter #0 [ <required> int $r ]
- Parameter #1 [ <required> int $g ]
- Parameter #2 [ <required> int $b ]
+ Parameter #0 [ <required> int $red ]
+ Parameter #1 [ <required> int $green ]
+ Parameter #2 [ <required> int $blue ]
Parameter #3 [ <required> int $opacity ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processBlur ] {
@@ -60718,6 +60709,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $radius ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processCreate ] {
@@ -60736,6 +60728,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #2 [ <required> int $offsetX ]
Parameter #3 [ <required> int $offsetY ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processFlip ] {
@@ -60743,6 +60736,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $direction ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processMask ] {
@@ -60757,6 +60751,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $amount ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processReflection ] {
@@ -60766,12 +60761,13 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #1 [ <required> int $opacity ]
Parameter #2 [ <required> bool $fadeIn ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processRender ] {
- Parameters [2] {
- Parameter #0 [ <required> string $ext ]
+ Parameter #0 [ <required> string $extension ]
Parameter #1 [ <required> int $quality ]
}
}
@@ -60782,6 +60778,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #0 [ <required> int $width ]
Parameter #1 [ <required> int $height ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processRotate ] {
@@ -60789,6 +60786,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $degrees ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processSave ] {
@@ -60797,6 +60795,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #0 [ <required> string $file ]
Parameter #1 [ <required> int $quality ]
}
+ - Return [ bool ]
}
Method [ <internal:phalcon> protected method processSharpen ] {
@@ -60804,21 +60803,23 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $amount ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processText ] {
- Parameters [9] {
Parameter #0 [ <required> string $text ]
- Parameter #1 [ <required> int $offsetX ]
- Parameter #2 [ <required> int $offsetY ]
+ Parameter #1 [ <required> $offsetX ]
+ Parameter #2 [ <required> $offsetY ]
Parameter #3 [ <required> int $opacity ]
- Parameter #4 [ <required> int $r ]
- Parameter #5 [ <required> int $g ]
- Parameter #6 [ <required> int $b ]
+ Parameter #4 [ <required> int $red ]
+ Parameter #5 [ <required> int $green ]
+ Parameter #6 [ <required> int $blue ]
Parameter #7 [ <required> int $size ]
- Parameter #8 [ <required> string $fontfile ]
+ Parameter #8 [ <optional> ?string $fontFile = <default> ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processWatermark ] {
@@ -60829,101 +60830,97 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #2 [ <required> int $offsetY ]
Parameter #3 [ <required> int $opacity ]
}
+ - Return [ void ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getHeight ] {
+ Method [ <internal:phalcon> private method check ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Return [ void ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getImage ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method background ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> string $color ]
+ Parameter #1 [ <optional> int $opacity = <default> ]
}
- - Return [ ?NULL ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getMime ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method blur ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> int $radius ]
}
- - Return [ string ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getRealpath ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method crop ] {
- - Parameters [0] {
+ - Parameters [4] {
+ Parameter #0 [ <required> int $width ]
+ Parameter #1 [ <required> int $height ]
+ Parameter #2 [ <optional> ?int $offsetX = <default> ]
+ Parameter #3 [ <optional> ?int $offsetY = <default> ]
}
- - Return [ string ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getType ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method flip ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> int $direction ]
}
- - Return [ int ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getWidth ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getHeight ] {
- Parameters [0] {
}
- Return [ int ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method background ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getImage ] {
- - Parameters [2] {
- Parameter #0 [ <required> string $color ]
- Parameter #1 [ <optional> int $opacity = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method blur ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getMime ] {
- - Parameters [1] {
- Parameter #0 [ <required> int $radius ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ string ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method crop ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getRealpath ] {
- - Parameters [4] {
- Parameter #0 [ <required> int $width ]
- Parameter #1 [ <required> int $height ]
- Parameter #2 [ <optional> ?int $offsetX = <default> ]
- Parameter #3 [ <optional> ?int $offsetY = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ string ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method flip ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getType ] {
- - Parameters [1] {
- Parameter #0 [ <required> int $direction ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ int ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method liquidRescale ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getWidth ] {
- - Parameters [4] {
- Parameter #0 [ <required> int $width ]
- Parameter #1 [ <required> int $height ]
- Parameter #2 [ <optional> int $deltaX = <default> ]
- Parameter #3 [ <optional> int $rigidity = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AbstractAdapter ]
+ - Return [ int ]
}
Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method mask ] {
- Parameters [1] {
- Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $watermark ]
+ Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $mask ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -60949,7 +60946,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method render ] {
- Parameters [2] {
- Parameter #0 [ <optional> ?string $ext = <default> ]
+ Parameter #0 [ <optional> ?string $extension = <default> ]
Parameter #1 [ <optional> int $quality = <default> ]
}
- Return [ string ]
@@ -60999,7 +60996,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #3 [ <optional> int $opacity = <default> ]
Parameter #4 [ <optional> string $color = <default> ]
Parameter #5 [ <optional> int $size = <default> ]
- Parameter #6 [ <optional> ?string $fontfile = <default> ]
+ Parameter #6 [ <optional> ?string $fontFile = <default> ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -61014,6 +61011,16 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
+
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> protected method checkHighLow ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> int $value ]
+ Parameter #1 [ <optional> int $min = <default> ]
+ Parameter #2 [ <optional> int $max = <default> ]
+ }
+ - Return [ int ]
+ }
}
}
@@ -61022,21 +61029,13 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Constants [0] {
}
- - Static properties [2] {
- Property [ protected static $checked = false ]
- Property [ protected static $version = 0 ]
+ - Static properties [0] {
}
- - Static methods [1] {
- Method [ <internal:phalcon> static public method check ] {
-
- - Parameters [0] {
- }
- - Return [ bool ]
- }
+ - Static methods [0] {
}
- - Properties [7] {
+ - Properties [8] {
Property [ protected $file = NULL ]
Property [ protected $height = NULL ]
Property [ protected $image = NULL ]
@@ -61044,6 +61043,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Property [ protected $realpath = NULL ]
Property [ protected $type = NULL ]
Property [ protected $width = NULL ]
+ Property [ protected $version = 0 ]
}
- Methods [40] {
@@ -61062,11 +61062,15 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
}
}
- Method [ <internal:phalcon> public method getInternalImInstance ] {
+ Method [ <internal:phalcon> public method liquidRescale ] {
- - Parameters [0] {
+ - Parameters [4] {
+ Parameter #0 [ <required> int $width ]
+ Parameter #1 [ <required> int $height ]
+ Parameter #2 [ <optional> int $deltaX = <default> ]
+ Parameter #3 [ <optional> int $rigidity = <default> ]
}
- - Return [ Imagick ]
+ - Return [ Phalcon\Image\Adapter\AbstractAdapter ]
}
Method [ <internal:phalcon> public method setResourceLimit ] {
@@ -61081,9 +61085,9 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon> protected method processBackground ] {
- Parameters [4] {
- Parameter #0 [ <required> int $r ]
- Parameter #1 [ <required> int $g ]
- Parameter #2 [ <required> int $b ]
+ Parameter #0 [ <required> int $red ]
+ Parameter #1 [ <required> int $green ]
+ Parameter #2 [ <required> int $blue ]
Parameter #3 [ <required> int $opacity ]
}
- Return [ void ]
@@ -61116,17 +61120,6 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Return [ void ]
}
- Method [ <internal:phalcon> protected method processLiquidRescale ] {
-
- - Parameters [4] {
- Parameter #0 [ <required> int $width ]
- Parameter #1 [ <required> int $height ]
- Parameter #2 [ <required> int $deltaX ]
- Parameter #3 [ <required> int $rigidity ]
- }
- - Return [ void ]
- }
-
Method [ <internal:phalcon> protected method processMask ] {
- Parameters [1] {
@@ -61193,6 +61186,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [1] {
Parameter #0 [ <required> int $amount ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processText ] {
@@ -61202,12 +61196,13 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #1 [ <required> $offsetX ]
Parameter #2 [ <required> $offsetY ]
Parameter #3 [ <required> int $opacity ]
- Parameter #4 [ <required> int $r ]
- Parameter #5 [ <required> int $g ]
- Parameter #6 [ <required> int $b ]
+ Parameter #4 [ <required> int $red ]
+ Parameter #5 [ <required> int $green ]
+ Parameter #6 [ <required> int $blue ]
Parameter #7 [ <required> int $size ]
- Parameter #8 [ <required> string $fontfile ]
+ Parameter #8 [ <optional> ?string $fontFile = <default> ]
}
+ - Return [ void ]
}
Method [ <internal:phalcon> protected method processWatermark ] {
@@ -61218,101 +61213,97 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #2 [ <required> int $offsetY ]
Parameter #3 [ <required> int $opacity ]
}
+ - Return [ void ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getHeight ] {
+ Method [ <internal:phalcon> private method check ] {
- Parameters [0] {
}
- - Return [ int ]
+ - Return [ void ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getImage ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method background ] {
- - Parameters [0] {
+ - Parameters [2] {
+ Parameter #0 [ <required> string $color ]
+ Parameter #1 [ <optional> int $opacity = <default> ]
}
- - Return [ ?NULL ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getMime ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method blur ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> int $radius ]
}
- - Return [ string ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getRealpath ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method crop ] {
- - Parameters [0] {
+ - Parameters [4] {
+ Parameter #0 [ <required> int $width ]
+ Parameter #1 [ <required> int $height ]
+ Parameter #2 [ <optional> ?int $offsetX = <default> ]
+ Parameter #3 [ <optional> ?int $offsetY = <default> ]
}
- - Return [ string ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getType ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method flip ] {
- - Parameters [0] {
+ - Parameters [1] {
+ Parameter #0 [ <required> int $direction ]
}
- - Return [ int ]
+ - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getWidth ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getHeight ] {
- Parameters [0] {
}
- Return [ int ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method background ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getImage ] {
- - Parameters [2] {
- Parameter #0 [ <required> string $color ]
- Parameter #1 [ <optional> int $opacity = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method blur ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getMime ] {
- - Parameters [1] {
- Parameter #0 [ <required> int $radius ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ string ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method crop ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getRealpath ] {
- - Parameters [4] {
- Parameter #0 [ <required> int $width ]
- Parameter #1 [ <required> int $height ]
- Parameter #2 [ <optional> ?int $offsetX = <default> ]
- Parameter #3 [ <optional> ?int $offsetY = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ string ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method flip ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getType ] {
- - Parameters [1] {
- Parameter #0 [ <required> int $direction ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AdapterInterface ]
+ - Return [ int ]
}
- Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method liquidRescale ] {
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> public method getWidth ] {
- - Parameters [4] {
- Parameter #0 [ <required> int $width ]
- Parameter #1 [ <required> int $height ]
- Parameter #2 [ <optional> int $deltaX = <default> ]
- Parameter #3 [ <optional> int $rigidity = <default> ]
+ - Parameters [0] {
}
- - Return [ Phalcon\Image\Adapter\AbstractAdapter ]
+ - Return [ int ]
}
Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method mask ] {
- Parameters [1] {
- Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $watermark ]
+ Parameter #0 [ <required> Phalcon\Image\Adapter\AdapterInterface $mask ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -61338,7 +61329,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter, prototype Phalcon\Image\Adapter\AdapterInterface> public method render ] {
- Parameters [2] {
- Parameter #0 [ <optional> ?string $ext = <default> ]
+ Parameter #0 [ <optional> ?string $extension = <default> ]
Parameter #1 [ <optional> int $quality = <default> ]
}
- Return [ string ]
@@ -61388,7 +61379,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #3 [ <optional> int $opacity = <default> ]
Parameter #4 [ <optional> string $color = <default> ]
Parameter #5 [ <optional> int $size = <default> ]
- Parameter #6 [ <optional> ?string $fontfile = <default> ]
+ Parameter #6 [ <optional> ?string $fontFile = <default> ]
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
@@ -61403,6 +61394,16 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
}
- Return [ Phalcon\Image\Adapter\AdapterInterface ]
}
+
+ Method [ <internal:phalcon, inherits Phalcon\Image\Adapter\AbstractAdapter> protected method checkHighLow ] {
+
+ - Parameters [3] {
+ Parameter #0 [ <required> int $value ]
+ Parameter #1 [ <optional> int $min = <default> ]
+ Parameter #2 [ <optional> int $max = <default> ]
+ }
+ - Return [ int ]
+ }
}
}
@@ -70964,7 +70965,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Parameters [0] {
}
- - Return [ Phalcon\Mvc\Router\RouteInterface ]
+ - Return [ ?Phalcon\Mvc\Router\RouteInterface ]
}
Method [ <internal:phalcon, inherits Phalcon\Mvc\Router, prototype Phalcon\Mvc\RouterInterface> public method getMatches ] {
@@ -72687,7 +72688,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Property [ protected $view = NULL ]
}
- - Methods [45] {
+ - Methods [46] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -72874,8 +72875,9 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon> final public method expression ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> array $expr ]
+ Parameter #1 [ <optional> bool $doubleQuotes = <default> ]
}
- Return [ string ]
}
@@ -72890,8 +72892,9 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Method [ <internal:phalcon> public method functionCall ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> array $expr ]
+ Parameter #1 [ <optional> bool $doubleQuotes = <default> ]
}
- Return [ string ]
}
@@ -73048,6 +73051,14 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
Parameter #0 [ <required> $statements ]
}
}
+
+ Method [ <internal:phalcon> private method isTagFactory ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> array $expression ]
+ }
+ - Return [ bool ]
+ }
}
}
@@ -79833,7 +79844,7 @@ Extension [ <persistent> extension #114 phalcon version 5.0.0RC3 ] {
- Return [ string ]
}
- Method [ <internal:phalcon> static public method form ] {
+ Method [ <internal:phalcon> static public method formLegacy ] {
- Parameters [1] {
Parameter #0 [ <required> $parameters ]
diff --git a/php-phalcon5.spec b/php-phalcon5.spec
index c118106..fb80e48 100644
--- a/php-phalcon5.spec
+++ b/php-phalcon5.spec
@@ -23,7 +23,7 @@
# after 40-json.ini, 20-pdo.ini
%global ini_name 50-%{pecl_name}.ini
%global upstream_ver 5.0.0
-%global upstream_pre RC3
+%global upstream_pre RC4
%global upstream_low %(echo %{upstream_pre} | tr '[:upper:]' '[:lower:]')
Name: %{?scl_prefix}php-phalcon5
@@ -250,6 +250,9 @@ fi
%changelog
+* Tue Aug 9 2022 Remi Collet <remi@remirepo.net> - 5.0.0~rc4-1
+- update to 5.0.0RC4
+
* Tue Jul 12 2022 Remi Collet <remi@remirepo.net> - 5.0.0~rc3-1
- update to 5.0.0RC3