summaryrefslogtreecommitdiffstats
path: root/php-phalcon3.spec
diff options
context:
space:
mode:
Diffstat (limited to 'php-phalcon3.spec')
-rw-r--r--php-phalcon3.spec37
1 files changed, 29 insertions, 8 deletions
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 9200289..7f1d3aa 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -13,7 +13,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit 47b23351bf16b8fcece3424e9b2371d89773c753
+%global gh_commit 084fbce9f88c970a4fee64d22911f44dc720f944
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
@@ -29,7 +29,7 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.1.2
+Version: 3.2.0
Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
@@ -49,7 +49,7 @@ BuildRequires: %{?scl_prefix}php-devel > 5.5
BuildRequires: %{?scl_prefix}php-json
BuildRequires: %{?scl_prefix}php-pdo
# For sources generation
-BuildRequires: %{?scl_prefix}zephir >= 0.9.7
+BuildRequires: %{?scl_prefix}zephir >= 0.9.8
BuildRequires: %{?scl_prefix}php-gd
BuildRequires: %{?scl_prefix}php-libsodium
BuildRequires: %{?scl_prefix}php-mbstring
@@ -103,6 +103,12 @@ Package built for PHP %(%{__php} -r 'echo PHP_MAJOR_VERSION.".".PHP_MINOR_VERSIO
cp %{SOURCE2} %{SOURCE3} %{SOURCE4} %{SOURCE5} \
ext/phalcon/assets/filters/
+%if "%{php_version}" < "7"
+# https://github.com/phalcon/cphalcon/issues/12909
+sed -e 's/zend_error_noreturn/zend_error/' \
+ -i ext/kernel/extended/fcall.c ext/kernel/object.c
+%endif
+
# Sanity check, really often broken
extver=$(sed -n '/#define PHP_PHALCON_VERSION/{s/.* "//;s/".*$//;p}' ext/php_phalcon.h)
if test "x${extver}" != "x%{version}%{?prever:-%{prever}}"; then
@@ -128,7 +134,8 @@ extension=%{ext_name}.so
;phalcon.orm.enable_implicit_joins = '1'
;phalcon.orm.cast_on_hydrate = '0'
;phalcon.orm.ignore_unknown_columns = '0'
-
+;phalcon.orm.update_snapshot_on_save = '1'
+;phalcon.orm.disable_assign_setters = '0'
EOF
@@ -161,6 +168,12 @@ cp -r build/NTS build/ZTS
: Build NTS extension
cd build/NTS
+%if "%{php_version}" < "7"
+# https://github.com/phalcon/cphalcon/issues/12909
+sed -e 's/zend_error_noreturn/zend_error/' \
+ -i phalcon.zep.c
+%endif
+
%{_bindir}/phpize
peclconf %{_bindir}/php-config
make %{?_smp_mflags}
@@ -168,6 +181,12 @@ make %{?_smp_mflags}
%if %{with_zts}
: Build ZTS extension
cd ../ZTS
+%if "%{php_version}" < "7"
+# https://github.com/phalcon/cphalcon/issues/12909
+sed -e 's/zend_error_noreturn/zend_error/' \
+ -i phalcon.zep.c
+%endif
+
%{_bindir}/zts-phpize
peclconf %{_bindir}/zts-php-config
make %{?_smp_mflags}
@@ -225,10 +244,8 @@ REPORT_EXIT_STATUS=1 \
%files
%{!?_licensedir:%global license %%doc}
-%license docs/LICENSE.md
-%doc CHANGELOG.md
-%doc CONTRIBUTING.md
-%doc docs/DOCUMENTATION.md
+%license LICENSE.txt
+%doc *.md
%config(noreplace) %{php_inidir}/%{ini_name}
%{php_extdir}/%{ext_name}.so
@@ -242,6 +259,10 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Jun 19 2017 Remi Collet <remi@remirepo.net> - 3.2.0-1
+- Update to 3.2.0
+- open https://github.com/phalcon/cphalcon/issues/12909 - PHP 5 compat
+
* Thu Apr 6 2017 Remi Collet <remi@remirepo.net> - 3.1.2-1
- Update to 3.1.2