summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--PHPINFO6
-rw-r--r--REFLECTION144
-rw-r--r--composer.json55
-rw-r--r--php-phalcon3.spec14
4 files changed, 121 insertions, 98 deletions
diff --git a/PHPINFO b/PHPINFO
index b6620f1..45f6cfa 100644
--- a/PHPINFO
+++ b/PHPINFO
@@ -5,9 +5,9 @@ phalcon
Web framework delivered as a C-extension for PHP
phalcon => enabled
Author => Phalcon Team and contributors
-Version => 3.4.1
-Build Date => Aug 21 2018 07:13:36
-Powered by Zephir => Version 0.10.10
+Version => 3.4.2
+Build Date => Dec 3 2018 08:51:20
+Powered by Zephir => Version 0.10.14
Directive => Local Value => Master Value
phalcon.db.escape_identifiers => On => On
diff --git a/REFLECTION b/REFLECTION
index 4a74a1b..31d2d89 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
+Extension [ <persistent> extension #192 phalcon version 3.4.2 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -3486,8 +3486,10 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon> abstract public method setFetchMode ] {
- - Parameters [1] {
+ - Parameters [3] {
Parameter #0 [ <required> $fetchMode ]
+ Parameter #1 [ <optional> $colNoOrClassNameOrObject ]
+ Parameter #2 [ <optional> $ctorargs ]
}
}
@@ -5078,8 +5080,9 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon> abstract public method bind ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> array $bindParams ]
+ Parameter #1 [ <optional> $merge ]
}
}
@@ -5092,8 +5095,10 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon> abstract public method where ] {
- - Parameters [1] {
+ - Parameters [3] {
Parameter #0 [ <required> $conditions ]
+ Parameter #1 [ <optional> $bindParams ]
+ Parameter #2 [ <optional> $bindTypes ]
}
}
@@ -5469,9 +5474,10 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon> abstract public method executeQuery ] {
- - Parameters [2] {
+ - Parameters [3] {
Parameter #0 [ <required> $phql ]
Parameter #1 [ <optional> $placeholders ]
+ Parameter #2 [ <optional> $types ]
}
}
@@ -6300,10 +6306,11 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon> abstract public method get ] {
- - Parameters [3] {
+ - Parameters [4] {
Parameter #0 [ <optional> $uri ]
Parameter #1 [ <optional> $args ]
Parameter #2 [ <optional> $local ]
+ Parameter #3 [ <optional> $baseUri ]
}
}
@@ -9667,13 +9674,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
- Method [ <internal:phalcon, prototype Phalcon\Db\DialectInterface> public method sharedLock ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $sqlQuery ]
- }
- }
-
Method [ <internal:phalcon, prototype Phalcon\Db\DialectInterface> final public method getColumnList ] {
- Parameters [3] {
@@ -9930,6 +9930,13 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
+ Method [ <internal:phalcon, inherits Phalcon\Db\DialectInterface> abstract public method sharedLock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sqlQuery ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\DialectInterface> abstract public method getColumnDefinition ] {
- Parameters [1] {
@@ -10184,6 +10191,9 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
- Methods [4] {
+ Method [ <internal:phalcon, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Paginator\AdapterInterface> public method setCurrentPage ] {
- Parameters [1] {
@@ -10198,9 +10208,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
- Method [ <internal:phalcon, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
- }
-
Method [ <internal:phalcon, inherits Phalcon\Paginator\AdapterInterface> abstract public method getPaginate ] {
}
}
@@ -10477,9 +10484,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon, prototype Phalcon\Assets\ResourceInterface> public method getFilter ] {
}
- Method [ <internal:phalcon, prototype Phalcon\Assets\ResourceInterface> public method getAttributes ] {
- }
-
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [4] {
@@ -10511,6 +10515,9 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
+ Method [ <internal:phalcon, prototype Phalcon\Assets\ResourceInterface> public method getAttributes ] {
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Assets\ResourceInterface> public method getResourceKey ] {
}
}
@@ -14178,9 +14185,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getFilter ] {
}
- Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getAttributes ] {
- }
-
Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method setType ] {
- Parameters [1] {
@@ -14202,6 +14206,9 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
+ Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getAttributes ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getResourceKey ] {
}
}
@@ -14244,9 +14251,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getFilter ] {
}
- Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getAttributes ] {
- }
-
Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method setType ] {
- Parameters [1] {
@@ -14268,6 +14272,9 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
+ Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getAttributes ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Assets\Inline, prototype Phalcon\Assets\ResourceInterface> public method getResourceKey ] {
}
}
@@ -20386,6 +20393,13 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon> public method getForeignKeyChecks ] {
}
+ Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method sharedLock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sqlQuery ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\Dialect> public method registerCustomFunction ] {
- Parameters [2] {
@@ -20428,13 +20442,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
- Method [ <internal:phalcon, inherits Phalcon\Db\Dialect, prototype Phalcon\Db\DialectInterface> public method sharedLock ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $sqlQuery ]
- }
- }
-
Method [ <internal:phalcon, inherits Phalcon\Db\Dialect, prototype Phalcon\Db\DialectInterface> final public method getColumnList ] {
- Parameters [3] {
@@ -20918,6 +20925,13 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
+ Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method sharedLock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sqlQuery ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\Dialect> public method registerCustomFunction ] {
- Parameters [2] {
@@ -20960,13 +20974,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
- Method [ <internal:phalcon, inherits Phalcon\Db\Dialect, prototype Phalcon\Db\DialectInterface> public method sharedLock ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $sqlQuery ]
- }
- }
-
Method [ <internal:phalcon, inherits Phalcon\Db\Dialect, prototype Phalcon\Db\DialectInterface> final public method getColumnList ] {
- Parameters [3] {
@@ -21452,6 +21459,13 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
+ Method [ <internal:phalcon, overwrites Phalcon\Db\DialectInterface, prototype Phalcon\Db\DialectInterface> public method sharedLock ] {
+
+ - Parameters [1] {
+ Parameter #0 [ <required> $sqlQuery ]
+ }
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Db\Dialect> public method registerCustomFunction ] {
- Parameters [2] {
@@ -21494,13 +21508,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
- Method [ <internal:phalcon, inherits Phalcon\Db\Dialect, prototype Phalcon\Db\DialectInterface> public method sharedLock ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $sqlQuery ]
- }
- }
-
Method [ <internal:phalcon, inherits Phalcon\Db\Dialect, prototype Phalcon\Db\DialectInterface> final public method getColumnList ] {
- Parameters [3] {
@@ -33449,6 +33456,12 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
- Methods [12] {
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\MessageInterface> public method getType ] {
+ }
+
+ Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\MessageInterface> public method getMessage ] {
+ }
+
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [5] {
@@ -33467,9 +33480,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
- Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\MessageInterface> public method getType ] {
- }
-
Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\MessageInterface> public method setMessage ] {
- Parameters [1] {
@@ -33477,9 +33487,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
}
}
- Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\MessageInterface> public method getMessage ] {
- }
-
Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\MessageInterface> public method setField ] {
- Parameters [1] {
@@ -40486,7 +40493,7 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Property [ <default> protected $_config ]
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -40497,6 +40504,12 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon, overwrites Phalcon\Paginator\AdapterInterface, prototype Phalcon\Paginator\AdapterInterface> public method getPaginate ] {
}
+ Method [ <internal:phalcon> public method paginate ] {
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method setCurrentPage ] {
- Parameters [1] {
@@ -40510,9 +40523,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Parameter #0 [ <required> $limitRows ]
}
}
-
- Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
- }
}
}
@@ -40533,7 +40543,7 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Property [ <default> protected $_config ]
}
- - Methods [5] {
+ - Methods [6] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -40544,6 +40554,12 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon, overwrites Phalcon\Paginator\AdapterInterface, prototype Phalcon\Paginator\AdapterInterface> public method getPaginate ] {
}
+ Method [ <internal:phalcon> public method paginate ] {
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method setCurrentPage ] {
- Parameters [1] {
@@ -40557,9 +40573,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Parameter #0 [ <required> $limitRows ]
}
}
-
- Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
- }
}
}
@@ -40582,7 +40595,7 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Property [ <default> protected $_columns ]
}
- - Methods [8] {
+ - Methods [9] {
Method [ <internal:phalcon, ctor> public method __construct ] {
- Parameters [1] {
@@ -40606,6 +40619,12 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Method [ <internal:phalcon, overwrites Phalcon\Paginator\AdapterInterface, prototype Phalcon\Paginator\AdapterInterface> public method getPaginate ] {
}
+ Method [ <internal:phalcon> public method paginate ] {
+ }
+
+ Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
+ }
+
Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method setCurrentPage ] {
- Parameters [1] {
@@ -40619,9 +40638,6 @@ Extension [ <persistent> extension #191 phalcon version 3.4.1 ] {
Parameter #0 [ <required> $limitRows ]
}
}
-
- Method [ <internal:phalcon, inherits Phalcon\Paginator\Adapter, prototype Phalcon\Paginator\AdapterInterface> public method getLimit ] {
- }
}
}
diff --git a/composer.json b/composer.json
index 970b5e4..e3dfcf2 100644
--- a/composer.json
+++ b/composer.json
@@ -8,27 +8,6 @@
"high load",
"mvc"
],
- "require": {
- "php": ">=5.5"
- },
- "require-dev": {
- "ext-dom": "*",
- "ext-json": "*",
- "ext-libxml": "*",
- "ext-mbstring": "*",
- "ext-xml": "*",
- "doctrine/instantiator": "1.0.5",
- "phpdocumentor/reflection-docblock": "^2.0",
- "phpunit/phpunit": "^4.8",
- "mustache/mustache": "^2.11",
- "twig/twig": "~1.34",
- "predis/predis": "^1.1",
- "codeception/codeception": "^2.3",
- "codeception/verify": "^0.3",
- "codeception/specify": "^0.4",
- "squizlabs/php_codesniffer": "^2.9",
- "phalcon/zephir": "^0.10"
- },
"license": "BSD-3-Clause",
"authors": [
{
@@ -41,24 +20,46 @@
"homepage": "https://github.com/phalcon/cphalcon/graphs/contributors"
}
],
+ "require": {
+ "php": ">=5.5",
+ "ext-apcu": "*",
+ "ext-dom": "*",
+ "ext-json": "*",
+ "ext-libxml": "*",
+ "ext-mbstring": "*",
+ "ext-pdo": "*",
+ "ext-xml": "*"
+ },
+ "require-dev": {
+ "codeception/codeception": "^2.3",
+ "codeception/specify": "^0.4",
+ "codeception/verify": "^0.3",
+ "doctrine/instantiator": "1.0.5",
+ "mustache/mustache": "^2.11",
+ "phpdocumentor/reflection-docblock": "^2.0",
+ "phpunit/phpunit": "^4.8 || ^5.7",
+ "predis/predis": "^1.1",
+ "squizlabs/php_codesniffer": "^3.3",
+ "twig/twig": "~1.34"
+ },
"autoload-dev": {
"psr-4": {
"Zephir\\Optimizers\\": "optimizers/",
"Phalcon\\Test\\Unit\\": "tests/unit/",
- "Phalcon\\Test\\Unit5x\\": "tests/unit5x/",
"Phalcon\\Test\\Integration\\": "tests/integration/",
"Phalcon\\Test\\Module\\": "tests/_support/Module/",
- "Phalcon\\Test\\Listener\\": "tests/_data/listener/"
+ "Phalcon\\Test\\Listener\\": "tests/_data/listener/",
+ "Phalcon\\Test\\Db\\": "tests/_data/db/"
}
},
"support": {
+ "email": "support@phalconphp.com",
"issues": "https://github.com/phalcon/cphalcon/issues",
- "source": "https://github.com/phalcon/cphalcon",
"forum": "https://forum.phalconphp.com/",
- "docs": "https://docs.phalconphp.com/",
"wiki": "https://github.com/phalcon/cphalcon/wiki",
"irc": "irc://irc.freenode.org/phalconphp",
- "rss" : "https://blog.phalconphp.com/rss",
- "email": "support@phalconphp.com"
+ "source": "https://github.com/phalcon/cphalcon",
+ "docs": "https://docs.phalconphp.com/",
+ "rss": "https://blog.phalconphp.com/rss"
}
}
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index 2db200f..fbcbe8f 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -17,14 +17,14 @@
%global pkg_name %{name}
%endif
-%global gh_commit caeac66e7db02fd54c44a27cf22a6381654af2ee
+%global gh_commit 2f55ebb91a37cdcd2bc0709c0cb313dc139bf91c
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
%global with_zts 0%{!?_without_zts:%{?__ztsphp:1}}
%global with_tests 0%{?_with_tests:1}
%global ext_name phalcon
-%global zephir_min 0.10.12
+%global zephir_min 0.10.14
%global zephir_max 0.11
%if "%{php_version}" < "5.6"
# after pdo.ini, json.ini, igbinary.ini
@@ -35,8 +35,8 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.4.1
-Release: 3%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.4.2
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
Group: Development/Libraries
@@ -149,6 +149,9 @@ extension=%{ext_name}.so
;phalcon.orm.disable_assign_setters = '0'
EOF
+: Check Zephir version
+grep PHP_PHALCON_ZEPVERSION ext/php_phalcon.h
+
%build
%{?dtsenable}
@@ -262,6 +265,9 @@ REPORT_EXIT_STATUS=1 \
%changelog
+* Mon Dec 3 2018 Remi Collet <remi@remirepo.net> - 3.4.2-1
+- update to 3.4.2 using zephir 0.10.14
+
* Sat Oct 20 2018 Remi Collet <remi@remirepo.net> - 3.4.1-3
- rebuild with zephir 0.10.12 for PHP 7.3