summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
-rw-r--r--REFLECTION89
-rw-r--r--php-phalcon3.spec11
2 files changed, 53 insertions, 47 deletions
diff --git a/REFLECTION b/REFLECTION
index fee721d..7fa2eaa 100644
--- a/REFLECTION
+++ b/REFLECTION
@@ -1,4 +1,4 @@
-Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
+Extension [ <persistent> extension #142 phalcon version 3.0.1 ] {
- INI {
Entry [ phalcon.db.escape_identifiers <ALL> ]
@@ -2896,6 +2896,32 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
}
}
+ Interface [ <internal:phalcon> interface Phalcon\Acl\ResourceInterface ] {
+
+ - Constants [0] {
+ }
+
+ - Static properties [0] {
+ }
+
+ - Static methods [0] {
+ }
+
+ - Properties [0] {
+ }
+
+ - Methods [3] {
+ Method [ <internal:phalcon> abstract public method getName ] {
+ }
+
+ Method [ <internal:phalcon> abstract public method getDescription ] {
+ }
+
+ Method [ <internal:phalcon> abstract public method __toString ] {
+ }
+ }
+ }
+
Interface [ <internal:phalcon> interface Phalcon\Acl\RoleInterface ] {
- Constants [0] {
@@ -6630,32 +6656,6 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
}
}
- Interface [ <internal:phalcon> interface Phalcon\Acl\ResourceInterface ] {
-
- - Constants [0] {
- }
-
- - Static properties [0] {
- }
-
- - Static methods [0] {
- }
-
- - Properties [0] {
- }
-
- - Methods [3] {
- Method [ <internal:phalcon> abstract public method getName ] {
- }
-
- Method [ <internal:phalcon> abstract public method getDescription ] {
- }
-
- Method [ <internal:phalcon> abstract public method __toString ] {
- }
- }
- }
-
Interface [ <internal:phalcon> interface Phalcon\Acl\RoleAware ] {
- Constants [0] {
@@ -12340,7 +12340,7 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
}
}
- Class [ <internal:phalcon> class Phalcon\Acl\Resource ] {
+ Class [ <internal:phalcon> class Phalcon\Acl\Resource implements Phalcon\Acl\ResourceInterface ] {
- Constants [0] {
}
@@ -12357,13 +12357,13 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
}
- Methods [4] {
- Method [ <internal:phalcon> public method getName ] {
+ Method [ <internal:phalcon, prototype Phalcon\Acl\ResourceInterface> public method getName ] {
}
- Method [ <internal:phalcon> public method __toString ] {
+ Method [ <internal:phalcon, prototype Phalcon\Acl\ResourceInterface> public method __toString ] {
}
- Method [ <internal:phalcon> public method getDescription ] {
+ Method [ <internal:phalcon, prototype Phalcon\Acl\ResourceInterface> public method getDescription ] {
}
Method [ <internal:phalcon, ctor> public method __construct ] {
@@ -16495,8 +16495,9 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
- Methods [12] {
Method [ <internal:phalcon, overwrites Phalcon\Config, ctor> public method __construct ] {
- - Parameters [1] {
+ - Parameters [2] {
Parameter #0 [ <required> $filePath ]
+ Parameter #1 [ <optional> $mode ]
}
}
@@ -30087,7 +30088,7 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
Property [ <default> protected $_snapshot ]
}
- - Methods [78] {
+ - Methods [77] {
Method [ <internal:phalcon, ctor> final public method __construct ] {
- Parameters [3] {
@@ -30525,13 +30526,6 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
}
}
- Method [ <internal:phalcon> final protected method _isVisible ] {
-
- - Parameters [1] {
- Parameter #0 [ <required> $property ]
- }
- }
-
Method [ <internal:phalcon> public method __get ] {
- Parameters [1] {
@@ -30975,13 +30969,14 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
- Static methods [0] {
}
- - Properties [24] {
+ - Properties [25] {
Property [ <default> protected $_dependencyInjector ]
Property [ <default> protected $_eventsManager ]
Property [ <default> protected $_customEventsManager ]
Property [ <default> protected $_readConnectionServices ]
Property [ <default> protected $_writeConnectionServices ]
Property [ <default> protected $_aliases ]
+ Property [ <default> protected $_modelVisibility ]
Property [ <default> protected $_hasMany ]
Property [ <default> protected $_hasManySingle ]
Property [ <default> protected $_hasOne ]
@@ -31002,7 +30997,7 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
Property [ <default> protected $_namespaceAliases ]
}
- - Methods [62] {
+ - Methods [63] {
Method [ <internal:phalcon, prototype Phalcon\Di\InjectionAwareInterface> public method setDI ] {
- Parameters [1] {
@@ -31071,6 +31066,14 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
}
}
+ Method [ <internal:phalcon> final public method isVisibleModelProperty ] {
+
+ - Parameters [2] {
+ Parameter #0 [ <required> Phalcon\Mvc\ModelInterface $model ]
+ Parameter #1 [ <required> $property ]
+ }
+ }
+
Method [ <internal:phalcon, prototype Phalcon\Mvc\Model\ManagerInterface> public method getModelSource ] {
- Parameters [1] {
@@ -40674,7 +40677,7 @@ Extension [ <persistent> extension #140 phalcon version 3.0.0 ] {
}
}
- Method [ <internal:phalcon> private method getOptionsDefault ] {
+ Method [ <internal:phalcon> protected method getOptionsDefault ] {
}
Method [ <internal:phalcon, inherits Phalcon\Translate\Adapter> public method setInterpolator ] {
diff --git a/php-phalcon3.spec b/php-phalcon3.spec
index d8c594b..aad5634 100644
--- a/php-phalcon3.spec
+++ b/php-phalcon3.spec
@@ -17,7 +17,7 @@
%global pkg_name %{name}
%endif
-%global gh_commit 5372ac7972218b10fd9f08027a7718ea10f191b5
+%global gh_commit 23b4100faa3ef91863d7f05de3f1c7a450cd52bc
%global gh_short %(c=%{gh_commit}; echo ${c:0:7})
%global gh_owner phalcon
%global gh_project cphalcon
@@ -33,8 +33,8 @@
%endif
Name: %{?sub_prefix}php-phalcon3
-Version: 3.0.0
-Release: 2%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
+Version: 3.0.1
+Release: 1%{?dist}%{!?scl:%{!?nophptag:%(%{__php} -r 'echo ".".PHP_MAJOR_VERSION.".".PHP_MINOR_VERSION;')}}
Summary: Phalcon Framework
Group: Development/Libraries
@@ -249,12 +249,15 @@ rm -rf %{buildroot}
%changelog
+* Fri Sep 2 2016 Remi Collet <remi@fedoraproject.org> - 3.0.1-1
+- update to 3.0.1
+
* Sat Jul 30 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-2
- generate sources using zephir
* Sat Jul 30 2016 Remi Collet <remi@fedoraproject.org> - 3.0.0-1
- update to 3.0.0
-- rename to php-phalcon2
+- rename to php-phalcon3
- PHP 7 build is broken for now
open https://github.com/phalcon/cphalcon/issues/12054